aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/blt
diff options
context:
space:
mode:
authorKenjiro Cho <kjc@FreeBSD.org>2003-10-22 10:16:00 +0000
committerKenjiro Cho <kjc@FreeBSD.org>2003-10-22 10:16:00 +0000
commit8a267b58025f68c6add3a6cf423a4ecc1b0bf987 (patch)
treeb320147c62ec6c663b20114739aab2b4bc1b4c47 /x11-toolkits/blt
parentb6bd1195158e60284457f4cc9b5b0a046220e03a (diff)
downloadports-8a267b58025f68c6add3a6cf423a4ecc1b0bf987.tar.gz
ports-8a267b58025f68c6add3a6cf423a4ecc1b0bf987.zip
Notes
Diffstat (limited to 'x11-toolkits/blt')
-rw-r--r--x11-toolkits/blt/Makefile40
-rw-r--r--x11-toolkits/blt/distinfo3
-rw-r--r--x11-toolkits/blt/files/patch-aa35
-rw-r--r--x11-toolkits/blt/files/patch-ab24
-rw-r--r--x11-toolkits/blt/pkg-descr7
-rw-r--r--x11-toolkits/blt/pkg-plist40
6 files changed, 96 insertions, 53 deletions
diff --git a/x11-toolkits/blt/Makefile b/x11-toolkits/blt/Makefile
index 4a8f715d7bf2..5f86a3214bfe 100644
--- a/x11-toolkits/blt/Makefile
+++ b/x11-toolkits/blt/Makefile
@@ -6,38 +6,50 @@
#
PORTNAME= blt
-PORTVERSION= 2.4u
-CATEGORIES= x11-toolkits tk83
-MASTER_SITES= ftp://tcltk.sourceforge.net/pub/tcltk/blt/ \
+PORTVERSION= 2.4z
+CATEGORIES= x11-toolkits tk84
+MASTER_SITES= ftp://ftp.sourceforge.net/blt/ \
ftp://ftp.csl.sony.co.jp/pub/kjc/ttt-libs/
DISTNAME= BLT${PORTVERSION}
+PATCH_SITES= ftp://ftp.sourceforge.net/blt/ \
+ ftp://ftp.csl.sony.co.jp/pub/kjc/ttt-libs/
+PATCHFILES= blt2.4z-patch-2
+PATCH_DIST_STRIP= -p1
+
MAINTAINER= kjc@csl.sony.co.jp
COMMENT= A Tk extension (with shared libs)
-LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
+LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
-WRKSRC= ${WRKDIR}/blt2.4u
+WRKSRC= ${WRKDIR}/blt2.4z
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
- --with-tcl=${LOCALBASE}/lib/tcl8.3 \
- --with-tk=${LOCALBASE}/lib/tk8.3 \
+ --exec_prefix=${PREFIX} \
+ --with-tcl=${LOCALBASE}/lib/tcl${TK_VER} \
+ --with-tk=${LOCALBASE}/lib/tk${TK_VER} \
--with-tcllibs=${LOCALBASE}/lib/ \
--with-tklibs=${LOCALBASE}/lib/ \
- --with-tclincls=${LOCALBASE}/include/tcl8.3 \
- --with-tkincls=${LOCALBASE}/include/tk8.3
+ --with-tclincls=${LOCALBASE}/include/tcl${TK_VER} \
+ --with-tkincls=${LOCALBASE}/include/tk${TK_VER}
INSTALLS_SHLIB= yes
MANN= BLT.n barchart.n beep.n bgexec.n bitmap.n \
- bltdebug.n busy.n cutbuffer.n dragdrop.n eps.n \
+ bltdebug.n busy.n container.n cutbuffer.n dragdrop.n eps.n \
graph.n hierbox.n hiertable.n htext.n spline.n \
- stripchart.n table.n tabset.n tile.n vector.n \
- watch.n winop.n
+ stripchart.n table.n tabset.n tree.n treeview.n tile.n \
+ vector.n watch.n winop.n
+MAN3= Blt_Tree.3 Blt_TreeCreate.3 Blt_TreeCreateNode.3 \
+ Blt_TreeDeleteNode.3 Blt_TreeExists.3 Blt_TreeGetNode.3 \
+ Blt_TreeGetToken.3 Blt_TreeName.3 Blt_TreeNodeId.3 \
+ Blt_TreeReleaseToken.3
+
+TK_VER?= 8.4
.include <bsd.port.pre.mk>
post-install:
- ${LN} -sf libBLT24.so.2 ${PREFIX}/lib/libBLT24.so
- ${LN} -sf libBLTlite24.so.2 ${PREFIX}/lib/libBLTlite24.so
+ ${LN} -sf libBLT24.so.3 ${PREFIX}/lib/libBLT24.so
+ ${LN} -sf libBLTlite24.so.3 ${PREFIX}/lib/libBLTlite24.so
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/blt/distinfo b/x11-toolkits/blt/distinfo
index aa4f2413b957..69227fe935a2 100644
--- a/x11-toolkits/blt/distinfo
+++ b/x11-toolkits/blt/distinfo
@@ -1 +1,2 @@
-MD5 (BLT2.4u.tar.gz) = bad9f33789a6aac390cebba819ee6b38
+MD5 (BLT2.4z.tar.gz) = aa2ed73080f3005d9c2a3b5e57ab1eff
+MD5 (blt2.4z-patch-2) = 0cebd9fdf8141fe3858742886eb8fa19
diff --git a/x11-toolkits/blt/files/patch-aa b/x11-toolkits/blt/files/patch-aa
index e02f71c05fa8..6d169b341160 100644
--- a/x11-toolkits/blt/files/patch-aa
+++ b/x11-toolkits/blt/files/patch-aa
@@ -1,60 +1,61 @@
---- configure.orig Fri Jun 23 09:40:05 2000
-+++ configure Tue Dec 19 21:17:39 2000
-@@ -1140,7 +1140,7 @@
+--- configure.orig Thu Aug 28 15:41:03 2003
++++ configure Thu Aug 28 15:49:25 2003
+@@ -1202,7 +1202,7 @@
#
# 1. command line (--with-cflags)
# 2. cached variable ($blt_cv_prog_cflags)
--# 3. set to "-O6" if using gcc ($BLT_HAVE_GCC)
-+# 3. set to "-O2" if using gcc ($BLT_HAVE_GCC)
+-# 3. set to "-O6" if using gcc ($blt_have_gcc)
++# 3. set to "-O2" if using gcc ($blt_have_gcc)
# 4. otherwise, default to "-O"
#
echo $ac_n "checking default compiler flags""... $ac_c" 1>&6
-@@ -1150,7 +1150,7 @@
+@@ -1212,7 +1212,7 @@
elif test "x${blt_cv_prog_cflags}" != "x" ; then
CFLAGS=${blt_cv_prog_cflags}
- elif test "${BLT_HAVE_GCC}" = "yes" ; then
+ elif test "${blt_have_gcc}" = "yes" ; then
- CFLAGS=-O6
+ CFLAGS=-O2
else
CFLAGS=-O
fi
-@@ -2572,6 +2572,7 @@
- if test "x$tclConfigFile" = "x" ; then
+@@ -3197,6 +3197,7 @@
+ if test "x$tcl_config_sh" = "x" ; then
for dir in \
`ls -dr /usr/local/tcl/tcl[7-9].[0-9]* 2>/dev/null` \
+ `ls -dr /usr/local/lib/tcl[7-9].[0-9]* 2>/dev/null` \
/usr/local/tcl \
/usr/local \
/usr
-@@ -2672,6 +2673,7 @@
- if test "x$tkConfigFile" = "x" ; then
+@@ -3295,6 +3296,7 @@
+ if test "x$tk_config_sh" = "x" ; then
for dir in \
`ls -dr /usr/local/tcl/tcl[7-9].[0-9]* 2>/dev/null` \
+ `ls -dr /usr/local/lib/tk[7-9].[0-9]* 2>/dev/null` \
/usr/local/tcl \
/usr/local \
${x_libraries} \
-@@ -2776,7 +2778,7 @@
+@@ -3379,7 +3381,7 @@
fi
case $target in
-- *-sunos4*|*-*-netbsd|NetBSD-*|FreeBSD-*|OpenBSD-*)
-+ *-sunos4*|*-*-netbsd|NetBSD-*|*-*-freebsd*|OpenBSD-*)
+- *-sunos4*|*-*-netbsd|NetBSD-*|FreeBSD-*|OpenBSD-*|*-*-cygwin*|*-*-mingw*)
++ *-sunos4*|*-*-netbsd|NetBSD-*|*-*-freebsd*|OpenBSD-*|*-*-cygwin*|*-*-mingw*)
TCL_LIB_NAME="tcl${TCL_MAJOR_VERSION}${TCL_MINOR_VERSION}"
TK_LIB_NAME="tk${TK_MAJOR_VERSION}${TK_MINOR_VERSION}"
;;
-@@ -3597,7 +3599,13 @@
+@@ -4111,7 +4113,14 @@
if test "$test_ok" = yes; then
SHLIB_CFLAGS="-fpic"
SHLIB_LD="ld"
- SHLIB_LD_FLAGS="-Bshareable -x"
+ if test `objformat` = "elf"; then
+ SHLIB_LD_FLAGS="-Bshareable -x -soname \$@"
-+ SHLIB_SUFFIX=".so.${BLT_MAJOR_VERSION}"
++ SHLIB_SUFFIX=".so.3"
+ else
+ SHLIB_LD_FLAGS="-Bshareable -x"
-+ SHLIB_SUFFIX=".so.${BLT_MAJOR_VERSION}.${BLT_MINOR_VERSION}"
++ SHLIB_SUFFIX=".so.3.0"
+ fi
++
fi
;;
diff --git a/x11-toolkits/blt/files/patch-ab b/x11-toolkits/blt/files/patch-ab
new file mode 100644
index 000000000000..0d6322527342
--- /dev/null
+++ b/x11-toolkits/blt/files/patch-ab
@@ -0,0 +1,24 @@
+--- src/bltTree.c.orig Sun Sep 29 07:44:12 2002
++++ src/bltTree.c Mon Oct 13 13:16:45 2003
+@@ -96,16 +96,16 @@
+
+ #define REBUILD_MULTIPLIER 3
+
+-#if (SIZEOF_VOID_P == 8)
+-#define RANDOM_INDEX(i) HashOneWord(mask, downshift, i)
+-#define BITSPERWORD 64
+-#else
+-
+ #define START_LOGSIZE 5 /* Initial hash table size is 32. */
+ #define MAX_LIST_VALUES 20 /* Convert to hash table when node
+ * value list gets bigger than this
+ * many values. */
+
++
++#if (SIZEOF_VOID_P == 8)
++#define RANDOM_INDEX(i) HashOneWord(mask, downshift, i)
++#define BITSPERWORD 64
++#else
+ /*
+ * The following macro takes a preliminary integer hash value and
+ * produces an index into a hash tables bucket list. The idea is
diff --git a/x11-toolkits/blt/pkg-descr b/x11-toolkits/blt/pkg-descr
index f242b8023cb6..ab675fc9f4b2 100644
--- a/x11-toolkits/blt/pkg-descr
+++ b/x11-toolkits/blt/pkg-descr
@@ -1,7 +1,6 @@
-This is version 2.4u of the BLT library. BLT is an extension to the Tk
-toolkit, adding new widgets, geometry managers, and miscellaneous
-commands. It does not require any patching of the Tcl or Tk source
-files.
+The BLT Toolkit is an extension to Tcl and Tk. It adds new commands
+and widgets to the Tcl interpreter. Included widgets are 2D graph,
+barchart, stripchart, tab notebook, and tree viewer.
NOTE: This kit requires as a pre-requisite the Tcl and Tk binary kits.
This version uses FreeBSD shared libraries.
diff --git a/x11-toolkits/blt/pkg-plist b/x11-toolkits/blt/pkg-plist
index 690d644f87fc..4082caf0afaf 100644
--- a/x11-toolkits/blt/pkg-plist
+++ b/x11-toolkits/blt/pkg-plist
@@ -3,29 +3,18 @@ bin/bltsh24
bin/bltwish
bin/bltwish24
include/blt.h
+include/bltBind.h
include/bltChain.h
+include/bltHash.h
+include/bltList.h
+include/bltPool.h
include/bltTree.h
include/bltVector.h
-lib/libBLT.a
-lib/libBLT24.a
-lib/libBLT24.so
-lib/libBLT24.so.2
-lib/libBLTlite.a
-lib/libBLTlite24.a
-lib/libBLTlite24.so
-lib/libBLTlite24.so.2
lib/blt2.4/NEWS
lib/blt2.4/PROBLEMS
lib/blt2.4/README
lib/blt2.4/bltCanvEps.pro
-lib/blt2.4/bltDnd.tcl
-lib/blt2.4/bltDragdrop.tcl
lib/blt2.4/bltGraph.pro
-lib/blt2.4/bltGraph.tcl
-lib/blt2.4/bltHierbox.tcl
-lib/blt2.4/bltHiertable.tcl
-lib/blt2.4/bltTabnotebook.tcl
-lib/blt2.4/bltTabset.tcl
lib/blt2.4/dd_protocols/dd-color.tcl
lib/blt2.4/dd_protocols/dd-file.tcl
lib/blt2.4/dd_protocols/dd-number.tcl
@@ -159,11 +148,28 @@ lib/blt2.4/demos/tabset1.tcl
lib/blt2.4/demos/tabset2.tcl
lib/blt2.4/demos/tabset3.tcl
lib/blt2.4/demos/tabset4.tcl
+lib/blt2.4/demos/treeview1.tcl
lib/blt2.4/demos/winop1.tcl
-lib/blt2.4/htresize.xbm
-lib/blt2.4/htresize_m.xbm
+lib/blt2.4/demos/winop2.tcl
+lib/blt2.4/dnd.tcl
+lib/blt2.4/dragdrop.tcl
+lib/blt2.4/graph.tcl
+lib/blt2.4/hierbox.tcl
lib/blt2.4/pkgIndex.tcl
+lib/blt2.4/tabnotebook.tcl
+lib/blt2.4/tabset.tcl
lib/blt2.4/tclIndex
+lib/blt2.4/treeview.tcl
+lib/blt2.4/treeview.xbm
+lib/blt2.4/treeview_m.xbm
+lib/libBLT.a
+lib/libBLT24.a
+lib/libBLT24.so
+lib/libBLT24.so.3
+lib/libBLTlite.a
+lib/libBLTlite24.a
+lib/libBLTlite24.so
+lib/libBLTlite24.so.3
@dirrm lib/blt2.4/demos/scripts
@dirrm lib/blt2.4/demos/images
@dirrm lib/blt2.4/demos/bitmaps/hand