aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/eel/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-24 23:07:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-24 23:07:37 +0000
commit8fdaf5d1e795b23d80ea3ed362013506875dd423 (patch)
tree943f8ae1cfe5271ac8a1c3c96c01a5e00d65fd8f /x11-toolkits/eel/Makefile
parent177a3b9143f2b0e425e411616b63d95a1cc4ad20 (diff)
downloadports-8fdaf5d1e795b23d80ea3ed362013506875dd423.tar.gz
ports-8fdaf5d1e795b23d80ea3ed362013506875dd423.zip
Notes
Diffstat (limited to 'x11-toolkits/eel/Makefile')
-rw-r--r--x11-toolkits/eel/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-toolkits/eel/Makefile b/x11-toolkits/eel/Makefile
new file mode 100644
index 000000000000..c6650ed0abba
--- /dev/null
+++ b/x11-toolkits/eel/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: eel2
+# Date created: 8th May 2001
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eel
+PORTVERSION= 2.8.2
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.8
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Generally useful classes and extensions to GNOME
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix gnomehack gnomehier gnomevfs2 gail libgnomeui
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-shared --enable-static
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ ${WRKSRC}/eel/eel-open-with-dialog.c
+
+.include <bsd.port.mk>