aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/eel2/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2001-05-08 18:58:23 +0000
committerAde Lovett <ade@FreeBSD.org>2001-05-08 18:58:23 +0000
commit92abd7971a1eb5a22da79d946e3d1b061555d6b7 (patch)
treefe5bba6a17df4c4ff73ea7ef247d79ae9b0935c1 /x11-toolkits/eel2/Makefile
parentea31e74b858bdea9616c7b2e3907c1f153e74bcc (diff)
downloadports-92abd7971a1eb5a22da79d946e3d1b061555d6b7.tar.gz
ports-92abd7971a1eb5a22da79d946e3d1b061555d6b7.zip
Notes
Diffstat (limited to 'x11-toolkits/eel2/Makefile')
-rw-r--r--x11-toolkits/eel2/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-toolkits/eel2/Makefile b/x11-toolkits/eel2/Makefile
new file mode 100644
index 000000000000..77d9a85d6f14
--- /dev/null
+++ b/x11-toolkits/eel2/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: eel
+# Date created: 8th May 2001
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eel
+PORTVERSION= 1.0
+CATEGORIES= graphics gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= stable/sources/librsvg
+
+MAINTAINER= ade@FreeBSD.org
+
+BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2 # XXX
+LIB_DEPENDS= rsvg.1:${PORTSDIR}/graphics/librsvg
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ARGS= --enable-shared --enable-static
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>