aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/eel
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
commit6f32add9a75efb180e462ffbdb0b080bc88088e3 (patch)
tree0fc7af36e22fc0dc7c1dc8aacabf6fe117e881da /x11-toolkits/eel
parentb8d245fedd5842fb6d68d0bdc6539885555a84e3 (diff)
Notes
Diffstat (limited to 'x11-toolkits/eel')
-rw-r--r--x11-toolkits/eel/Makefile16
-rw-r--r--x11-toolkits/eel/distinfo6
-rw-r--r--x11-toolkits/eel/files/patch-eel_eel-open-with-dialog.c52
-rw-r--r--x11-toolkits/eel/pkg-plist10
4 files changed, 13 insertions, 71 deletions
diff --git a/x11-toolkits/eel/Makefile b/x11-toolkits/eel/Makefile
index 41f8f44c5f63..046b5293d833 100644
--- a/x11-toolkits/eel/Makefile
+++ b/x11-toolkits/eel/Makefile
@@ -3,14 +3,13 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11-toolkits/eel/Makefile,v 1.60 2007/09/18 14:12:45 ahze Exp $
+# $MCom: ports/x11-toolkits/eel/Makefile,v 1.67 2008/03/10 21:38:32 mezz Exp $
#
PORTNAME= eel
-PORTVERSION= 2.20.0
+PORTVERSION= 2.22.0
CATEGORIES= x11-toolkits gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -19,18 +18,13 @@ COMMENT= Generally useful classes and extensions to GNOME
USE_GETTEXT= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_XLIB= yes
+USE_XORG= xrender
GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomehack gail gnomedesktop gnomemenus ltverhack
+USE_GNOME= gnomeprefix gnomehack gail gnomedesktop ltverhack intlhack
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-shared --enable-static
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-post-patch:
- @${REINPLACE_CMD} -e 's|applications.menu|gnome-applications.menu|; \
- s|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${WRKSRC}/eel/eel-open-with-dialog.c
-
.include <bsd.port.mk>
diff --git a/x11-toolkits/eel/distinfo b/x11-toolkits/eel/distinfo
index 24738bf2d84b..838be7cde287 100644
--- a/x11-toolkits/eel/distinfo
+++ b/x11-toolkits/eel/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/eel-2.20.0.tar.bz2) = 691734dc1078e05e726b4f5b8646dadf
-SHA256 (gnome2/eel-2.20.0.tar.bz2) = ba35db646ce069ee66a92fa95d10aff583e00e6039b1b5bb0fa6036742fddd70
-SIZE (gnome2/eel-2.20.0.tar.bz2) = 647919
+MD5 (gnome2/eel-2.22.0.tar.bz2) = cd0db25194c154f07c39b45ca5943999
+SHA256 (gnome2/eel-2.22.0.tar.bz2) = 09258b129d1cf805b56bfbbfc19798d158fa8001594d0f807e23562805581331
+SIZE (gnome2/eel-2.22.0.tar.bz2) = 606502
diff --git a/x11-toolkits/eel/files/patch-eel_eel-open-with-dialog.c b/x11-toolkits/eel/files/patch-eel_eel-open-with-dialog.c
deleted file mode 100644
index 09270d77cacc..000000000000
--- a/x11-toolkits/eel/files/patch-eel_eel-open-with-dialog.c
+++ /dev/null
@@ -1,52 +0,0 @@
---- eel/eel-open-with-dialog.c.orig Mon Mar 21 06:25:51 2005
-+++ eel/eel-open-with-dialog.c Mon Mar 21 06:39:29 2005
-@@ -422,7 +422,7 @@
- gtk_file_chooser_set_select_multiple (GTK_FILE_CHOOSER (chooser),
- FALSE);
- gtk_file_chooser_set_current_folder (GTK_FILE_CHOOSER (chooser),
-- "/usr/bin");
-+ "%%LOCALBASE%%/bin");
-
- gtk_widget_show (chooser);
- }
-@@ -452,10 +452,13 @@
- char *file;
- gboolean long_operation;
-
-+ GDK_THREADS_ENTER ();
-+
- long_operation = FALSE;
- do {
- if (!dialog->details->add_icon_paths) {
- dialog->details->add_icons_idle_id = 0;
-+ GDK_THREADS_LEAVE ();
- return FALSE;
- }
-
-@@ -508,6 +511,8 @@
- /* don't go back into the main loop if this wasn't very hard to do */
- } while (!long_operation);
-
-+ GDK_THREADS_LEAVE ();
-+
- return TRUE;
- }
-
-@@ -575,6 +580,8 @@
- GSList *l;
- const char *prev_name;
-
-+ GDK_THREADS_ENTER ();
-+
- /* create list store */
- dialog->details->program_list_store = gtk_list_store_new (NUM_COLUMNS,
- GDK_TYPE_PIXBUF,
-@@ -633,6 +640,8 @@
- NULL);
-
- gtk_tree_view_append_column (GTK_TREE_VIEW (dialog->details->program_list), column);
-+
-+ GDK_THREADS_LEAVE ();
-
- dialog->details->add_icon_paths = g_slist_reverse (dialog->details->add_icon_paths);
-
diff --git a/x11-toolkits/eel/pkg-plist b/x11-toolkits/eel/pkg-plist
index fac1807dce3c..8316a352c40a 100644
--- a/x11-toolkits/eel/pkg-plist
+++ b/x11-toolkits/eel/pkg-plist
@@ -1,5 +1,6 @@
include/eel-2/eel/eel-accessibility.h
include/eel-2/eel/eel-alert-dialog.h
+include/eel-2/eel/eel-app-launch-context.h
include/eel-2/eel/eel-art-extensions.h
include/eel-2/eel/eel-art-gtk-extensions.h
include/eel-2/eel/eel-background-box.h
@@ -7,7 +8,6 @@ include/eel-2/eel/eel-background.h
include/eel-2/eel/eel-canvas-rect-ellipse.h
include/eel-2/eel/eel-canvas-util.h
include/eel-2/eel/eel-canvas.h
-include/eel-2/eel/eel-dateedit-extensions.h
include/eel-2/eel/eel-debug-drawing.h
include/eel-2/eel/eel-debug.h
include/eel-2/eel/eel-editable-label.h
@@ -26,15 +26,12 @@ include/eel-2/eel/eel-i18n.h
include/eel-2/eel/eel-image-table.h
include/eel-2/eel/eel-labeled-image.h
include/eel-2/eel/eel-marshal.h
-include/eel-2/eel/eel-mime-application-chooser.h
-include/eel-2/eel/eel-mime-extensions.h
-include/eel-2/eel/eel-open-with-dialog.h
+include/eel-2/eel/eel-mount-operation.h
include/eel-2/eel/eel-pango-extensions.h
include/eel-2/eel/eel-preferences-glade.h
include/eel-2/eel/eel-preferences.h
include/eel-2/eel/eel-self-checks.h
include/eel-2/eel/eel-stock-dialogs.h
-include/eel-2/eel/eel-string-list.h
include/eel-2/eel/eel-string.h
include/eel-2/eel/eel-type-builtins.h
include/eel-2/eel/eel-types.h
@@ -50,6 +47,7 @@ libdata/pkgconfig/eel-2.0.pc
share/locale/am/LC_MESSAGES/eel-2.0.mo
share/locale/ang/LC_MESSAGES/eel-2.0.mo
share/locale/ar/LC_MESSAGES/eel-2.0.mo
+share/locale/as/LC_MESSAGES/eel-2.0.mo
share/locale/az/LC_MESSAGES/eel-2.0.mo
share/locale/be/LC_MESSAGES/eel-2.0.mo
share/locale/bg/LC_MESSAGES/eel-2.0.mo
@@ -151,5 +149,7 @@ share/locale/zh_TW/LC_MESSAGES/eel-2.0.mo
@dirrmtry share/locale/dz
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as
@dirrmtry share/locale/ang/LC_MESSAGES
@dirrmtry share/locale/ang