aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/eel
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-24 23:07:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-24 23:07:37 +0000
commit8fdaf5d1e795b23d80ea3ed362013506875dd423 (patch)
tree943f8ae1cfe5271ac8a1c3c96c01a5e00d65fd8f /x11-toolkits/eel
parent177a3b9143f2b0e425e411616b63d95a1cc4ad20 (diff)
downloadports-8fdaf5d1e795b23d80ea3ed362013506875dd423.tar.gz
ports-8fdaf5d1e795b23d80ea3ed362013506875dd423.zip
Notes
Diffstat (limited to 'x11-toolkits/eel')
-rw-r--r--x11-toolkits/eel/Makefile33
-rw-r--r--x11-toolkits/eel/distinfo2
-rw-r--r--x11-toolkits/eel/files/patch-Makefile.in14
-rw-r--r--x11-toolkits/eel/files/patch-eel::eel-vfs-extensions.c15
-rw-r--r--x11-toolkits/eel/files/patch-eel_eel-open-with-dialog.c11
-rw-r--r--x11-toolkits/eel/pkg-descr7
-rw-r--r--x11-toolkits/eel/pkg-plist122
7 files changed, 204 insertions, 0 deletions
diff --git a/x11-toolkits/eel/Makefile b/x11-toolkits/eel/Makefile
new file mode 100644
index 000000000000..c6650ed0abba
--- /dev/null
+++ b/x11-toolkits/eel/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: eel2
+# Date created: 8th May 2001
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eel
+PORTVERSION= 2.8.2
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.8
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Generally useful classes and extensions to GNOME
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix gnomehack gnomehier gnomevfs2 gail libgnomeui
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-shared --enable-static
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ ${WRKSRC}/eel/eel-open-with-dialog.c
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/eel/distinfo b/x11-toolkits/eel/distinfo
new file mode 100644
index 000000000000..43f56ccf9a21
--- /dev/null
+++ b/x11-toolkits/eel/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome2/eel-2.8.2.tar.bz2) = 4d0beb2f0ad4c304b49c06b08d0a03e5
+SIZE (gnome2/eel-2.8.2.tar.bz2) = 620939
diff --git a/x11-toolkits/eel/files/patch-Makefile.in b/x11-toolkits/eel/files/patch-Makefile.in
new file mode 100644
index 000000000000..c3cb2f239196
--- /dev/null
+++ b/x11-toolkits/eel/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- Makefile.in 2002/06/13 16:05:09 1.1
++++ Makefile.in 2002/06/13 16:05:18
+@@ -119,7 +119,7 @@
+
+ NULL =
+
+-SUBDIRS = eel test po
++SUBDIRS = eel po
+
+ EXTRA_DIST = COPYING.LIB HACKING MAINTAINERS eel.spec.in $(NULL)
+
diff --git a/x11-toolkits/eel/files/patch-eel::eel-vfs-extensions.c b/x11-toolkits/eel/files/patch-eel::eel-vfs-extensions.c
new file mode 100644
index 000000000000..a71c0f102a7b
--- /dev/null
+++ b/x11-toolkits/eel/files/patch-eel::eel-vfs-extensions.c
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- eel/eel-vfs-extensions.c 2001/12/20 13:41:21 1.1
++++ eel/eel-vfs-extensions.c 2001/12/20 13:47:36
+@@ -116,7 +116,8 @@
+
+ /* Return the file. */
+ *file_size = total_bytes_read;
+- *file_contents = g_realloc (buffer, total_bytes_read);
++ *file_contents = g_realloc (buffer, total_bytes_read + 1);
++ (*file_contents)[total_bytes_read] = '\0';
+ return GNOME_VFS_OK;
+ }
+
diff --git a/x11-toolkits/eel/files/patch-eel_eel-open-with-dialog.c b/x11-toolkits/eel/files/patch-eel_eel-open-with-dialog.c
new file mode 100644
index 000000000000..9512a2703290
--- /dev/null
+++ b/x11-toolkits/eel/files/patch-eel_eel-open-with-dialog.c
@@ -0,0 +1,11 @@
+--- eel/eel-open-with-dialog.c.orig Mon Oct 4 00:30:27 2004
++++ eel/eel-open-with-dialog.c Mon Oct 4 00:30:40 2004
+@@ -380,7 +380,7 @@
+ gtk_file_chooser_set_select_multiple (GTK_FILE_CHOOSER (chooser),
+ FALSE);
+ gtk_file_chooser_set_current_folder (GTK_FILE_CHOOSER (chooser),
+- "/usr/bin");
++ "%%X11BASE%%/bin");
+
+ gtk_widget_show (chooser);
+ }
diff --git a/x11-toolkits/eel/pkg-descr b/x11-toolkits/eel/pkg-descr
new file mode 100644
index 000000000000..4b91eb9d0da3
--- /dev/null
+++ b/x11-toolkits/eel/pkg-descr
@@ -0,0 +1,7 @@
+The eel library contains a number of useful classes and functions which
+extend glib, gtk, gnome-libs, and other widely-used GNOME platform libraries.
+
+Almost all of the eel library was previously part of Nautilus, but is now
+a separate package so it can be used by other applications.
+
+WWW: http://www.gnome.org/
diff --git a/x11-toolkits/eel/pkg-plist b/x11-toolkits/eel/pkg-plist
new file mode 100644
index 000000000000..6af5ffaa2fa3
--- /dev/null
+++ b/x11-toolkits/eel/pkg-plist
@@ -0,0 +1,122 @@
+include/eel-2/eel/eel-accessibility.h
+include/eel-2/eel/eel-alert-dialog.h
+include/eel-2/eel/eel-art-extensions.h
+include/eel-2/eel/eel-art-gtk-extensions.h
+include/eel-2/eel/eel-background-box.h
+include/eel-2/eel/eel-background.h
+include/eel-2/eel/eel-canvas-rect-ellipse.h
+include/eel-2/eel/eel-canvas-util.h
+include/eel-2/eel/eel-canvas.h
+include/eel-2/eel/eel-cell-renderer-pixbuf-list.h
+include/eel-2/eel/eel-dateedit-extensions.h
+include/eel-2/eel/eel-debug-drawing.h
+include/eel-2/eel/eel-debug.h
+include/eel-2/eel/eel-editable-label.h
+include/eel-2/eel/eel-ellipsizing-label.h
+include/eel-2/eel/eel-enumeration.h
+include/eel-2/eel/eel-features.h
+include/eel-2/eel/eel-gconf-extensions.h
+include/eel-2/eel/eel-gdk-extensions.h
+include/eel-2/eel/eel-gdk-pixbuf-extensions.h
+include/eel-2/eel/eel-glib-extensions.h
+include/eel-2/eel/eel-gnome-extensions.h
+include/eel-2/eel/eel-graphic-effects.h
+include/eel-2/eel/eel-gtk-container.h
+include/eel-2/eel/eel-gtk-extensions.h
+include/eel-2/eel/eel-gtk-macros.h
+include/eel-2/eel/eel-i18n.h
+include/eel-2/eel/eel-image-table.h
+include/eel-2/eel/eel-labeled-image.h
+include/eel-2/eel/eel-marshal.h
+include/eel-2/eel/eel-mime-application-chooser.h
+include/eel-2/eel/eel-mime-extensions.h
+include/eel-2/eel/eel-open-with-dialog.h
+include/eel-2/eel/eel-pango-extensions.h
+include/eel-2/eel/eel-preferences-glade.h
+include/eel-2/eel/eel-preferences.h
+include/eel-2/eel/eel-self-checks.h
+include/eel-2/eel/eel-stock-dialogs.h
+include/eel-2/eel/eel-string-list.h
+include/eel-2/eel/eel-string.h
+include/eel-2/eel/eel-type-builtins.h
+include/eel-2/eel/eel-types.h
+include/eel-2/eel/eel-vfs-extensions.h
+include/eel-2/eel/eel-wrap-table.h
+include/eel-2/eel/eel-xml-extensions.h
+include/eel-2/eel/eel.h
+lib/libeel-2.a
+lib/libeel-2.so
+lib/libeel-2.so.10
+libdata/pkgconfig/eel-2.0.pc
+share/locale/am/LC_MESSAGES/eel-2.0.mo
+share/locale/ang/LC_MESSAGES/eel-2.0.mo
+share/locale/ar/LC_MESSAGES/eel-2.0.mo
+share/locale/az/LC_MESSAGES/eel-2.0.mo
+share/locale/be/LC_MESSAGES/eel-2.0.mo
+share/locale/bg/LC_MESSAGES/eel-2.0.mo
+share/locale/bn/LC_MESSAGES/eel-2.0.mo
+share/locale/br/LC_MESSAGES/eel-2.0.mo
+share/locale/bs/LC_MESSAGES/eel-2.0.mo
+share/locale/ca/LC_MESSAGES/eel-2.0.mo
+share/locale/cs/LC_MESSAGES/eel-2.0.mo
+share/locale/cy/LC_MESSAGES/eel-2.0.mo
+share/locale/da/LC_MESSAGES/eel-2.0.mo
+share/locale/de/LC_MESSAGES/eel-2.0.mo
+share/locale/el/LC_MESSAGES/eel-2.0.mo
+share/locale/en_CA/LC_MESSAGES/eel-2.0.mo
+share/locale/en_GB/LC_MESSAGES/eel-2.0.mo
+share/locale/es/LC_MESSAGES/eel-2.0.mo
+share/locale/et/LC_MESSAGES/eel-2.0.mo
+share/locale/eu/LC_MESSAGES/eel-2.0.mo
+share/locale/fa/LC_MESSAGES/eel-2.0.mo
+share/locale/fi/LC_MESSAGES/eel-2.0.mo
+share/locale/fr/LC_MESSAGES/eel-2.0.mo
+share/locale/ga/LC_MESSAGES/eel-2.0.mo
+share/locale/gl/LC_MESSAGES/eel-2.0.mo
+share/locale/gu/LC_MESSAGES/eel-2.0.mo
+share/locale/he/LC_MESSAGES/eel-2.0.mo
+share/locale/hi/LC_MESSAGES/eel-2.0.mo
+share/locale/hr/LC_MESSAGES/eel-2.0.mo
+share/locale/hu/LC_MESSAGES/eel-2.0.mo
+share/locale/id/LC_MESSAGES/eel-2.0.mo
+share/locale/is/LC_MESSAGES/eel-2.0.mo
+share/locale/it/LC_MESSAGES/eel-2.0.mo
+share/locale/ja/LC_MESSAGES/eel-2.0.mo
+share/locale/kn/LC_MESSAGES/eel-2.0.mo
+share/locale/ko/LC_MESSAGES/eel-2.0.mo
+share/locale/li/LC_MESSAGES/eel-2.0.mo
+share/locale/lt/LC_MESSAGES/eel-2.0.mo
+share/locale/lv/LC_MESSAGES/eel-2.0.mo
+share/locale/mk/LC_MESSAGES/eel-2.0.mo
+share/locale/ml/LC_MESSAGES/eel-2.0.mo
+share/locale/mn/LC_MESSAGES/eel-2.0.mo
+share/locale/mr/LC_MESSAGES/eel-2.0.mo
+share/locale/ms/LC_MESSAGES/eel-2.0.mo
+share/locale/nb/LC_MESSAGES/eel-2.0.mo
+share/locale/ne/LC_MESSAGES/eel-2.0.mo
+share/locale/nl/LC_MESSAGES/eel-2.0.mo
+share/locale/nn/LC_MESSAGES/eel-2.0.mo
+share/locale/no/LC_MESSAGES/eel-2.0.mo
+share/locale/or/LC_MESSAGES/eel-2.0.mo
+share/locale/pa/LC_MESSAGES/eel-2.0.mo
+share/locale/pl/LC_MESSAGES/eel-2.0.mo
+share/locale/pt/LC_MESSAGES/eel-2.0.mo
+share/locale/pt_BR/LC_MESSAGES/eel-2.0.mo
+share/locale/ro/LC_MESSAGES/eel-2.0.mo
+share/locale/ru/LC_MESSAGES/eel-2.0.mo
+share/locale/sk/LC_MESSAGES/eel-2.0.mo
+share/locale/sl/LC_MESSAGES/eel-2.0.mo
+share/locale/sq/LC_MESSAGES/eel-2.0.mo
+share/locale/sr/LC_MESSAGES/eel-2.0.mo
+share/locale/sr@Latn/LC_MESSAGES/eel-2.0.mo
+share/locale/sv/LC_MESSAGES/eel-2.0.mo
+share/locale/ta/LC_MESSAGES/eel-2.0.mo
+share/locale/th/LC_MESSAGES/eel-2.0.mo
+share/locale/tr/LC_MESSAGES/eel-2.0.mo
+share/locale/uk/LC_MESSAGES/eel-2.0.mo
+share/locale/vi/LC_MESSAGES/eel-2.0.mo
+share/locale/wa/LC_MESSAGES/eel-2.0.mo
+share/locale/zh_CN/LC_MESSAGES/eel-2.0.mo
+share/locale/zh_TW/LC_MESSAGES/eel-2.0.mo
+@dirrm include/eel-2/eel
+@dirrm include/eel-2