aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/efltk/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-29 09:27:45 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-29 09:27:45 +0000
commit0bc63bae10e1effcf855170b4f7b60d78ee46a46 (patch)
treea27f9e03cabd085e2b6d79ed2997e97c7e0d0915 /x11-toolkits/efltk/Makefile
parentdd65b6d747ea1fbbb8c05abdc74d55b24cf7a640 (diff)
Add efltk 2.0.1,
EFltk is a LGPL'd C++ graphical user interface toolkit for X (UNIX(r)), OpenGL(r), and Microsoft(r) Windows(r). It is based on FLTK2 (see README.fltk) and is currently developed by Equinox Desktop Environment Team (ede.sf.net) PR: ports/63517 Submitted by: Sergey Matveychuk <sem@ciam.ru>
Notes
Notes: svn path=/head/; revision=102501
Diffstat (limited to 'x11-toolkits/efltk/Makefile')
-rw-r--r--x11-toolkits/efltk/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-toolkits/efltk/Makefile b/x11-toolkits/efltk/Makefile
new file mode 100644
index 000000000000..6926342571a7
--- /dev/null
+++ b/x11-toolkits/efltk/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: efltk
+# Date created: 27 Febrary 2004
+# Whom: Sergey Matveychuk <sem@ciam.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= efltk
+PORTVERSION= 2.0.1
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ede
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${TIMESTAMP}
+
+MAINTAINER= sem@ciam.ru
+COMMENT= Extended Fast Light Toolkit
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+
+TIMESTAMP= 20040218
+
+ONLY_FOR_ARCHS= i386
+
+.if defined(WITHOUT_MYSQL)
+CONFIGURE_ARGS+= --disable-mysql
+.else
+USE_MYSQL= yes
+.endif
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
+ DEBUGFLAG="${CFLAGS} -I${LOCALBASE}/include"
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>