aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/etk/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-10-08 13:48:37 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-10-08 13:48:37 +0000
commitee774b0f4fa7f1842f6b4dfdfe60b22cbcf12442 (patch)
tree1bf12eadb5a7920766bf7a613174c0475b810d0d /x11-toolkits/etk/Makefile
parent32e98c797bd5b952894ff185e59df8a91844f4ab (diff)
Notes
Diffstat (limited to 'x11-toolkits/etk/Makefile')
-rw-r--r--x11-toolkits/etk/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-toolkits/etk/Makefile b/x11-toolkits/etk/Makefile
new file mode 100644
index 000000000000..29ed7a285b26
--- /dev/null
+++ b/x11-toolkits/etk/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: etk
+# Date created: 2006-08-14
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= etk
+PORTVERSION= 20060926
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://sunner.elcomnet.ru/~stas/
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= A comprehensive toolkit based on the EFL
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_EFL= evas ecore edje
+USE_LDCONFIG= yes
+# NLS is mandatory
+USE_GETTEXT= yes
+LDFLAGS= "-lintl"
+
+.include <bsd.port.pre.mk>
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
+.include <bsd.port.post.mk>