aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fltk/Makefile
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1999-03-07 23:52:56 +0000
committerBill Fumerola <billf@FreeBSD.org>1999-03-07 23:52:56 +0000
commite8d9657e5584dd3105850e3d820325951e7d11a6 (patch)
tree75607ccb96a86edc2b87c5ac028ad8c6c4aa55e7 /x11-toolkits/fltk/Makefile
parent07e43910e4b1c42f19577eb3420da53edf1cb9a8 (diff)
downloadports-e8d9657e5584dd3105850e3d820325951e7d11a6.tar.gz
ports-e8d9657e5584dd3105850e3d820325951e7d11a6.zip
Notes
Diffstat (limited to 'x11-toolkits/fltk/Makefile')
-rw-r--r--x11-toolkits/fltk/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
new file mode 100644
index 000000000000..9ba961bd93dc
--- /dev/null
+++ b/x11-toolkits/fltk/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: fltk
+# Version required: 19990127
+# Date created: 11 February 1999
+# Whom: Dima Sivachenko <dima@Chg.RU>
+#
+# $Id: $
+#
+
+DISTNAME= fltk-19990127
+PKGNAME= fltk-1999.01.27
+CATEGORIES= x11-toolkit
+MASTER_SITES= ftp://ftp.easysw.com/pub/fltk/ \
+ ftp://ftp.northamerica.net/pub/ESP/fltk/ \
+ ftp://ftp.funet.fi/mirrors/ftp.easysw.com/pub/fltk/ \
+ ftp://ftp.kddlabs.co.jp/pub/lang/fltk/ \
+ ftp://ftp.c-com.net/pub/LinuxBerg/files/x11/dev/
+
+MAINTAINER= dima@chg.ru
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --enable-shared
+USE_X_PREFIX= yes
+
+post-install:
+
+ @ ${INSTALL_DATA} ${WRKSRC}/lib/libfltk.so.1 ${PREFIX}/lib
+ @ ${LDCONFIG} -m
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/fltk
+ @ ${INSTALL_DATA} ${WRKSRC}/documentation/* ${PREFIX}/share/doc/fltk
+.endif
+
+.include <bsd.port.mk>