aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fltk
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-12-12 16:13:53 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-12-12 16:13:53 +0000
commitb61fbfaed8ea33d3405f721a6fd07b71bfbc0eca (patch)
treeb0b7a211ecd8c475310050be42f0113f7df5dabb /x11-toolkits/fltk
parentcd4b5e26f1f107f63d1df5461afe8a66829dc3ec (diff)
downloadports-b61fbfaed8ea33d3405f721a6fd07b71bfbc0eca.tar.gz
ports-b61fbfaed8ea33d3405f721a6fd07b71bfbc0eca.zip
Notes
Diffstat (limited to 'x11-toolkits/fltk')
-rw-r--r--x11-toolkits/fltk/Makefile11
-rw-r--r--x11-toolkits/fltk/distinfo4
-rw-r--r--x11-toolkits/fltk/files/patch-FL_Fl_Widget.H10
-rw-r--r--x11-toolkits/fltk/pkg-plist2
4 files changed, 18 insertions, 9 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index e7b73b4229e9..eb0b928836f7 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= fltk
-PORTVERSION= 1.3.1
+PORTVERSION= 1.3.2
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_EASYSW}
MASTER_SITE_SUBDIR= fltk/${PORTVERSION}
@@ -16,28 +16,29 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
USE_LDCONFIG= yes
USE_XORG= xft
-USE_GL= gl glu
-USE_GCC= any
+USE_GL= glu
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-threads \
--enable-shared \
--enable-xft
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${WRKSRC}/src -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+PORTDOCS= *
+
MAN1= fltk-config.1 fluid.1
MAN3= fltk.3
post-patch:
- ${REINPLACE_CMD} -e '30s/test //' ${WRKSRC}/Makefile
prefix="${PREFIX}" ; plength=$$(($${#prefix}+10)) ; \
${REINPLACE_CMD} -e "\|/etc/fltk|{s||${PREFIX}&|;s|10|$${plength}|;}" \
${WRKSRC}/src/Fl_Preferences.cxx
.if !defined(NOPORTDOCS)
-PORTDOCS= *
post-install:
cd ${WRKSRC}/documentation && ${MAKE} docinstall
cd ${WRKSRC}/test && ${MAKE} install
diff --git a/x11-toolkits/fltk/distinfo b/x11-toolkits/fltk/distinfo
index be0effc710ca..158465ea8cfc 100644
--- a/x11-toolkits/fltk/distinfo
+++ b/x11-toolkits/fltk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fltk-1.3.1-source.tar.gz) = 49006c148fad8c31a3a961c74486fb485c7878b9d0d084e597f30e354d7cf549
-SIZE (fltk-1.3.1-source.tar.gz) = 4257291
+SHA256 (fltk-1.3.2-source.tar.gz) = 176044df94f31bd53a5806cf5054ca78b180bf9ae27ce47649608833695ee4a4
+SIZE (fltk-1.3.2-source.tar.gz) = 4260874
diff --git a/x11-toolkits/fltk/files/patch-FL_Fl_Widget.H b/x11-toolkits/fltk/files/patch-FL_Fl_Widget.H
new file mode 100644
index 000000000000..225614ffe622
--- /dev/null
+++ b/x11-toolkits/fltk/files/patch-FL_Fl_Widget.H
@@ -0,0 +1,10 @@
+--- FL/Fl_Widget.H.orig 2012-12-12 15:44:54.000000000 +0100
++++ FL/Fl_Widget.H 2012-12-12 15:52:48.000000000 +0100
+@@ -99,6 +99,7 @@
+ */
+ class FL_EXPORT Fl_Widget {
+ friend class Fl_Group;
++ friend class Fl_X;
+
+ Fl_Group* parent_;
+ Fl_Callback* callback_;
diff --git a/x11-toolkits/fltk/pkg-plist b/x11-toolkits/fltk/pkg-plist
index ec181b8ddde4..88266fa9dd9f 100644
--- a/x11-toolkits/fltk/pkg-plist
+++ b/x11-toolkits/fltk/pkg-plist
@@ -159,5 +159,3 @@ lib/libfltk_images.so
lib/libfltk_images.so.1
lib/libfltk_images.so.1.3
@dirrm include/FL
-@dirrmtry etc/fltk/fltk.org
-@dirrmtry etc/fltk