aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fltk
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2007-02-01 12:02:46 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2007-02-01 12:02:46 +0000
commit13afc99a99a6b37f1403c18947ac5bc661db2266 (patch)
tree2fed11927e2de3c8cba584309eb30a06d522c38b /x11-toolkits/fltk
parent830072bb8e62f81c5f53c304103cbf5d860277d5 (diff)
downloadports-13afc99a99a6b37f1403c18947ac5bc661db2266.tar.gz
ports-13afc99a99a6b37f1403c18947ac5bc661db2266.zip
Notes
Diffstat (limited to 'x11-toolkits/fltk')
-rw-r--r--x11-toolkits/fltk/Makefile15
-rw-r--r--x11-toolkits/fltk/files/patch-FL-Fl_Spinner.H14
2 files changed, 19 insertions, 10 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index fb2cf51e8740..33b8d7705d29 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -7,15 +7,10 @@
PORTNAME= fltk
PORTVERSION= ${VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits
-MASTER_SITES= http://ftp.easysw.com/pub/fltk/%SUBDIR%/ \
- ftp://ftp.easysw.com/pub/fltk/%SUBDIR%/ \
- ftp://ftp3.easysw.com/pub/fltk/%SUBDIR%/ \
- http://mirror.nu6.org/ftp.easysw.com/pub/fltk/%SUBDIR%/ \
- http://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/fltk/%SUBDIR%/ \
- http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/%SUBDIR%/
-MASTER_SITE_SUBDIR= ${VERSION}
+MASTER_SITES= ${MASTER_SITE_EASYSW}
+MASTER_SITE_SUBDIR= fltk/${VERSION}
.ifdef WITH_THREADS
PKGNAMESUFFIX= -threads
.endif
@@ -39,7 +34,7 @@ CONFLICTS= fltk-threads-1*
VERSION= 1.1.7
USE_BZIP2= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+=--enable-shared --enable-xft
@@ -56,7 +51,7 @@ MAN3= fltk.3
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000 && defined(WITH_THREADS)
-IGNORE= "does not work on FreeBSD 4.x, because threading is not activated"
+IGNORE= does not work on FreeBSD 4.x, because threading is not activated
.endif
pre-everything::
diff --git a/x11-toolkits/fltk/files/patch-FL-Fl_Spinner.H b/x11-toolkits/fltk/files/patch-FL-Fl_Spinner.H
new file mode 100644
index 000000000000..a03e2624fc83
--- /dev/null
+++ b/x11-toolkits/fltk/files/patch-FL-Fl_Spinner.H
@@ -0,0 +1,14 @@
+--- FL/Fl_Spinner.H.orig Sun Jan 14 12:57:46 2007
++++ FL/Fl_Spinner.H Sun Jan 14 12:58:41 2007
+@@ -127,9 +127,9 @@
+
+ const char *format() { return (format_); }
+ void format(const char *f) { format_ = f; update(); }
+- double maxinum() const { return (maximum_); }
++ double maximum() const { return (maximum_); }
+ void maximum(double m) { maximum_ = m; }
+- double mininum() const { return (minimum_); }
++ double minimum() const { return (minimum_); }
+ void minimum(double m) { minimum_ = m; }
+ void range(double a, double b) { minimum_ = a; maximum_ = b; }
+ void resize(int X, int Y, int W, int H) {