aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-01-14 11:57:29 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-01-14 11:57:29 +0000
commitb533c0bc048411ba3fed0aeb633b27bde726ec7d (patch)
tree28a45bb399bf78e50eb603c12fd49135f26a31e1 /x11-toolkits/fox/Makefile
parent6bff64967cf73634e76677549b1acfd76d7e831c (diff)
downloadports-b533c0bc048411ba3fed0aeb633b27bde726ec7d.tar.gz
ports-b533c0bc048411ba3fed0aeb633b27bde726ec7d.zip
Notes
Diffstat (limited to 'x11-toolkits/fox/Makefile')
-rw-r--r--x11-toolkits/fox/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/x11-toolkits/fox/Makefile b/x11-toolkits/fox/Makefile
index a76ee8646489..af6bbf3f0dc2 100644
--- a/x11-toolkits/fox/Makefile
+++ b/x11-toolkits/fox/Makefile
@@ -41,6 +41,7 @@ PLIST_SUB= OLDFILE="@comment " \
USE_MESA= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}" \
CPPFLAGS="-I${LOCALBASE}/include" \
@@ -81,7 +82,9 @@ post-extract:
.endif
post-patch:
- ${PERL} -i -pe 's/^(SUBDIRS\s*=\s*).*/$$1utils include src \$${DOC}/' \
+ ${REINPLACE_CMD} -E 's/^(SUBDIRS[ ]*=[ ]*).*/\1utils include src $${DOC}/' \
${WRKSRC}/Makefile.in
+ ${FIND} ${WRKSRC} -name Makefile.in -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -E 's:\$$\(prefix\)/@PACKAGE@:$$(datadir)/doc/@PACKAGE@:'
.include <bsd.port.mk>