aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-12-02 20:32:32 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-12-02 20:32:32 +0000
commit7e835c9257ca52ff62a4ff8c9dbf4e65641313e2 (patch)
treec485bb3dfd2bf4373a88a464170cadcd089e85d5 /x11-toolkits/fox/Makefile
parent63cc17faef78218ed1b54228769f0d00873ca7a3 (diff)
Notes
Diffstat (limited to 'x11-toolkits/fox/Makefile')
-rw-r--r--x11-toolkits/fox/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/x11-toolkits/fox/Makefile b/x11-toolkits/fox/Makefile
index f0191c9fe8b7..95a32f47e9c6 100644
--- a/x11-toolkits/fox/Makefile
+++ b/x11-toolkits/fox/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= fox
-PORTVERSION?= 0.99.174
-PORTREVISION?= 1
+PORTVERSION?= 0.99.181
+PORTREVISION?= 0
CATEGORIES= x11-toolkits
MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
ftp://ftp.fox-toolkit.org/pub/ \
@@ -32,13 +32,16 @@ BUILD_DEPENDS= ${X11BASE}/include/xunicode/xunicode.h:${PORTSDIR}/converters/xun
CONFIGURE_ENV= X_CFLAGS=-DUSE_UNICODE
-PLIST_SUB= NEWFILE="@comment "
+PLIST_SUB= OLDFILE="" \
+ NEWFILE="@comment "
.else
-PLIST_SUB= NEWFILE=""
+PLIST_SUB= OLDFILE="@comment " \
+ NEWFILE=""
.endif
USE_MESA= yes
INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}" \
CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -62,7 +65,7 @@ MAKE_ARGS+= DOC=
.else
MAKE_ARGS+= DOC=doc
.endif
-USE_LIBTOOL= yes
+#USE_LIBTOOL= yes
SHLIB_MAJ= 1
SHLIB_MIN= 0
MAKE_ENV+= LT_CURRENT="${SHLIB_MAJ}" LT_REVISION="${SHLIB_MIN}"
@@ -77,4 +80,8 @@ post-extract:
cd ${WRKSRC} && ${LN} -s ${X11BASE}/include/xunicode
.endif
+post-patch:
+ ${PERL} -i -pe 's/^(SUBDIRS\s*=\s*).*/$$1utils include src \$${DOC}/' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>