aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox10/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-03-22 00:34:21 +0000
committerWill Andrews <will@FreeBSD.org>2000-03-22 00:34:21 +0000
commitbeff722fd9038dbf6c9066c10a34740d081d396e (patch)
treebf6062e375a5d204d3a3ba550059c9ed35a01c7f /x11-toolkits/fox10/Makefile
parente05c25a8bfb41edae18214ae1281268c8328111a (diff)
downloadports-beff722fd9038dbf6c9066c10a34740d081d396e.tar.gz
ports-beff722fd9038dbf6c9066c10a34740d081d396e.zip
Notes
Diffstat (limited to 'x11-toolkits/fox10/Makefile')
-rw-r--r--x11-toolkits/fox10/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-toolkits/fox10/Makefile b/x11-toolkits/fox10/Makefile
new file mode 100644
index 000000000000..32652635e247
--- /dev/null
+++ b/x11-toolkits/fox10/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: fox
+# Version required: 0.1
+# Date created: 23 Feb 2000
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= fox
+PKGNAME= fox-0.99.112
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://ftp.cfdrc.com/pub/FOX/ \
+ ftp://imssun1.epfl.ch/pub/ \
+ ftp://SunSITE.Informatik.RWTH-Aachen.DE/pub/Linux/fox/
+
+MAINTAINER= will@FreeBSD.org
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.3:${PORTSDIR}/graphics/png \
+ GL.14:${PORTSDIR}/graphics/Mesa3
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-opengl=mesa --with-x
+.if defined(NO_SHM)
+CONFIGURE_ARGS+=--with-shm=no
+.else
+CONFIGURE_ARGS+=--with-shm=yes
+.endif
+.if defined(DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.else
+CONFIGURE_ARGS+=--enable-release
+.endif
+.if defined(WANT_PROFILE)
+CONFIGURE_ARGS+=--with-profiling=gprof
+.endif
+USE_LIBTOOL= yes
+WRKSRC= ${WRKDIR}/${PKGNAME}
+SHLIB_MAJ= 1
+SHLIB_MIN= 0
+MAKE_ENV+= LT_CURRENT="${SHLIB_MAJ}" LT_REVISION="${SHLIB_MIN}"
+MAN1= reswrap.1
+
+.include <bsd.port.pre.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+PLIST_SUB+= LIBVER="${SHLIB_MAJ}"
+.else
+PLIST_SUB+= LIBVER="${SHLIB_MAJ}.${SHLIB_MIN}"
+.endif
+
+.include <bsd.port.post.mk>