aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox14/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-02-08 00:14:58 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-02-08 00:14:58 +0000
commitb9bedb1d3e7b4a15860e54b7f8c166f7308f3f43 (patch)
tree0adce3beb1b6a40cba662c24c71f76a6fb81366b /x11-toolkits/fox14/Makefile
parentefcf8584e2274d51c80ad5490321d04603848ec1 (diff)
downloadports-b9bedb1d3e7b4a15860e54b7f8c166f7308f3f43.tar.gz
ports-b9bedb1d3e7b4a15860e54b7f8c166f7308f3f43.zip
Notes
Diffstat (limited to 'x11-toolkits/fox14/Makefile')
-rw-r--r--x11-toolkits/fox14/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/x11-toolkits/fox14/Makefile b/x11-toolkits/fox14/Makefile
index 0046bc81b46f..6de627fb31c9 100644
--- a/x11-toolkits/fox14/Makefile
+++ b/x11-toolkits/fox14/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fox
-PORTVERSION?= 1.0.30
-PORTREVISION?= 0
+PORTVERSION= 1.1.22
CATEGORIES= x11-toolkits
MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
ftp://ftp.fox-toolkit.org/pub/ \
@@ -26,8 +25,9 @@ USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}" \
CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+=--with-opengl=mesa --with-x
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lXm"
+CONFIGURE_ARGS+=--with-opengl=mesa --with-x \
+ --enable-xthreads
MAN1= reswrap.1
@@ -133,4 +133,16 @@ pre-everything::
.endif
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+##
+## Port conflict management
+##
+.if exists(${LOCALBASE}/lib/libFOX-1.0.so)
+IGNORE= Conflict management: you have port fox-devel installed. The\
+ fox port is incompatible with fox-devel one. You have to\
+ uninstall fox-devel port if you really need the fox one
+.endif
+
+.include <bsd.port.post.mk>
+