aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox14
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /x11-toolkits/fox14
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'x11-toolkits/fox14')
-rw-r--r--x11-toolkits/fox14/Makefile4
-rw-r--r--x11-toolkits/fox14/files/patch-src-fxpngio.cpp46
2 files changed, 48 insertions, 2 deletions
diff --git a/x11-toolkits/fox14/Makefile b/x11-toolkits/fox14/Makefile
index cb5f570741e2..38f810c52c57 100644
--- a/x11-toolkits/fox14/Makefile
+++ b/x11-toolkits/fox14/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fox
PORTVERSION= ${MAJORVER}.${SHVER}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11-toolkits
MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
ftp://ftp.fox-toolkit.org/pub/ \
@@ -17,7 +17,7 @@ MAINTAINER?= gahr@FreeBSD.org
COMMENT= Fast and extensive C++ GUI toolkit
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
Xft.2:${PORTSDIR}/x11-fonts/libXft
diff --git a/x11-toolkits/fox14/files/patch-src-fxpngio.cpp b/x11-toolkits/fox14/files/patch-src-fxpngio.cpp
new file mode 100644
index 000000000000..b1854671bad9
--- /dev/null
+++ b/x11-toolkits/fox14/files/patch-src-fxpngio.cpp
@@ -0,0 +1,46 @@
+--- src/fxpngio.cpp.orig 2005-11-19 21:22:25.000000000 +0100
++++ src/fxpngio.cpp 2012-05-07 07:11:22.000000000 +0200
+@@ -21,13 +21,13 @@
+ *********************************************************************************
+ * $Id: fxpngio.cpp,v 1.35.2.1 2005/11/19 20:22:25 fox Exp $ *
+ ********************************************************************************/
++#ifdef HAVE_PNG_H
++#include "png.h"
++#endif
+ #include "fxver.h"
+ #include "fxdefs.h"
+ #include "FXHash.h"
+ #include "FXStream.h"
+-#ifdef HAVE_PNG_H
+-#include "png.h"
+-#endif
+
+ /*
+ Notes:
+@@ -76,7 +76,7 @@
+ FXStream* store=(FXStream*)png_get_error_ptr(png_ptr);
+ store->setError(FXStreamFormat); // Flag this as a format error in FXStream
+ FXTRACE((100,"Error in png: %s\n",message));
+- longjmp(png_ptr->jmpbuf,1); // Bail out
++ longjmp(png_jmpbuf(png_ptr),1); // Bail out
+ }
+
+
+@@ -121,7 +121,7 @@
+ }
+
+ // Set error handling
+- if(setjmp(png_ptr->jmpbuf)){
++ if(setjmp(png_jmpbuf(png_ptr))){
+
+ // Free all of the memory associated with the png_ptr and info_ptr
+ png_destroy_read_struct(&png_ptr,&info_ptr,(png_infopp)NULL);
+@@ -234,7 +234,7 @@
+ }
+
+ // Set error handling.
+- if(setjmp(png_ptr->jmpbuf)){
++ if(setjmp(png_jmpbuf(png_ptr))){
+ png_destroy_write_struct(&png_ptr,&info_ptr);
+ return FALSE;
+ }