aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox14
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-05-16 10:57:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-05-16 10:57:08 +0000
commit72c0964070411418c5b85c13f79c119e39eca87a (patch)
treed2b305ed1d57cf3cdee778d5855c5d6ea975d679 /x11-toolkits/fox14
parente035d321fc55480d75de5fb6451378f5aa13e529 (diff)
downloadports-72c0964070411418c5b85c13f79c119e39eca87a.tar.gz
ports-72c0964070411418c5b85c13f79c119e39eca87a.zip
Notes
Diffstat (limited to 'x11-toolkits/fox14')
-rw-r--r--x11-toolkits/fox14/Makefile40
1 files changed, 8 insertions, 32 deletions
diff --git a/x11-toolkits/fox14/Makefile b/x11-toolkits/fox14/Makefile
index bba06ef89e41..fbeede77070f 100644
--- a/x11-toolkits/fox14/Makefile
+++ b/x11-toolkits/fox14/Makefile
@@ -41,6 +41,14 @@ MAN1= shutterbug.1 reswrap.1
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
+OPTIONS= OPTIMIZED_CXXFLAGS "Enable additional optimizations" off \
+ CUPS "Enable CUPS support" off \
+ DEBUG "Build with DEBUG support" off \
+ FOX_APPLICATIONS "Install sample applications" off \
+ PROFILING "Build with PROFILING support" off \
+ SHM "Enable Shared Memory support" on \
+ XFT "Enable Xft support" on
+
.include <bsd.port.pre.mk>
##
@@ -120,36 +128,4 @@ post-patch:
${WRKSRC}/Makefile.in
.endif
-pre-everything::
-.if !defined(WITH_OPTIMIZED_CXXFLAGS)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can enable additional compilation optimizations'
- @${ECHO_MSG} 'by defining WITH_OPTIMIZED_CXXFLAGS'
-.endif
-.if !defined(WITH_CUPS)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can enable CUPS support by defining WITH_CUPS'
-.endif
-.if !defined(WITH_DEBUG)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can build DEBUG support by defining WITH_DEBUG'
-.endif
-.if !defined(WITH_FOX_APPLICATIONS)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can install FOX sample applications by defining WITH_FOX_APPLICATIONS"
-.endif
-.if !defined(WITH_PROFILING)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can build PROFILING support by defining WITH_PROFILING'
-.endif
-.if !defined(WITHOUT_SHM)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can disable Shared Memory support by defining WITHOUT_SHM'
-.endif
-.if !defined(WITHOUT_XFT)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can disable Xft support by defining WITHOUT_XFT'
-.endif
- @${ECHO_MSG}
-
.include <bsd.port.post.mk>