aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/freeglut/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2003-05-05 22:16:26 +0000
committerEric Anholt <anholt@FreeBSD.org>2003-05-05 22:16:26 +0000
commita8a511ee7a87e9d4c48b9c588e3405f437a7c016 (patch)
tree3bfeb2adba022e07a17219b3fc35c43bf95d369a /x11-toolkits/freeglut/Makefile
parent3044de721fa5763cc097bee4a7e6ab2e1b6c0fe1 (diff)
Notes
Diffstat (limited to 'x11-toolkits/freeglut/Makefile')
-rw-r--r--x11-toolkits/freeglut/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-toolkits/freeglut/Makefile b/x11-toolkits/freeglut/Makefile
new file mode 100644
index 000000000000..8786e74dc6e1
--- /dev/null
+++ b/x11-toolkits/freeglut/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: freeglut
+# Date created: Wed Apr 23 2003
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= freeglut
+PORTVERSION= 1.3
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://${PORTNAME}.sourceforge.net/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${SNAPDATE}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An alternative to the OpenGL Utility Toolkit (GLUT) library
+
+SNAPDATE= 2002-01-25
+
+USE_AUTOMAKE= yes
+HAS_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+USE_XLIB= yes
+USE_GNOME= glib12
+CONFIGURE_ARGS= --x-includes=${X11BASE}/include --x-libraries=${X11BASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include `${GLIB_CONFIG} --cflags`" \
+ LDFLAGS="`${GLIB_CONFIG} --libs`"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.1
+
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
+
+MK2X11= freeglut-1.3/Makefile.am genfonts/Makefile.am
+
+post-patch:
+.for file in ${MK2X11}
+ @${REINPLACE_CMD} -e "s|%%X11BASE%%|${X11BASE}|g" ${WRKSRC}/${file}
+.endfor
+
+post-install:
+ @${ECHO_MSG}
+ @${ECHO_MSG} " freeglut requires a DRI enabled-graphic card;"
+ @${ECHO_MSG} " You may try to run the program 'one' to check your installation."
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>