aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gal2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /x11-toolkits/gal2/Makefile
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Notes
Diffstat (limited to 'x11-toolkits/gal2/Makefile')
-rw-r--r--x11-toolkits/gal2/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/x11-toolkits/gal2/Makefile b/x11-toolkits/gal2/Makefile
index 725f935a6428..4a68461fcfce 100644
--- a/x11-toolkits/gal2/Makefile
+++ b/x11-toolkits/gal2/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= gal2
-PORTVERSION= 2.2.5
+PORTVERSION= 2.4.0
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -18,16 +18,26 @@ COMMENT= A collection of widgets taken from GNOME 2 gnumeric
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix gnomehier intlhack \
- libgnomeui libgnomeprintui
+USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui libgnomeprintui
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER=15
CONFIGURE_ARGS= --enable-static --with-libiconv
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-PLIST_SUB= VERSION="2.2" PORTVERSION=${PORTVERSION}
+PLIST_SUB= VERSION="2.4" PORTVERSION=${PORTVERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ( ${OSVERSION} > 600000 && ${OSVERSION} < 600006 ) || \
+ ( ${OSVERSION} < 503101 )
+.for po in da.po it.po zh_CN.po
+ @${REINPLACE_CMD} -e 's|%-|%|g' ${WRKSRC}/po/${po}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>