aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gal2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /x11-toolkits/gal2
parentcc0f3248a2eb77d7e3df88333fd25eb8594223dc (diff)
downloadports-e18151212d3326dbf04797c6d5300fb1211ee875.tar.gz
ports-e18151212d3326dbf04797c6d5300fb1211ee875.zip
Notes
Diffstat (limited to 'x11-toolkits/gal2')
-rw-r--r--x11-toolkits/gal2/Makefile16
-rw-r--r--x11-toolkits/gal2/distinfo4
-rw-r--r--x11-toolkits/gal2/files/patch-gal_widgets_e-canvas.c11
-rw-r--r--x11-toolkits/gal2/pkg-plist125
4 files changed, 124 insertions, 32 deletions
diff --git a/x11-toolkits/gal2/Makefile b/x11-toolkits/gal2/Makefile
index da148b95ed6e..ca84b9d42e2d 100644
--- a/x11-toolkits/gal2/Makefile
+++ b/x11-toolkits/gal2/Makefile
@@ -3,13 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/x11-toolkits/gal2/Makefile,v 1.52 2005/08/19 13:26:41 marcus Exp $
#
PORTNAME= gal2
-PORTVERSION= 2.4.3
+PORTVERSION= 2.5.3
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.5
DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -21,17 +22,22 @@ USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui libgnomeprintui
+USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui libgnomeprintui \
+ ltverhack
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --enable-static --with-libiconv
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-PLIST_SUB= VERSION="2.4" PORTVERSION=${PORTVERSION}
+PLIST_SUB= VERSION="2.6" PORTVERSION=${PORTVERSION} \
+ SHLIBVERSION="2.4"
.include <bsd.port.pre.mk>
+post-extract:
+ ${TOUCH} -f ${WRKSRC}/gal/util/e-util-private.h
+
post-patch:
.if ( ${OSVERSION} > 600000 && ${OSVERSION} < 600006 ) || \
( ${OSVERSION} < 503101 )
diff --git a/x11-toolkits/gal2/distinfo b/x11-toolkits/gal2/distinfo
index 036606f5fcdd..bc3f355aa0a5 100644
--- a/x11-toolkits/gal2/distinfo
+++ b/x11-toolkits/gal2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gal-2.4.3.tar.bz2) = de9ef290fd614a1057e26e31bc294142
-SIZE (gnome2/gal-2.4.3.tar.bz2) = 1056344
+MD5 (gnome2/gal-2.5.3.tar.bz2) = 8fae770488887f9d0f95bcdbffc673cc
+SIZE (gnome2/gal-2.5.3.tar.bz2) = 1153998
diff --git a/x11-toolkits/gal2/files/patch-gal_widgets_e-canvas.c b/x11-toolkits/gal2/files/patch-gal_widgets_e-canvas.c
deleted file mode 100644
index 10dc71d4cb9f..000000000000
--- a/x11-toolkits/gal2/files/patch-gal_widgets_e-canvas.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- gal/widgets/e-canvas.c.orig Tue May 24 01:16:33 2005
-+++ gal/widgets/e-canvas.c Tue May 24 01:16:51 2005
-@@ -1015,7 +1015,7 @@ void e_canvas_popup_tooltip (ECanvas *ca
-
- void e_canvas_hide_tooltip (ECanvas *canvas)
- {
-- if (canvas->tooltip_window) {
-+ if (canvas && canvas->tooltip_window) {
- gtk_widget_destroy (canvas->tooltip_window);
- canvas->tooltip_window = NULL;
- }
diff --git a/x11-toolkits/gal2/pkg-plist b/x11-toolkits/gal2/pkg-plist
index ba5831247aa9..3c7ce3862c55 100644
--- a/x11-toolkits/gal2/pkg-plist
+++ b/x11-toolkits/gal2/pkg-plist
@@ -7,6 +7,7 @@ include/gal-%%VERSION%%/gal/a11y/e-table/gal-a11y-e-cell-vbox.h
include/gal-%%VERSION%%/gal/a11y/e-table/gal-a11y-e-cell.h
include/gal-%%VERSION%%/gal/a11y/e-table/gal-a11y-e-table-click-to-add-factory.h
include/gal-%%VERSION%%/gal/a11y/e-table/gal-a11y-e-table-click-to-add.h
+include/gal-%%VERSION%%/gal/a11y/e-table/gal-a11y-e-table-column-header.h
include/gal-%%VERSION%%/gal/a11y/e-table/gal-a11y-e-table-factory.h
include/gal-%%VERSION%%/gal/a11y/e-table/gal-a11y-e-table-item-factory.h
include/gal-%%VERSION%%/gal/a11y/e-table/gal-a11y-e-table-item.h
@@ -148,20 +149,115 @@ include/gal-%%VERSION%%/gal/widgets/gal-combo-stack.h
include/gal-%%VERSION%%/gal/widgets/gal-combo-text.h
include/gal-%%VERSION%%/gal/widgets/widget-color-combo.h
include/gal-%%VERSION%%/gal/widgets/widget-pixmap-combo.h
-lib/libgal-%%VERSION%%.a
-lib/libgal-%%VERSION%%.so
-lib/libgal-%%VERSION%%.so.0
-lib/libgal-a11y-%%VERSION%%.a
-lib/libgal-a11y-%%VERSION%%.so
-lib/libgal-a11y-%%VERSION%%.so.0
+lib/libgal-%%SHLIBVERSION%%.a
+lib/libgal-%%SHLIBVERSION%%.so
+lib/libgal-%%SHLIBVERSION%%.so.0
+lib/libgal-a11y-%%SHLIBVERSION%%.a
+lib/libgal-a11y-%%SHLIBVERSION%%.so
+lib/libgal-a11y-%%SHLIBVERSION%%.so.0
libdata/pkgconfig/gal-%%VERSION%%.pc
-share/doc/gal-%%VERSION%%/gal-api.html
-share/doc/gal-%%VERSION%%/gal-api.sgml
-share/doc/gal-%%VERSION%%/gal-decl.txt
-share/doc/gal-%%VERSION%%/gal-sections.txt
-share/doc/gal-%%VERSION%%/gal.hierarchy
-share/doc/gal-%%VERSION%%/gal.signals
-share/doc/gal-%%VERSION%%/gal.types
+share/doc/gal/book1.html
+share/doc/gal/cell-renderers.html
+share/doc/gal/combo-boxes.html
+share/doc/gal/cut-and-paste.html
+share/doc/gal/e-font.html
+share/doc/gal/e-table-core.html
+share/doc/gal/e-table.html
+share/doc/gal/e-text.html
+share/doc/gal/ecanvas.html
+share/doc/gal/ecanvasvbox.html
+share/doc/gal/ecell.html
+share/doc/gal/ecellcheckbox.html
+share/doc/gal/ecelltext.html
+share/doc/gal/ecelltoggle.html
+share/doc/gal/ecelltree.html
+share/doc/gal/eentry.html
+share/doc/gal/ehpaned.html
+share/doc/gal/ehscrollbar.html
+share/doc/gal/epaned.html
+share/doc/gal/eprintable.html
+share/doc/gal/ereflow.html
+share/doc/gal/ereflowsorted.html
+share/doc/gal/escrollframe.html
+share/doc/gal/etable.html
+share/doc/gal/etableclicktoadd.html
+share/doc/gal/etablecol.html
+share/doc/gal/etablecolumnspecification.html
+share/doc/gal/etableconfig.html
+share/doc/gal/etableconfigfield.html
+share/doc/gal/etableextras.html
+share/doc/gal/etablefieldchooser.html
+share/doc/gal/etablefieldchooserdialog.html
+share/doc/gal/etablefieldchooseritem.html
+share/doc/gal/etablegroup.html
+share/doc/gal/etablegroupcontainer.html
+share/doc/gal/etablegroupleaf.html
+share/doc/gal/etableheader.html
+share/doc/gal/etableheaderitem.html
+share/doc/gal/etableitem.html
+share/doc/gal/etablemodel.html
+share/doc/gal/etableone.html
+share/doc/gal/etablescrolled.html
+share/doc/gal/etableselectionmodel.html
+share/doc/gal/etablesimple.html
+share/doc/gal/etablesorted.html
+share/doc/gal/etablesortedvariable.html
+share/doc/gal/etablesorter.html
+share/doc/gal/etablesortinfo.html
+share/doc/gal/etablespecification.html
+share/doc/gal/etablestate.html
+share/doc/gal/etablesubset.html
+share/doc/gal/etablesubsetvariable.html
+share/doc/gal/etabletextmodel.html
+share/doc/gal/etext.html
+share/doc/gal/etexteventprocessor.html
+share/doc/gal/etexteventprocessoremacslike.html
+share/doc/gal/etextmodel.html
+share/doc/gal/etreesimple.html
+share/doc/gal/evpaned.html
+share/doc/gal/evscrollbar.html
+share/doc/gal/gal-api.html
+share/doc/gal/gal-api.sgml
+share/doc/gal/gal-colorcombo.html
+share/doc/gal/gal-colorgroup.html
+share/doc/gal/gal-colorpalette.html
+share/doc/gal/gal-decl.txt
+share/doc/gal/gal-e-cache.html
+share/doc/gal/gal-e-canvas-utils.html
+share/doc/gal/gal-e-colors.html
+share/doc/gal/gal-e-cursors.html
+share/doc/gal/gal-e-font.html
+share/doc/gal/gal-e-gui-utils.html
+share/doc/gal/gal-e-popup-menu.html
+share/doc/gal/gal-e-table-col-dnd.html
+share/doc/gal/gal-e-table-defines.html
+share/doc/gal/gal-e-table-header-utils.html
+share/doc/gal/gal-e-table-tooltip.html
+share/doc/gal/gal-e-table-tree.html
+share/doc/gal/gal-e-text-event-processor-types.html
+share/doc/gal/gal-e-tree-model.html
+share/doc/gal/gal-e-unicode.html
+share/doc/gal/gal-e-util.html
+share/doc/gal/gal-e-xml-utils.html
+share/doc/gal/gal-gtkcombobox.html
+share/doc/gal/gal-sections.txt
+share/doc/gal/gal.hierarchy
+share/doc/gal/gal.signals
+share/doc/gal/gal.types
+share/doc/gal/galdefineviewsdialog.html
+share/doc/gal/galdefineviewsmodel.html
+share/doc/gal/galview.html
+share/doc/gal/galviewcollection.html
+share/doc/gal/galviewetable.html
+share/doc/gal/galviewfactory.html
+share/doc/gal/galviewfactoryetable.html
+share/doc/gal/galviewnewdialog.html
+share/doc/gal/gtkcombostack.html
+share/doc/gal/gtkcombotext.html
+share/doc/gal/pixmapcombo.html
+share/doc/gal/reflow.html
+share/doc/gal/utility-widgets.html
+share/doc/gal/view-configurationt.html
share/gnome/gal-%%VERSION%%/%%PORTVERSION%%/glade/e-categories-master-list-dialog.glade
share/gnome/gal-%%VERSION%%/%%PORTVERSION%%/glade/e-table-config-no-group.glade
share/gnome/gal-%%VERSION%%/%%PORTVERSION%%/glade/e-table-config.glade
@@ -224,6 +320,7 @@ share/locale/lv/LC_MESSAGES/gal-%%VERSION%%.mo
share/locale/mn/LC_MESSAGES/gal-%%VERSION%%.mo
share/locale/ms/LC_MESSAGES/gal-%%VERSION%%.mo
share/locale/nb/LC_MESSAGES/gal-%%VERSION%%.mo
+share/locale/ne/LC_MESSAGES/gal-%%VERSION%%.mo
share/locale/nl/LC_MESSAGES/gal-%%VERSION%%.mo
share/locale/nn/LC_MESSAGES/gal-%%VERSION%%.mo
share/locale/no/LC_MESSAGES/gal-%%VERSION%%.mo
@@ -253,7 +350,7 @@ share/locale/zh_TW/LC_MESSAGES/gal-%%VERSION%%.mo
@dirrm share/gnome/gal-%%VERSION%%/%%PORTVERSION%%/glade
@dirrm share/gnome/gal-%%VERSION%%/%%PORTVERSION%%
@dirrm share/gnome/gal-%%VERSION%%
-@dirrm share/doc/gal-%%VERSION%%
+@dirrm share/doc/gal
@dirrm include/gal-%%VERSION%%/gal/widgets
@dirrm include/gal-%%VERSION%%/gal/util
@dirrm include/gal-%%VERSION%%/gal/shortcut-bar