aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gal
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2001-02-09 22:01:23 +0000
committerAde Lovett <ade@FreeBSD.org>2001-02-09 22:01:23 +0000
commit1dacfd6f15f31ed5d6bbe6d9cd9e01ea9057187d (patch)
treef8cb129e364be1e4ebb4254f6c7c02b4a2bf96f2 /x11-toolkits/gal
parent566eafd7493c7d55f9816ee2f1f54d9cddb760e7 (diff)
downloadports-1dacfd6f15f31ed5d6bbe6d9cd9e01ea9057187d.tar.gz
ports-1dacfd6f15f31ed5d6bbe6d9cd9e01ea9057187d.zip
Notes
Diffstat (limited to 'x11-toolkits/gal')
-rw-r--r--x11-toolkits/gal/Makefile6
-rw-r--r--x11-toolkits/gal/distinfo2
-rw-r--r--x11-toolkits/gal/files/patch-aa48
-rw-r--r--x11-toolkits/gal/files/patch-ac21
-rw-r--r--x11-toolkits/gal/pkg-plist40
5 files changed, 83 insertions, 34 deletions
diff --git a/x11-toolkits/gal/Makefile b/x11-toolkits/gal/Makefile
index c7d0f7c44566..d7223ac381a0 100644
--- a/x11-toolkits/gal/Makefile
+++ b/x11-toolkits/gal/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gal
-PORTVERSION= 0.4.1
+PORTVERSION= 0.5
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/gal
@@ -17,7 +17,7 @@ LIB_DEPENDS= gnomeprint.13:${PORTSDIR}/print/gnomeprint \
glade.4:${PORTSDIR}/devel/libglade \
unicode.0:${PORTSDIR}/devel/libunicode \
gnomevfs.0:${PORTSDIR}/devel/gnomevfs \
- iconv.2:${PORTSDIR}/converters/iconv
+ giconv.2:${PORTSDIR}/converters/libiconv
USE_X_PREFIX= yes
USE_PERL5= yes
@@ -25,7 +25,7 @@ USE_GMAKE= yes
USE_GNOME= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --enable-static
+CONFIGURE_ARGS= --enable-static --with-libiconv
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/x11-toolkits/gal/distinfo b/x11-toolkits/gal/distinfo
index ec0ecb00248a..10d952f8519a 100644
--- a/x11-toolkits/gal/distinfo
+++ b/x11-toolkits/gal/distinfo
@@ -1 +1 @@
-MD5 (gal-0.4.1.tar.gz) = c0f791fdbd6af7b906cd372dc0a3c25c
+MD5 (gal-0.5.tar.gz) = 1aaf233130fa116334da2edc516b8958
diff --git a/x11-toolkits/gal/files/patch-aa b/x11-toolkits/gal/files/patch-aa
index 402e100d12f3..79bbe96885e2 100644
--- a/x11-toolkits/gal/files/patch-aa
+++ b/x11-toolkits/gal/files/patch-aa
@@ -1,25 +1,31 @@
---- configure.orig Thu Dec 14 13:56:02 2000
-+++ configure Fri Dec 15 10:52:44 2000
-@@ -4958,5 +4958,5 @@
- LDFLAGS="$LDFLAGS $ICONV_LIBS"
--echo $ac_n "checking for libiconv in -liconv""... $ac_c" 1>&6
--echo "configure:4961: checking for libiconv in -liconv" >&5
--ac_lib_var=`echo iconv'_'libiconv | sed 'y%./+-%__p_%'`
-+echo $ac_n "checking for iconv in -liconv""... $ac_c" 1>&6
-+echo "configure:4961: checking for iconv in -liconv" >&5
-+ac_lib_var=`echo iconv'_'iconv | sed 'y%./+-%__p_%'`
- if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
-@@ -4972,6 +4972,6 @@
- builtin and then its argument prototype would still apply. */
--char libiconv();
-+char iconv();
+--- configure.orig Thu Feb 8 13:54:31 2001
++++ configure Fri Feb 9 10:46:57 2001
+@@ -5017,5 +5017,5 @@
+ CFLAGS="$CFLAGS $ICONV_CFLAGS"
+-LDFLAGS="$LDFLAGS $ICONV_LIBS -liconv"
+-echo $ac_n "checking for iconv in -liconv""... $ac_c" 1>&6
+-echo "configure:5021: checking for iconv in -liconv" >&5
++LDFLAGS="$LDFLAGS $ICONV_LIBS -lgiconv"
++echo $ac_n "checking for iconv in -lgiconv""... $ac_c" 1>&6
++echo "configure:5021: checking for iconv in -lgiconv" >&5
+ if eval "test \"`echo '$''{'ac_cv_libiconv'+set}'`\" = set"; then
+@@ -5027,3 +5027,3 @@
- int main() {
--libiconv()
-+iconv()
- ; return 0; }
-@@ -5206,4 +5206,4 @@
- echo "configure:5207: checking for GTK >= 1.2.7" >&5
+-#include <iconv.h>
++#include <giconv.h>
+
+@@ -5050,3 +5050,3 @@
+ if test $ac_cv_libiconv = yes; then
+- ICONV_LIBS="$ICONV_LIBS -liconv"
++ ICONV_LIBS="$ICONV_LIBS -lgiconv"
+ have_iconv=yes
+@@ -5176,3 +5176,3 @@
+
+-#include <iconv.h>
++#include <giconv.h>
+ #include <stdlib.h>
+@@ -5302,4 +5302,4 @@
+ echo "configure:5303: checking for GTK >= 1.2.7" >&5
-if gtk-config --version > /dev/null 2>&1; then
- vers=`gtk-config --version | awk 'BEGIN { FS = "."; } { printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+if $GTK_CONFIG --version > /dev/null 2>&1; then
diff --git a/x11-toolkits/gal/files/patch-ac b/x11-toolkits/gal/files/patch-ac
new file mode 100644
index 000000000000..0969ed3eb8b4
--- /dev/null
+++ b/x11-toolkits/gal/files/patch-ac
@@ -0,0 +1,21 @@
+--- gal/widgets/e-font.c.orig Wed Feb 7 14:35:03 2001
++++ gal/widgets/e-font.c Fri Feb 9 10:55:19 2001
+@@ -19,3 +19,3 @@
+ #include <unicode.h>
+-#include <iconv.h>
++#include <giconv.h>
+ #include "gal/util/e-cache.h"
+--- gal/widgets/e-font.h.orig Tue Feb 6 15:24:03 2001
++++ gal/widgets/e-font.h Fri Feb 9 10:55:41 2001
+@@ -16,3 +16,3 @@
+ #include <gdk/gdk.h>
+-#include <iconv.h>
++#include <giconv.h>
+ #include <libgnome/gnome-defs.h>
+--- gal/widgets/e-unicode.c.orig Wed Feb 7 14:35:03 2001
++++ gal/widgets/e-unicode.c Fri Feb 9 11:02:57 2001
+@@ -15,3 +15,3 @@
+ #include <unicode.h>
+-#include <iconv.h>
++#include <giconv.h>
+ #include <gdk/gdk.h>
diff --git a/x11-toolkits/gal/pkg-plist b/x11-toolkits/gal/pkg-plist
index 0c65f244bf81..f9532138063f 100644
--- a/x11-toolkits/gal/pkg-plist
+++ b/x11-toolkits/gal/pkg-plist
@@ -3,6 +3,9 @@ include/gal/e-paned/e-hpaned.h
include/gal/e-paned/e-paned.h
include/gal/e-paned/e-vpaned.h
include/gal/e-table/e-cell-checkbox.h
+include/gal/e-table/e-cell-date.h
+include/gal/e-table/e-cell-number.h
+include/gal/e-table/e-cell-size.h
include/gal/e-table/e-cell-text.h
include/gal/e-table/e-cell-toggle.h
include/gal/e-table/e-cell-tree.h
@@ -11,7 +14,6 @@ include/gal/e-table/e-table-click-to-add.h
include/gal/e-table/e-table-col-dnd.h
include/gal/e-table/e-table-col.h
include/gal/e-table/e-table-column-specification.h
-include/gal/e-table/e-table-config-field.h
include/gal/e-table/e-table-config.h
include/gal/e-table/e-table-defines.h
include/gal/e-table/e-table-extras.h
@@ -47,6 +49,7 @@ include/gal/e-text/e-entry.h
include/gal/e-text/e-text-event-processor-emacs-like.h
include/gal/e-text/e-text-event-processor-types.h
include/gal/e-text/e-text-event-processor.h
+include/gal/e-text/e-text-model-uri.h
include/gal/e-text/e-text-model.h
include/gal/e-text/e-text.h
include/gal/menus/gal-define-views-dialog.h
@@ -57,7 +60,14 @@ include/gal/menus/gal-view-factory-etable.h
include/gal/menus/gal-view-factory.h
include/gal/menus/gal-view-new-dialog.h
include/gal/menus/gal-view.h
+include/gal/shortcut-bar/e-group-bar.h
+include/gal/shortcut-bar/e-icon-bar-bg-item.h
+include/gal/shortcut-bar/e-icon-bar.h
+include/gal/shortcut-bar/e-shortcut-bar.h
+include/gal/shortcut-bar/e-shortcut-model.h
+include/gal/shortcut-bar/e-vscrolled-bar.h
include/gal/util/e-cache.h
+include/gal/util/e-i18n.h
include/gal/util/e-util.h
include/gal/util/e-xml-utils.h
include/gal/widgets/color-group.h
@@ -65,6 +75,7 @@ include/gal/widgets/color-palette.h
include/gal/widgets/e-canvas-utils.h
include/gal/widgets/e-canvas-vbox.h
include/gal/widgets/e-canvas.h
+include/gal/widgets/e-categories.h
include/gal/widgets/e-colors.h
include/gal/widgets/e-cursors.h
include/gal/widgets/e-font.h
@@ -84,19 +95,22 @@ include/gal/widgets/widget-color-combo.h
include/gal/widgets/widget-pixmap-combo.h
lib/libgal.a
lib/libgal.so
-lib/libgal.so.3
+lib/libgal.so.4
share/gnome/etable/%%VERSION%%/glade/e-table-config.glade
share/gnome/etable/%%VERSION%%/glade/e-table-field-chooser.glade
share/gnome/etable/%%VERSION%%/glade/e-table-group.glade
+share/gnome/gal/%%VERSION%%/glade/gal-categories.glade
share/gnome/gal/%%VERSION%%/glade/gal-define-views.glade
share/gnome/gal/%%VERSION%%/glade/gal-view-new-dialog.glade
-share/gnome/bonobo/html/gal-api.sgml
-share/gnome/bonobo/html/gal-decl.txt
-share/gnome/bonobo/html/gal-sections.txt
-share/gnome/bonobo/html/gal.hierarchy
-share/gnome/bonobo/html/gal.signals
-share/gnome/bonobo/html/gal.types
+share/gnome/gal/html/gal-api.sgml
+share/gnome/gal/html/gal-decl.txt
+share/gnome/gal/html/gal-sections.txt
+share/gnome/gal/html/gal.hierarchy
+share/gnome/gal/html/gal.signals
+share/gnome/gal/html/gal.types
+share/locale/ca/LC_MESSAGES/gal.mo
share/locale/da/LC_MESSAGES/gal.mo
+share/locale/de/LC_MESSAGES/gal.mo
share/locale/en_GB/LC_MESSAGES/gal.mo
share/locale/es/LC_MESSAGES/gal.mo
share/locale/fi/LC_MESSAGES/gal.mo
@@ -106,18 +120,26 @@ share/locale/hu/LC_MESSAGES/gal.mo
share/locale/it/LC_MESSAGES/gal.mo
share/locale/ja/LC_MESSAGES/gal.mo
share/locale/ko/LC_MESSAGES/gal.mo
+share/locale/lt/LC_MESSAGES/gal.mo
share/locale/no/LC_MESSAGES/gal.mo
share/locale/pl/LC_MESSAGES/gal.mo
+share/locale/pt_BR/LC_MESSAGES/gal.mo
+share/locale/ru/LC_MESSAGES/gal.mo
+share/locale/sk/LC_MESSAGES/gal.mo
share/locale/sv/LC_MESSAGES/gal.mo
+share/locale/tr/LC_MESSAGES/gal.mo
+share/locale/uk/LC_MESSAGES/gal.mo
@dirrm share/gnome/gal/%%VERSION%%/glade
@dirrm share/gnome/gal/%%VERSION%%
+@dirrm share/gnome/gal/html/gal
+@dirrm share/gnome/gal/html
@dirrm share/gnome/gal
@dirrm share/gnome/etable/%%VERSION%%/glade
@dirrm share/gnome/etable/%%VERSION%%
@dirrm share/gnome/etable
-@dirrm share/gnome/bonobo/html/gal
@dirrm include/gal/widgets
@dirrm include/gal/util
+@dirrm include/gal/shortcut-bar
@dirrm include/gal/menus
@dirrm include/gal/e-text
@dirrm include/gal/e-table