aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gdl
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-09 03:46:19 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-09 03:46:19 +0000
commitebcf70874201395644716e74e503cec42a0b8c8c (patch)
tree6bc1df4dc73945ab6377a2db28f389e060f5a4d4 /x11-toolkits/gdl
parentdfd8e5085384dc291f67ec9d91e65fcc235da122 (diff)
downloadports-ebcf70874201395644716e74e503cec42a0b8c8c.tar.gz
ports-ebcf70874201395644716e74e503cec42a0b8c8c.zip
Notes
Diffstat (limited to 'x11-toolkits/gdl')
-rw-r--r--x11-toolkits/gdl/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/x11-toolkits/gdl/Makefile b/x11-toolkits/gdl/Makefile
index 1759cd802e55..598507ea2ae6 100644
--- a/x11-toolkits/gdl/Makefile
+++ b/x11-toolkits/gdl/Makefile
@@ -20,7 +20,12 @@ USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack libgnomeui
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -Ee \
+ 's|-D[^[:space:]_]+_DISABLE_DEPRECATED||g'
+
.include <bsd.port.mk>