aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gdl
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /x11-toolkits/gdl
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
downloadports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.tar.gz
ports-af3811313c14afb06fe2d1f6158e3e431bbfc2b6.zip
Notes
Diffstat (limited to 'x11-toolkits/gdl')
-rw-r--r--x11-toolkits/gdl/Makefile14
-rw-r--r--x11-toolkits/gdl/distinfo4
-rw-r--r--x11-toolkits/gdl/files/patch-gdl__gdl-dock-item-button-image.c11
-rw-r--r--x11-toolkits/gdl/files/patch-gdl__gdl-dock-item.c11
-rw-r--r--x11-toolkits/gdl/pkg-plist257
5 files changed, 129 insertions, 168 deletions
diff --git a/x11-toolkits/gdl/Makefile b/x11-toolkits/gdl/Makefile
index fe51f85de348..c547fdc8001a 100644
--- a/x11-toolkits/gdl/Makefile
+++ b/x11-toolkits/gdl/Makefile
@@ -1,18 +1,22 @@
# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/x11-toolkits/gdl/Makefile,v 1.40 2010/09/29 08:07:46 kwm Exp $
+# $MCom: ports/trunk/x11-toolkits/gdl/Makefile 19868 2014-09-14 13:50:26Z kwm $
PORTNAME= gdl
-PORTVERSION= 2.30.1
-PORTREVISION= 3
+PORTVERSION= 3.12.0
+PORTREVISION= 2
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Components intended to be shared between GNOME development tools
-USES= gettext gmake libtool:keepla pathfix pkgconfig tar:bzip2
-USE_GNOME= gnomeprefix gtk20
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GNOME= gnomeprefix gtk30 intlhack
+USES= gettext gmake libtool pathfix pkgconfig tar:xz
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/x11-toolkits/gdl/distinfo b/x11-toolkits/gdl/distinfo
index 4172b616d9e0..e13b49050478 100644
--- a/x11-toolkits/gdl/distinfo
+++ b/x11-toolkits/gdl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gdl-2.30.1.tar.bz2) = 027dd1cd0191996fe1a0dc902da857698cc79564cb057ba13b09097e56e30cc1
-SIZE (gdl-2.30.1.tar.bz2) = 569211
+SHA256 (gnome3/gdl-3.12.0.tar.xz) = 4770f959f31ed5e616fe623c284e8dd6136e49902d19b6e37938d34be4f6b88d
+SIZE (gnome3/gdl-3.12.0.tar.xz) = 527944
diff --git a/x11-toolkits/gdl/files/patch-gdl__gdl-dock-item-button-image.c b/x11-toolkits/gdl/files/patch-gdl__gdl-dock-item-button-image.c
deleted file mode 100644
index 1d058e9e6a06..000000000000
--- a/x11-toolkits/gdl/files/patch-gdl__gdl-dock-item-button-image.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./gdl/gdl-dock-item-button-image.c.orig 2012-03-19 01:16:15.000000000 +1030
-+++ ./gdl/gdl-dock-item-button-image.c 2012-03-19 01:16:32.000000000 +1030
-@@ -49,7 +49,7 @@
- cairo_set_line_width(cr, 1.0);
-
- style = gtk_widget_get_style (widget);
-- g_return_if_fail (style != NULL);
-+ g_return_val_if_fail (style != NULL, 0);
- color = &style->fg[GTK_STATE_NORMAL];
- cairo_set_source_rgba(cr, color->red / 65535.0,
- color->green / 65535.0, color->blue / 65535.0, 0.55);
diff --git a/x11-toolkits/gdl/files/patch-gdl__gdl-dock-item.c b/x11-toolkits/gdl/files/patch-gdl__gdl-dock-item.c
deleted file mode 100644
index 7931c8c0d0f7..000000000000
--- a/x11-toolkits/gdl/files/patch-gdl__gdl-dock-item.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./gdl/gdl-dock-item.c.orig 2012-03-19 01:15:14.000000000 +1030
-+++ ./gdl/gdl-dock-item.c 2012-03-19 01:15:55.000000000 +1030
-@@ -1816,7 +1816,7 @@
- GtkWidget *
- gdl_dock_item_get_grip(GdlDockItem *item)
- {
-- g_return_if_fail (item != NULL);
-+ g_return_val_if_fail (item != NULL, NULL);
- g_return_val_if_fail (GDL_IS_DOCK_ITEM (item), NULL);
-
- return item->_priv->grip;
diff --git a/x11-toolkits/gdl/pkg-plist b/x11-toolkits/gdl/pkg-plist
index 0cc646adace3..ded78c952822 100644
--- a/x11-toolkits/gdl/pkg-plist
+++ b/x11-toolkits/gdl/pkg-plist
@@ -1,139 +1,118 @@
-include/libgdl-1.0/gdl/gdl-dock-bar.h
-include/libgdl-1.0/gdl/gdl-dock-item.h
-include/libgdl-1.0/gdl/gdl-dock-item-grip.h
-include/libgdl-1.0/gdl/gdl-dock-layout.h
-include/libgdl-1.0/gdl/gdl-dock-master.h
-include/libgdl-1.0/gdl/gdl-dock-object.h
-include/libgdl-1.0/gdl/gdl-dock-placeholder.h
-include/libgdl-1.0/gdl/gdl-dock.h
-include/libgdl-1.0/gdl/gdl-tools.h
-include/libgdl-1.0/gdl/gdl.h
-include/libgdl-1.0/gdl/libgdltypebuiltins.h
-lib/libgdl-1.la
-lib/libgdl-1.so
-lib/libgdl-1.so.3
-lib/libgdl-1.so.3.0.0
-libdata/pkgconfig/gdl-1.0.pc
-%%DOCSDIR%%/gdl-gdl-dock-bar.html
-%%DOCSDIR%%/gdl-gdl-dock-item.html
-%%DOCSDIR%%/gdl-gdl-dock-layout.html
-%%DOCSDIR%%/gdl-gdl-dock-master.html
-%%DOCSDIR%%/gdl-gdl-dock-object.html
-%%DOCSDIR%%/gdl-gdl-dock-placeholder.html
-%%DOCSDIR%%/gdl-gdl-tools.html
-%%DOCSDIR%%/gdl-gdl-dock.html
-%%DOCSDIR%%/gdl-main.html
-%%DOCSDIR%%/gdl.devhelp
-%%DOCSDIR%%/gdl.devhelp2
-%%DOCSDIR%%/home.png
-%%DOCSDIR%%/index.html
-%%DOCSDIR%%/index.sgml
-%%DOCSDIR%%/left.png
-%%DOCSDIR%%/right.png
-%%DOCSDIR%%/style.css
-%%DOCSDIR%%/up.png
-share/gdl/ui/layout.ui
-share/locale/am/LC_MESSAGES/gdl-1.mo
-share/locale/ar/LC_MESSAGES/gdl-1.mo
-share/locale/ast/LC_MESSAGES/gdl-1.mo
-share/locale/az/LC_MESSAGES/gdl-1.mo
-share/locale/be/LC_MESSAGES/gdl-1.mo
-share/locale/bg/LC_MESSAGES/gdl-1.mo
-share/locale/bn/LC_MESSAGES/gdl-1.mo
-share/locale/ca/LC_MESSAGES/gdl-1.mo
-share/locale/ca@valencia/LC_MESSAGES/gdl-1.mo
-share/locale/cs/LC_MESSAGES/gdl-1.mo
-share/locale/da/LC_MESSAGES/gdl-1.mo
-share/locale/de/LC_MESSAGES/gdl-1.mo
-share/locale/dz/LC_MESSAGES/gdl-1.mo
-share/locale/el/LC_MESSAGES/gdl-1.mo
-share/locale/en_CA/LC_MESSAGES/gdl-1.mo
-share/locale/en_GB/LC_MESSAGES/gdl-1.mo
-share/locale/en@shaw/LC_MESSAGES/gdl-1.mo
-share/locale/es/LC_MESSAGES/gdl-1.mo
-share/locale/et/LC_MESSAGES/gdl-1.mo
-share/locale/eu/LC_MESSAGES/gdl-1.mo
-share/locale/fi/LC_MESSAGES/gdl-1.mo
-share/locale/fr/LC_MESSAGES/gdl-1.mo
-share/locale/ga/LC_MESSAGES/gdl-1.mo
-share/locale/gl/LC_MESSAGES/gdl-1.mo
-share/locale/gu/LC_MESSAGES/gdl-1.mo
-share/locale/he/LC_MESSAGES/gdl-1.mo
-share/locale/hi/LC_MESSAGES/gdl-1.mo
-share/locale/hr/LC_MESSAGES/gdl-1.mo
-share/locale/hu/LC_MESSAGES/gdl-1.mo
-share/locale/hy/LC_MESSAGES/gdl-1.mo
-share/locale/id/LC_MESSAGES/gdl-1.mo
-share/locale/it/LC_MESSAGES/gdl-1.mo
-share/locale/ja/LC_MESSAGES/gdl-1.mo
-share/locale/ko/LC_MESSAGES/gdl-1.mo
-share/locale/lt/LC_MESSAGES/gdl-1.mo
-share/locale/lv/LC_MESSAGES/gdl-1.mo
-share/locale/mai/LC_MESSAGES/gdl-1.mo
-share/locale/mk/LC_MESSAGES/gdl-1.mo
-share/locale/ml/LC_MESSAGES/gdl-1.mo
-share/locale/mr/LC_MESSAGES/gdl-1.mo
-share/locale/nb/LC_MESSAGES/gdl-1.mo
-share/locale/ne/LC_MESSAGES/gdl-1.mo
-share/locale/nl/LC_MESSAGES/gdl-1.mo
-share/locale/oc/LC_MESSAGES/gdl-1.mo
-share/locale/or/LC_MESSAGES/gdl-1.mo
-share/locale/pa/LC_MESSAGES/gdl-1.mo
-share/locale/pl/LC_MESSAGES/gdl-1.mo
-share/locale/ps/LC_MESSAGES/gdl-1.mo
-share/locale/pt/LC_MESSAGES/gdl-1.mo
-share/locale/pt_BR/LC_MESSAGES/gdl-1.mo
-share/locale/ro/LC_MESSAGES/gdl-1.mo
-share/locale/ru/LC_MESSAGES/gdl-1.mo
-share/locale/rw/LC_MESSAGES/gdl-1.mo
-share/locale/si/LC_MESSAGES/gdl-1.mo
-share/locale/sk/LC_MESSAGES/gdl-1.mo
-share/locale/sl/LC_MESSAGES/gdl-1.mo
-share/locale/sq/LC_MESSAGES/gdl-1.mo
-share/locale/sr/LC_MESSAGES/gdl-1.mo
-share/locale/sr@latin/LC_MESSAGES/gdl-1.mo
-share/locale/sv/LC_MESSAGES/gdl-1.mo
-share/locale/te/LC_MESSAGES/gdl-1.mo
-share/locale/th/LC_MESSAGES/gdl-1.mo
-share/locale/tr/LC_MESSAGES/gdl-1.mo
-share/locale/ug/LC_MESSAGES/gdl-1.mo
-share/locale/uk/LC_MESSAGES/gdl-1.mo
-share/locale/vi/LC_MESSAGES/gdl-1.mo
-share/locale/zh_CN/LC_MESSAGES/gdl-1.mo
-share/locale/zh_HK/LC_MESSAGES/gdl-1.mo
-share/locale/zh_TW/LC_MESSAGES/gdl-1.mo
-@dirrm share/gdl/ui
-@dirrm share/gdl
-@dirrm %%DOCSDIR%%
-@dirrm include/libgdl-1.0/gdl
-@dirrm include/libgdl-1.0
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
-@dirrmtry share/locale/te/LC_MESSAGES
-@dirrmtry share/locale/te
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
-@dirrmtry share/locale/si/LC_MESSAGES
-@dirrmtry share/locale/si
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/ps/LC_MESSAGES
-@dirrmtry share/locale/ps
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrmtry share/locale/mai/LC_MESSAGES
-@dirrmtry share/locale/mai
-@dirrmtry share/locale/hy/LC_MESSAGES
-@dirrmtry share/locale/hy
-@dirrmtry share/locale/en@shaw/LC_MESSAGES
-@dirrmtry share/locale/en@shaw
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/ca@valencia/LC_MESSAGES
-@dirrmtry share/locale/ca@valencia
-@dirrmtry share/locale/ast/LC_MESSAGES
-@dirrmtry share/locale/ast
+include/libgdl-3.0/gdl/gdl-dock-bar.h
+include/libgdl-3.0/gdl/gdl-dock-item-grip.h
+include/libgdl-3.0/gdl/gdl-dock-item.h
+include/libgdl-3.0/gdl/gdl-dock-layout.h
+include/libgdl-3.0/gdl/gdl-dock-master.h
+include/libgdl-3.0/gdl/gdl-dock-object.h
+include/libgdl-3.0/gdl/gdl-dock-placeholder.h
+include/libgdl-3.0/gdl/gdl-dock.h
+include/libgdl-3.0/gdl/gdl.h
+include/libgdl-3.0/gdl/libgdltypebuiltins.h
+lib/girepository-1.0/Gdl-3.typelib
+lib/libgdl-3.so
+lib/libgdl-3.so.5
+lib/libgdl-3.so.5.0.8
+libdata/pkgconfig/gdl-3.0.pc
+share/doc/gdl-3.0/GdlDock.html
+share/doc/gdl-3.0/GdlDockBar.html
+share/doc/gdl-3.0/GdlDockItem.html
+share/doc/gdl-3.0/GdlDockItemButtonImage.html
+share/doc/gdl-3.0/GdlDockItemGrip.html
+share/doc/gdl-3.0/GdlDockLayout.html
+share/doc/gdl-3.0/GdlDockMaster.html
+share/doc/gdl-3.0/GdlDockNotebook.html
+share/doc/gdl-3.0/GdlDockObject.html
+share/doc/gdl-3.0/GdlDockPaned.html
+share/doc/gdl-3.0/GdlDockPlaceholder.html
+share/doc/gdl-3.0/GdlDockTablabel.html
+share/doc/gdl-3.0/GdlPreviewWindow.html
+share/doc/gdl-3.0/GdlSwitcher.html
+share/doc/gdl-3.0/annotation-glossary.html
+share/doc/gdl-3.0/api-index-full.html
+share/doc/gdl-3.0/api.html
+share/doc/gdl-3.0/core.html
+share/doc/gdl-3.0/deprecated.html
+share/doc/gdl-3.0/gdl-3.0.devhelp2
+share/doc/gdl-3.0/home.png
+share/doc/gdl-3.0/index.html
+share/doc/gdl-3.0/index.sgml
+share/doc/gdl-3.0/left.png
+share/doc/gdl-3.0/private.html
+share/doc/gdl-3.0/right.png
+share/doc/gdl-3.0/style.css
+share/doc/gdl-3.0/up.png
+share/doc/gdl-3.0/widget.html
+share/gir-1.0/Gdl-3.gir
+share/locale/am/LC_MESSAGES/gdl-3.mo
+share/locale/ar/LC_MESSAGES/gdl-3.mo
+share/locale/as/LC_MESSAGES/gdl-3.mo
+share/locale/ast/LC_MESSAGES/gdl-3.mo
+share/locale/az/LC_MESSAGES/gdl-3.mo
+share/locale/be/LC_MESSAGES/gdl-3.mo
+share/locale/bg/LC_MESSAGES/gdl-3.mo
+share/locale/bn/LC_MESSAGES/gdl-3.mo
+share/locale/ca/LC_MESSAGES/gdl-3.mo
+share/locale/ca@valencia/LC_MESSAGES/gdl-3.mo
+share/locale/cs/LC_MESSAGES/gdl-3.mo
+share/locale/da/LC_MESSAGES/gdl-3.mo
+share/locale/de/LC_MESSAGES/gdl-3.mo
+share/locale/dz/LC_MESSAGES/gdl-3.mo
+share/locale/el/LC_MESSAGES/gdl-3.mo
+share/locale/en@shaw/LC_MESSAGES/gdl-3.mo
+share/locale/en_CA/LC_MESSAGES/gdl-3.mo
+share/locale/en_GB/LC_MESSAGES/gdl-3.mo
+share/locale/eo/LC_MESSAGES/gdl-3.mo
+share/locale/es/LC_MESSAGES/gdl-3.mo
+share/locale/et/LC_MESSAGES/gdl-3.mo
+share/locale/eu/LC_MESSAGES/gdl-3.mo
+share/locale/fi/LC_MESSAGES/gdl-3.mo
+share/locale/fr/LC_MESSAGES/gdl-3.mo
+share/locale/ga/LC_MESSAGES/gdl-3.mo
+share/locale/gl/LC_MESSAGES/gdl-3.mo
+share/locale/gu/LC_MESSAGES/gdl-3.mo
+share/locale/he/LC_MESSAGES/gdl-3.mo
+share/locale/hi/LC_MESSAGES/gdl-3.mo
+share/locale/hr/LC_MESSAGES/gdl-3.mo
+share/locale/hu/LC_MESSAGES/gdl-3.mo
+share/locale/hy/LC_MESSAGES/gdl-3.mo
+share/locale/id/LC_MESSAGES/gdl-3.mo
+share/locale/it/LC_MESSAGES/gdl-3.mo
+share/locale/ja/LC_MESSAGES/gdl-3.mo
+share/locale/km/LC_MESSAGES/gdl-3.mo
+share/locale/ko/LC_MESSAGES/gdl-3.mo
+share/locale/lt/LC_MESSAGES/gdl-3.mo
+share/locale/lv/LC_MESSAGES/gdl-3.mo
+share/locale/mai/LC_MESSAGES/gdl-3.mo
+share/locale/mk/LC_MESSAGES/gdl-3.mo
+share/locale/ml/LC_MESSAGES/gdl-3.mo
+share/locale/mr/LC_MESSAGES/gdl-3.mo
+share/locale/nb/LC_MESSAGES/gdl-3.mo
+share/locale/ne/LC_MESSAGES/gdl-3.mo
+share/locale/nl/LC_MESSAGES/gdl-3.mo
+share/locale/oc/LC_MESSAGES/gdl-3.mo
+share/locale/or/LC_MESSAGES/gdl-3.mo
+share/locale/pa/LC_MESSAGES/gdl-3.mo
+share/locale/pl/LC_MESSAGES/gdl-3.mo
+share/locale/ps/LC_MESSAGES/gdl-3.mo
+share/locale/pt/LC_MESSAGES/gdl-3.mo
+share/locale/pt_BR/LC_MESSAGES/gdl-3.mo
+share/locale/ro/LC_MESSAGES/gdl-3.mo
+share/locale/ru/LC_MESSAGES/gdl-3.mo
+share/locale/rw/LC_MESSAGES/gdl-3.mo
+share/locale/si/LC_MESSAGES/gdl-3.mo
+share/locale/sk/LC_MESSAGES/gdl-3.mo
+share/locale/sl/LC_MESSAGES/gdl-3.mo
+share/locale/sq/LC_MESSAGES/gdl-3.mo
+share/locale/sr/LC_MESSAGES/gdl-3.mo
+share/locale/sr@latin/LC_MESSAGES/gdl-3.mo
+share/locale/sv/LC_MESSAGES/gdl-3.mo
+share/locale/te/LC_MESSAGES/gdl-3.mo
+share/locale/tg/LC_MESSAGES/gdl-3.mo
+share/locale/th/LC_MESSAGES/gdl-3.mo
+share/locale/tr/LC_MESSAGES/gdl-3.mo
+share/locale/ug/LC_MESSAGES/gdl-3.mo
+share/locale/uk/LC_MESSAGES/gdl-3.mo
+share/locale/vi/LC_MESSAGES/gdl-3.mo
+share/locale/zh_CN/LC_MESSAGES/gdl-3.mo
+share/locale/zh_HK/LC_MESSAGES/gdl-3.mo
+share/locale/zh_TW/LC_MESSAGES/gdl-3.mo