aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gdl
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-07-24 11:23:15 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-07-24 11:23:15 +0000
commit4635923bf31e4251e00cb9f84ad5b075ae97199a (patch)
tree8be27b083452d5f3aac4561be19456828c4bb3cb /x11-toolkits/gdl
parent5615e38ce11d98b1ae9cb9a2209cd58a84750e25 (diff)
downloadports-4635923bf31e4251e00cb9f84ad5b075ae97199a.tar.gz
ports-4635923bf31e4251e00cb9f84ad5b075ae97199a.zip
Notes
Diffstat (limited to 'x11-toolkits/gdl')
-rw-r--r--x11-toolkits/gdl/Makefile31
-rw-r--r--x11-toolkits/gdl/distinfo1
-rw-r--r--x11-toolkits/gdl/files/patch-Makefile.in18
-rw-r--r--x11-toolkits/gdl/files/patch-ltmain.sh18
-rw-r--r--x11-toolkits/gdl/files/patch-scintilla-control::scintilla::Makefile.in14
-rw-r--r--x11-toolkits/gdl/pkg-comment1
-rw-r--r--x11-toolkits/gdl/pkg-descr16
-rw-r--r--x11-toolkits/gdl/pkg-plist16
8 files changed, 115 insertions, 0 deletions
diff --git a/x11-toolkits/gdl/Makefile b/x11-toolkits/gdl/Makefile
new file mode 100644
index 000000000000..3012c918cbf4
--- /dev/null
+++ b/x11-toolkits/gdl/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gdl
+# Date created: 24 July 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdl
+PORTVERSION= 0.1.0
+CATEGORIES?= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/${PORTNAME}
+
+MAINTAINER?= gnome@FreeBSD.org
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GNOME= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gdl/distinfo b/x11-toolkits/gdl/distinfo
new file mode 100644
index 000000000000..580d548da627
--- /dev/null
+++ b/x11-toolkits/gdl/distinfo
@@ -0,0 +1 @@
+MD5 (gdl-0.1.0.tar.bz2) = 29f88e72f6bf5ba4314e4779e029fe0a
diff --git a/x11-toolkits/gdl/files/patch-Makefile.in b/x11-toolkits/gdl/files/patch-Makefile.in
new file mode 100644
index 000000000000..a6f6a1be7bf4
--- /dev/null
+++ b/x11-toolkits/gdl/files/patch-Makefile.in
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- Makefile.in 2001/07/24 11:08:03 1.1
++++ Makefile.in 2001/07/24 11:09:14
+@@ -146,10 +146,10 @@
+
+ SUBDIRS = idl gdl scintilla-control po intl
+
+-m4datadir = $(datadir)/aclocal
++m4datadir = $(prefix)/share/aclocal
+ m4data_DATA = gdl.m4
+
+-confexecdir = $(libdir)
++confexecdir = $(sysconfdir)
+ confexec_DATA = gdlConf.sh
+
+ EXTRA_DIST = gdl.m4 gdlConf.sh.in MAINTAINERS AUTHORS
diff --git a/x11-toolkits/gdl/files/patch-ltmain.sh b/x11-toolkits/gdl/files/patch-ltmain.sh
new file mode 100644
index 000000000000..0c594216b0e1
--- /dev/null
+++ b/x11-toolkits/gdl/files/patch-ltmain.sh
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/07/23 09:45:58 1.1
++++ ltmain.sh 2001/07/23 09:46:28
+@@ -4175,10 +4175,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/x11-toolkits/gdl/files/patch-scintilla-control::scintilla::Makefile.in b/x11-toolkits/gdl/files/patch-scintilla-control::scintilla::Makefile.in
new file mode 100644
index 000000000000..02a0fee07a1e
--- /dev/null
+++ b/x11-toolkits/gdl/files/patch-scintilla-control::scintilla::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- scintilla-control/scintilla/Makefile.in 2001/07/24 10:59:04 1.1
++++ scintilla-control/scintilla/Makefile.in 2001/07/24 10:59:42
+@@ -144,7 +144,7 @@
+ gnomelocaledir = @gnomelocaledir@
+ l = @l@
+
+-INCLUDES = `gtk-config --cflags` -DGTK -DSCI_LEXER -W -Wall -I .
++INCLUDES = ${GTK_CFLAGS} -DGTK -DSCI_LEXER -W -Wall -I .
+
+ noinst_LIBRARIES = libscintilla-widget.a libthrowaway.a
+
diff --git a/x11-toolkits/gdl/pkg-comment b/x11-toolkits/gdl/pkg-comment
new file mode 100644
index 000000000000..68991cf555a1
--- /dev/null
+++ b/x11-toolkits/gdl/pkg-comment
@@ -0,0 +1 @@
+A components intended to be shared between GNOME development tools
diff --git a/x11-toolkits/gdl/pkg-descr b/x11-toolkits/gdl/pkg-descr
new file mode 100644
index 000000000000..ae7f43d40aea
--- /dev/null
+++ b/x11-toolkits/gdl/pkg-descr
@@ -0,0 +1,16 @@
+Gnome Devtool Libraries
+=======================
+
+This package contains components and libraries that are intended to be
+shared between GNOME development tools, including gnome-debug,
+gnome-build, and gIDE.
+
+The current pieces of GDL include:
+
+ - A code-editing bonboo component based on the Scintilla
+ widget (scintilla-control).
+
+ - An utility library that also contains the stubs and skels for
+ the above components (gdl).
+
+WWW: http://www.gnome.org/
diff --git a/x11-toolkits/gdl/pkg-plist b/x11-toolkits/gdl/pkg-plist
new file mode 100644
index 000000000000..2f6b5437f208
--- /dev/null
+++ b/x11-toolkits/gdl/pkg-plist
@@ -0,0 +1,16 @@
+bin/scintilla-control
+etc/gdlConf.sh
+include/gdl/GDL.h
+include/gdl/gdl-server-manager.h
+include/gdl/gdl-tools.h
+include/gdl/gdl.h
+lib/libgdl.a
+lib/libgdl.so
+lib/libgdl.so.0
+share/aclocal/gdl.m4
+share/gnome/idl/GDL.idl
+share/gnome/idl/editor-buffer.idl
+share/gnome/idl/editor-gutter.idl
+share/gnome/oaf/Bonobo_Control_Scintilla.oaf
+share/gnome/ui/scintilla-ui.xml
+@dirrm include/gdl