aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gigi
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-12-12 05:13:24 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-12-12 05:13:24 +0000
commit21da9138c2e06764523de69a01e6d93db7375756 (patch)
treebae294c68eb00705d2b1bf13b283fe79253a6506 /x11-toolkits/gigi
parent0c56bfb5f0520135a5286323fbcad1fb40e45d73 (diff)
downloadports-21da9138c2e06764523de69a01e6d93db7375756.tar.gz
ports-21da9138c2e06764523de69a01e6d93db7375756.zip
Notes
Diffstat (limited to 'x11-toolkits/gigi')
-rw-r--r--x11-toolkits/gigi/Makefile33
-rw-r--r--x11-toolkits/gigi/distinfo6
-rw-r--r--x11-toolkits/gigi/pkg-plist2
3 files changed, 21 insertions, 20 deletions
diff --git a/x11-toolkits/gigi/Makefile b/x11-toolkits/gigi/Makefile
index b62411681702..308ae0769c84 100644
--- a/x11-toolkits/gigi/Makefile
+++ b/x11-toolkits/gigi/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= gigi
-PORTVERSION= 0.6.0.20070905
+PORTVERSION= 0.6.0.20071206
CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= alepulver
+MASTER_SITES= ftp://ftp.alepulver.com.ar/distfiles/
MAINTAINER= alepulver@FreeBSD.org
COMMENT= OpenGL Graphic User Interface Library
@@ -24,35 +23,35 @@ SCONS_ARGS= prefix="" pkgconfigdir=""
USE_SDL= sdl
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}/GG
+# Ensure local headers are found first, otherwise updating would fail.
+CFLAGS+= -I.
-#OPTIONS= OGRE "Enable Ogre (3D engine) support" off
+OPTIONS= OGRE "Enable Ogre (3D engine) support" off
SHLIB_VER= 0
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
+GIGI_LIBS= GiGi GiGiSDL
.include <bsd.port.pre.mk>
-#.if defined(WITH_OGRE)
-#LIB_DEPENDS+= OgreMain.13:${PORTSDIR}/graphics/ogre3d
-#PLIST_SUB+= OGRE=""
-#.else
-#SCONS_ENV+= build_ogre_driver=0 build_ogre_ois_plugin=0
-#PLIST_SUB+= OGRE="@comment "
-#.endif
+.if defined(WITH_OGRE)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d
+RUN_DEPENDS+= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d
+PLIST_SUB+= OGRE=""
+GIGI_LIBS+= GiGiOgre
+.else
+SCONS_ARGS+= build_ogre_driver=0 build_ogre_ois_plugin=0
+PLIST_SUB+= OGRE="@comment "
+.endif
post-build:
@${REINPLACE_CMD} -Ee 's,^(prefix|(lib|include)dir)=,&${PREFIX},' \
${WRKSRC}/*.pc
-do-build:
- @cd ${BUILD_WRKSRC} && \
- ${SETENV} ${SCONS_BUILDENV} ktrace -di ${SCONS_BIN} ${SCONS_ENV} ${SCONS_ARGS} \
- ${SCONS_TARGET}
-
do-install:
${MKDIR} ${PREFIX}/include/GG
${CP} -R ${WRKSRC}/GG/* ${PREFIX}/include/GG
-.for lib in GiGi GiGiSDL
+.for lib in ${GIGI_LIBS}
${INSTALL_PROGRAM} ${WRKSRC}/lib${lib}.so \
${PREFIX}/lib/lib${lib}.so.${SHLIB_VER}
cd ${PREFIX}/lib && ${LN} -sf lib${lib}.so.${SHLIB_VER} lib${lib}.so
diff --git a/x11-toolkits/gigi/distinfo b/x11-toolkits/gigi/distinfo
index 0fc6b5dd4134..4ad3e35a2c3c 100644
--- a/x11-toolkits/gigi/distinfo
+++ b/x11-toolkits/gigi/distinfo
@@ -1,3 +1,3 @@
-MD5 (gigi-0.6.0.20070905.tar.bz2) = a0a766163975200ed09be8b4cbfbd557
-SHA256 (gigi-0.6.0.20070905.tar.bz2) = c77f63364ce3496f3ef2f584e1fa88e84681efce74431a58fe70531073f1cb53
-SIZE (gigi-0.6.0.20070905.tar.bz2) = 601868
+MD5 (gigi-0.6.0.20071206.tar.bz2) = 558ae774b9de74b60e9f3d0e7188f6f4
+SHA256 (gigi-0.6.0.20071206.tar.bz2) = 88a6f726f6cb5aabdb9bb10752e3eb13f233a1e63d4e5052755c79ee480d2d7d
+SIZE (gigi-0.6.0.20071206.tar.bz2) = 601431
diff --git a/x11-toolkits/gigi/pkg-plist b/x11-toolkits/gigi/pkg-plist
index 20492e7fb15f..c1cccc7942de 100644
--- a/x11-toolkits/gigi/pkg-plist
+++ b/x11-toolkits/gigi/pkg-plist
@@ -56,6 +56,8 @@ include/GG/ltdl.h
include/GG/ltdl_config.h
lib/libGiGi.so
lib/libGiGi.so.0
+%%OGRE%%lib/libGiGiOgre.so
+%%OGRE%%lib/libGiGiOgre.so.0
lib/libGiGiSDL.so
lib/libGiGiSDL.so.0
libdata/pkgconfig/GiGi.pc