aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gnocl/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2004-03-26 18:00:49 +0000
committerMark Linimon <linimon@FreeBSD.org>2004-03-26 18:00:49 +0000
commit4adc5ba87e69a177fc67b0b795f882fba8afafd3 (patch)
tree8a93c40be8164f5570d52f66b6b624fd4f04dc08 /x11-toolkits/gnocl/Makefile
parenta381e74c1fb3433b87e250dabc0f524a154898c8 (diff)
downloadports-4adc5ba87e69a177fc67b0b795f882fba8afafd3.tar.gz
ports-4adc5ba87e69a177fc67b0b795f882fba8afafd3.zip
Notes
Diffstat (limited to 'x11-toolkits/gnocl/Makefile')
-rw-r--r--x11-toolkits/gnocl/Makefile43
1 files changed, 36 insertions, 7 deletions
diff --git a/x11-toolkits/gnocl/Makefile b/x11-toolkits/gnocl/Makefile
index 8be75e2f1d51..6d0c076b6953 100644
--- a/x11-toolkits/gnocl/Makefile
+++ b/x11-toolkits/gnocl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnocl
-PORTVERSION= 0.5.12
+PORTVERSION= 0.5.15
PORTREVISION= 1
CATEGORIES= x11-toolkits devel
MASTER_SITES= http://www.dr-baum.net/gnocl/
@@ -18,13 +18,14 @@ BUILD_DEPENDS= ${LOCALBASE}/include/tcl8.4/tcl.h:${PORTSDIR}/lang/tcl84
USE_GMAKE= yes
USE_BZIP2= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
BUILD_WRKSRC= ${WRKSRC}/src
CFLAGS+= -I${LOCALBASE}/include/tcl8.4
USE_X_PREFIX= yes
-USE_GNOME= libgnomecanvas gconf2
+USE_GNOME= gtk20
.include <bsd.port.pre.mk>
@@ -33,24 +34,52 @@ CFLAGS+= -fPIC
.endif
GNOCL_CANVAS_FILE="lib/libgnoclCanvas.so.1"
+GNOCL_GCONF_FILE="lib/libgnoclGconf.so.1"
+GNOCL_GNOME_FILE="lib/libgnoclGnome.so.1"
.if defined(WITHOUT_CANVAS)
-ALL_TARGET= gnocl
-USE_GNOME= gtk20 gconf2
GNOCL_CANVAS_FILE= "@comment "
+.else
+USE_GNOME+= libgnomecanvas
.endif
-.if defined(WITH_GNOME)
-GNOCL_USE_GNOME:=1
-USE_GNOME+= libgnomeui
+.if defined(WITHOUT_GCONF)
+GNOCL_GCONF_FILE= "@comment "
+.else
+USE_GNOME+= gconf2
+.endif
+
+.if defined(WITHOUT_GNOME)
+GNOCL_GNOME_FILE= "@comment "
+.else
+USE_GNOME+= libgnomeui gnomepanel
.endif
PLIST_SUB+= GNOCL_CANVAS_FILE=${GNOCL_CANVAS_FILE}
+PLIST_SUB+= GNOCL_GCONF_FILE=${GNOCL_GCONF_FILE}
+PLIST_SUB+= GNOCL_GNOME_FILE=${GNOCL_GNOME_FILE}
+
+post-patch:
+.if defined(WITHOUT_CANVAS)
+ ${REINPLACE_CMD} -e 's=^USE_CANVAS=#USE_CANVAS=' ${BUILD_WRKSRC}/Makefile
+.endif
+.if defined(WITHOUT_GCONF)
+ ${REINPLACE_CMD} -e 's=^USE_GCONF=#USE_GCONF=' ${BUILD_WRKSRC}/Makefile
+.endif
+.if defined(WITHOUT_GNOME)
+ ${REINPLACE_CMD} -e 's=^USE_GNOME=#USE_GNOME=' ${BUILD_WRKSRC}/Makefile
+.endif
do-install:
${INSTALL_DATA} ${BUILD_WRKSRC}/gnocl.so ${PREFIX}/lib/libgnocl.so.1
if ${TEST} -f ${BUILD_WRKSRC}/gnoclCanvas.so; then \
${INSTALL_DATA} ${BUILD_WRKSRC}/gnoclCanvas.so ${PREFIX}/lib/libgnoclCanvas.so.1; \
fi; \
+ if ${TEST} -f ${BUILD_WRKSRC}/gnoclGconf.so; then \
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/gnoclGconf.so ${PREFIX}/lib/libgnoclGconf.so.1; \
+ fi; \
+ if ${TEST} -f ${BUILD_WRKSRC}/gnoclGnome.so; then \
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/gnoclGnome.so ${PREFIX}/lib/libgnoclGnome.so.1; \
+ fi; \
.include <bsd.port.post.mk>