aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gnocl
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-07-18 08:44:53 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-07-18 08:44:53 +0000
commit17f544534eb424175cd6d3d269aeee2e38afa860 (patch)
treeb6a9d7ddabc6bf47caff66fd9872d7611eed5745 /x11-toolkits/gnocl
parentb09bad088013ff6944eb1c50c6ee00572021c0fd (diff)
downloadports-17f544534eb424175cd6d3d269aeee2e38afa860.tar.gz
ports-17f544534eb424175cd6d3d269aeee2e38afa860.zip
Notes
Diffstat (limited to 'x11-toolkits/gnocl')
-rw-r--r--x11-toolkits/gnocl/Makefile2
-rw-r--r--x11-toolkits/gnocl/distinfo4
-rw-r--r--x11-toolkits/gnocl/files/patch-src_gnocl.c11
-rw-r--r--x11-toolkits/gnocl/files/patch-src_pixBufFilters.c12
4 files changed, 26 insertions, 3 deletions
diff --git a/x11-toolkits/gnocl/Makefile b/x11-toolkits/gnocl/Makefile
index 267c524278d4..3460dbb3cdf7 100644
--- a/x11-toolkits/gnocl/Makefile
+++ b/x11-toolkits/gnocl/Makefile
@@ -24,7 +24,7 @@ USE_LDCONFIG= yes
CFLAGS+= -I${TCL_INCLUDEDIR} -L${TCL_LIBDIR} `pkg-config --cflags libglade-2.0`
BASE_VERSION= 0.9.95
-NIGHTLY_BUILD= 10-05-11
+NIGHTLY_BUILD= 30-06-11
WRKSRC= ${WRKDIR}/${PORTNAME}-${BASE_VERSION}
BUILD_WRKSRC= ${WRKSRC}/src
diff --git a/x11-toolkits/gnocl/distinfo b/x11-toolkits/gnocl/distinfo
index 30987defa3d0..37381218a306 100644
--- a/x11-toolkits/gnocl/distinfo
+++ b/x11-toolkits/gnocl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnocl-0.9.95-10-05-11.tar.bz2) = 3b719d4e78949cff43a7d7bdb52174310236fbcdf3b0342e86341216850b509f
-SIZE (gnocl-0.9.95-10-05-11.tar.bz2) = 992044
+SHA256 (gnocl-0.9.95-30-06-11.tar.bz2) = 98e9bb6ea1a1fdcc1d2161070d2c3e0479e48b042a138fde7d29834c9e953b2f
+SIZE (gnocl-0.9.95-30-06-11.tar.bz2) = 1003258
diff --git a/x11-toolkits/gnocl/files/patch-src_gnocl.c b/x11-toolkits/gnocl/files/patch-src_gnocl.c
new file mode 100644
index 000000000000..6dd2f50b5f82
--- /dev/null
+++ b/x11-toolkits/gnocl/files/patch-src_gnocl.c
@@ -0,0 +1,11 @@
+--- src/gnocl.c.orig 2011-07-18 10:33:09.000000000 +0200
++++ src/gnocl.c 2011-07-18 10:33:16.000000000 +0200
+@@ -647,7 +647,7 @@
+ /* non-gtk widgets */
+ { "spinner", gnoclSpinnerCmd },
+ { "dial", gnoclDialCmd },
+- { "imageViewer", gnoclImageViewerCmd },
++// { "imageViewer", gnoclImageViewerCmd },
+
+ /* gnocl only widget */
+ { "splashScreen", gnoclSplashScreenCmd },
diff --git a/x11-toolkits/gnocl/files/patch-src_pixBufFilters.c b/x11-toolkits/gnocl/files/patch-src_pixBufFilters.c
new file mode 100644
index 000000000000..a578b4fed663
--- /dev/null
+++ b/x11-toolkits/gnocl/files/patch-src_pixBufFilters.c
@@ -0,0 +1,12 @@
+--- src/pixBufFilters.c.orig 2011-07-18 09:45:14.000000000 +0200
++++ src/pixBufFilters.c 2011-07-18 09:45:20.000000000 +0200
+@@ -14,9 +14,6 @@
+ #include <string.h>
+ #include <assert.h>
+
+-static guint32 convertRGBtoPixel ( gchar *clr );
+-
+-
+ int isBlack ( GdkPixbuf *pixbuf, gint x, gint y, gint threshold )
+ {
+ guchar *pixels;