aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gnustep-gui/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-08-23 10:49:48 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-08-23 10:49:48 +0000
commit6ffe0e82a84f610ba149fed661b7185640da0913 (patch)
treee87ac59bdfdab65582d1dd8d7ba0855d896e8c63 /x11-toolkits/gnustep-gui/Makefile
parent0e47114f8742bbf513da0c9e2d1b353dc79ca7a6 (diff)
downloadports-6ffe0e82a84f610ba149fed661b7185640da0913.tar.gz
ports-6ffe0e82a84f610ba149fed661b7185640da0913.zip
Notes
Diffstat (limited to 'x11-toolkits/gnustep-gui/Makefile')
-rw-r--r--x11-toolkits/gnustep-gui/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index 67bdd9f9e9d9..1ed7822d87f5 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnustep
-PORTVERSION= 0.6.5
+PORTVERSION= 0.6.6
CATEGORIES= devel
MASTER_SITES= ftp://ftp.gnustep.org/pub/gnustep/core/ \
ftp://ftp.peanuts.org/Mirrors/GNUstep/gnustep/core/
@@ -25,15 +25,15 @@ BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
USE_NEWGCC= yes
PREFIX= ${LOCALBASE}/GNUstep
-WRKSRC= ${WRKDIR}/gstep-0.6.5
+WRKSRC= ${WRKDIR}/${DISTNAME}
GNU_CONFIGURE= yes
CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c"
CONFIGURE_ARGS= --with-library-combo=gnu-gnu-gnu-xgps \
--with-jpeg-library=${LOCALBASE}/lib \
--with-jpeg-include=${LOCALBASE}/include \
--with-tiff-library=${LOCALBASE}/lib \
- --with-tiff-include=${LOCALBASE}/include \
- --enable-threads=posix
+ --with-tiff-include=${LOCALBASE}/include # --enable-threads=posix
+CONFIGURE_TARGET=
USE_GMAKE= yes
USE_XLIB= yes
MAKEFILE=
@@ -45,7 +45,6 @@ GNU_ARCH= ix86
.else
GNU_ARCH= ${MACHINE_ARCH}
.endif
-GNU_HOST= freebsd${OSREL}
-PLIST_SUB+= GNU_ARCH=${GNU_ARCH} GNU_HOST=${GNU_HOST}
+PLIST_SUB+= GNU_ARCH=${GNU_ARCH} VERSION=${PORTVERSION}
.include <bsd.port.post.mk>