aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gnustep-gui
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-12-23 22:13:53 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-12-23 22:13:53 +0000
commit7155542038b8b409839d291a48f6e100e49eeef1 (patch)
tree3629f899f9ed20f0d523190512059651d164b98a /x11-toolkits/gnustep-gui
parent7f0a29087aca61f5af1a289634209b2c8d4ee001 (diff)
downloadports-7155542038b8b409839d291a48f6e100e49eeef1.tar.gz
ports-7155542038b8b409839d291a48f6e100e49eeef1.zip
Notes
Diffstat (limited to 'x11-toolkits/gnustep-gui')
-rw-r--r--x11-toolkits/gnustep-gui/Makefile22
-rw-r--r--x11-toolkits/gnustep-gui/files/patch-pa_unix_oss.c14
2 files changed, 29 insertions, 7 deletions
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index b761e7990ddf..1e9c7de94b1d 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -13,7 +13,9 @@ PORTVERSION= 0.7.6
.endif
CATEGORIES= x11-toolkits
.if defined(GNUSTEP_GUI_DEVEL)
-MASTER_SITES= ftp://ftp.gnustep.org/pub/gnustep/core/
+MASTER_SITES= ${MASTER_SITE_GNUSTEP} \
+ ftp://ftp.gnustep.org/pub/gnustep/%SUBDIR%/
+MASTER_SITE_SUBDIR= core
PKGNAMESUFFIX?= -devel
.else
MASTER_SITES= ${MASTER_SITE_LOCAL}
@@ -49,12 +51,14 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET=
USE_GMAKE= yes
MAKEFILE=
-MAKE_FLAGS= OPTFLAG="${CFLAGS}"
+MAKE_FLAGS+= OPTFLAG="${CFLAGS}"
+MAKE_FLAGS+= ADDITIONAL_LIB_DIRS=/usr/local/lib to core/gui/Source/GNUmakefile.preamble
NO_MTREE= yes
CONFIGURE_ARGS+= --with-tiff-library=${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-tiff-include=${LOCALBASE}/include
CONFIGURE_ARGS+= --with-jpeg-library=${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-jpeg-include=${LOCALBASE}/include
+EXTRA_FIX= ${WRKSRC}/Tools/gsnd/portaudio/pa_unix_oss/Makefile
.if ${MACHINE_ARCH} == "i386"
GNU_ARCH= ix86
@@ -71,6 +75,12 @@ post-extract:
@${CP} ${PREFIX}/System/Makefiles/${file} ${WRKSRC}
.endfor
+pre-configure:
+ @ ${MV} ${EXTRA_FIX} ${EXTRA_FIX}.sed
+ ${SED} -e "s=-lphread=${PTHREAD_LIBS}=" -e "s;CFLAGS =;CFLAGS+=;" \
+ -e "s;-Wall;-Wall ${PTHREAD_CFLAGS:S=""==};" \
+ ${EXTRA_FIX}.sed > ${EXTRA_FIX}
+
do-configure:
@(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
if ! ${SETENV} CC="${CC}" CXX="${CXX}" \
@@ -94,10 +104,8 @@ do-install:
@(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
-.if defined(GNUSTEP_GUI_DEVEL)
-.if ${OSVERSION} > 500030
-CONFIGURE_ARGS+= --disable-gsnd
-.endif
-.endif
+test:
+ @(cd ${WRKSRC}/Tools/gsnd/portaudio/pa_unix_oss && \
+ ${GMAKE} && ./patest)
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/gnustep-gui/files/patch-pa_unix_oss.c b/x11-toolkits/gnustep-gui/files/patch-pa_unix_oss.c
new file mode 100644
index 000000000000..4a88b41dee54
--- /dev/null
+++ b/x11-toolkits/gnustep-gui/files/patch-pa_unix_oss.c
@@ -0,0 +1,14 @@
+--- Tools/gsnd/portaudio/pa_unix_oss/pa_unix_oss.c.orig Wed Oct 2 05:34:54 2002
++++ Tools/gsnd/portaudio/pa_unix_oss/pa_unix_oss.c Mon Dec 2 09:21:34 2002
+@@ -110,7 +110,11 @@
+ #ifdef __linux__
+ #include <linux/soundcard.h>
+ #else
++#ifdef __FreeBSD__
++#include <sys/soundcard.h>
++#else
+ #include <machine/soundcard.h> /* JH20010905 */
++#endif
+ #endif
+
+ #include "portaudio.h"