aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gnustep-gui
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-02-25 13:24:12 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2007-02-25 13:24:12 +0000
commitd23fe039b93b7e4caa670dfd392bcb61d9eff555 (patch)
treea82017d79037d86fcc64d4759c25439b014d77f1 /x11-toolkits/gnustep-gui
parente0074eaf499cd86f2d87e155845536a88eaa2591 (diff)
downloadports-d23fe039b93b7e4caa670dfd392bcb61d9eff555.tar.gz
ports-d23fe039b93b7e4caa670dfd392bcb61d9eff555.zip
Notes
Diffstat (limited to 'x11-toolkits/gnustep-gui')
-rw-r--r--x11-toolkits/gnustep-gui/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index 2296a665ec71..a8f1dbb07a10 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -38,6 +38,7 @@ USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
USE_XLIB= yes
EXTRA_PATCHES+= ${FILESDIR}/GNUmakefile.patch
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAKE_FLAGS+= OPTFLAG="${CFLAGS}"
BREAKS_IF_PEDANTIC= yes
@@ -49,6 +50,13 @@ IGNORE= requires procfs mounted to build or run, for details see procfs(5)
.endif
.endif
+.if defined(WITH_PORTAUDIO2)
+LIB_DEPENDS+= portaudio:${PORTSDIR}/audio/portaudio2
+CPPFLAGS+= -I${LOCALBASE}/include/portaudio2 ${PTHREAD_CFLAGS}
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib/portaudio2 ${PTHREAD_LIBS}
+.endif
+
.if !defined(WITHOUT_CUPS)
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
PLIST_SUB+= WITH_CUPS=""