aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/granite
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2014-05-29 17:26:42 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2014-05-29 17:26:42 +0000
commitfa91bbab04c70b9def1f0675507f7ca6c709a1a5 (patch)
tree0db2e53ceda30675a4769c809a9b407bd78c4903 /x11-toolkits/granite
parent4c8736f8f1f68a11164aa1aacb5e043948970220 (diff)
downloadports-fa91bbab04c70b9def1f0675507f7ca6c709a1a5.tar.gz
ports-fa91bbab04c70b9def1f0675507f7ca6c709a1a5.zip
Notes
Diffstat (limited to 'x11-toolkits/granite')
-rw-r--r--x11-toolkits/granite/Makefile3
-rw-r--r--x11-toolkits/granite/distinfo4
-rw-r--r--x11-toolkits/granite/files/patch-CMakeLists.txt24
-rw-r--r--x11-toolkits/granite/files/patch-lib__Application.vala24
-rw-r--r--x11-toolkits/granite/pkg-plist2
5 files changed, 48 insertions, 9 deletions
diff --git a/x11-toolkits/granite/Makefile b/x11-toolkits/granite/Makefile
index a77959f9ef4b..0cd3faabe576 100644
--- a/x11-toolkits/granite/Makefile
+++ b/x11-toolkits/granite/Makefile
@@ -4,9 +4,11 @@
PORTNAME= granite
PORTVERSION= 0.2.3.1
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= https://launchpadlibrarian.net/169958088/ \
https://launchpad.net/${PORTNAME}/0.2/${PORTVERSION}/+download/
+DIST_SUBDIR= eos
MAINTAINER= olivierd@FreeBSD.org
COMMENT= Extensions of Gtk+ toolkit
@@ -15,6 +17,7 @@ LICENSE= GPLv3
BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
LIB_DEPENDS= libgee-0.8.so:${PORTSDIR}/devel/libgee
+RUN_DEPENDS= contractor:${PORTSDIR}/sysutils/contractor
USE_GCC= yes
USES= cmake pkgconfig gettext tar:tgz
diff --git a/x11-toolkits/granite/distinfo b/x11-toolkits/granite/distinfo
index b72915b4a8be..efc437e89001 100644
--- a/x11-toolkits/granite/distinfo
+++ b/x11-toolkits/granite/distinfo
@@ -1,2 +1,2 @@
-SHA256 (granite-0.2.3.1.tgz) = 56f05338bb7967f0b912d35bf780a3ddd68b517e1939371a14a5f79581a8f80d
-SIZE (granite-0.2.3.1.tgz) = 152607
+SHA256 (eos/granite-0.2.3.1.tgz) = 56f05338bb7967f0b912d35bf780a3ddd68b517e1939371a14a5f79581a8f80d
+SIZE (eos/granite-0.2.3.1.tgz) = 152607
diff --git a/x11-toolkits/granite/files/patch-CMakeLists.txt b/x11-toolkits/granite/files/patch-CMakeLists.txt
index 0357d48a268e..f85add1cbcbf 100644
--- a/x11-toolkits/granite/files/patch-CMakeLists.txt
+++ b/x11-toolkits/granite/files/patch-CMakeLists.txt
@@ -1,5 +1,5 @@
---- ./CMakeLists.txt.orig 2013-12-15 12:43:00.000000000 +0000
-+++ ./CMakeLists.txt 2013-12-26 19:54:31.000000000 +0000
+--- ./CMakeLists.txt.orig 2014-03-18 20:51:49.000000000 +0000
++++ ./CMakeLists.txt 2014-05-29 09:36:44.000000000 +0000
@@ -24,12 +24,28 @@
include (CPack)
add_custom_target (dist COMMAND ${CMAKE_MAKE_PROGRAM} package_source)
@@ -29,7 +29,7 @@
#
# Packages in PKG_DEPS are used with the vala compiler and other related tools (not versioned.)
# Packages in PKG_DEPS_CHECK are used with PKG-Config and for linking, etc. They can contain versions.
-@@ -42,19 +58,18 @@
+@@ -42,31 +58,37 @@
gtk+-3.0
gio-unix-2.0
posix
@@ -52,11 +52,25 @@
pkg_check_modules (DEPS REQUIRED ${PKG_DEPS_CHECK})
set (VALAC_OPTIONS
-@@ -66,7 +81,6 @@
+ --thread
+ --target-glib=2.32)
+
+-if (CMAKE_SYSTEM_NAME MATCHES "Linux")
++if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+ set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=LINUX)
++elseif (${CMAKE_SYSTEM_NAME} MATCHES "DragonFly")
++ set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=DragonFly)
++elseif (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
++ set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=FreeBSD)
++elseif (${CMAKE_SYSTEM_NAME} MATCHES "NetBSD")
++ set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=NetBSD)
++elseif (${CMAKE_SYSTEM_NAME} MATCHES "OpenBSD")
++ set (VALAC_OPTIONS ${VALAC_OPTIONS} --define=OpenBSD)
endif ()
add_subdirectory (lib)
-add_subdirectory (demo)
- add_subdirectory (doc)
+-add_subdirectory (doc)
++#add_subdirectory (doc)
add_subdirectory (po)
add_subdirectory (icons)
diff --git a/x11-toolkits/granite/files/patch-lib__Application.vala b/x11-toolkits/granite/files/patch-lib__Application.vala
new file mode 100644
index 000000000000..cbbfcde92052
--- /dev/null
+++ b/x11-toolkits/granite/files/patch-lib__Application.vala
@@ -0,0 +1,24 @@
+--- ./lib/Application.vala.orig 2014-03-18 20:51:49.000000000 +0000
++++ ./lib/Application.vala 2014-05-29 09:42:26.000000000 +0000
+@@ -69,6 +69,8 @@
+ public Application () {
+ #if LINUX
+ prctl (15, exec_name, 0, 0, 0);
++#elif DragonFly || FreeBSD || NetBSD || OpenBSD
++ setproctitle (exec_name);
+ #endif
+ Environment.set_prgname (exec_name);
+
+@@ -90,6 +92,12 @@
+ #if LINUX
+ [CCode (cheader_filename = "sys/prctl.h", cname = "prctl")]
+ protected extern static int prctl (int option, string arg2, ulong arg3, ulong arg4, ulong arg5);
++#elif DragonFly || FreeBSD
++ [CCode (cheader_filename = "unistd.h", cname = "setproctitle")]
++ protected extern static void setproctitle (string fmt, ...);
++#elif NetBSD || OpenBSD
++ [CCode (cheader_filename = "stdlib.h", cname = "setproctitle")]
++ protected extern static void setproctitle (string fmt, ...);
+ #endif
+
+ /**
diff --git a/x11-toolkits/granite/pkg-plist b/x11-toolkits/granite/pkg-plist
index 1f8a751593c0..11b9e0b3f979 100644
--- a/x11-toolkits/granite/pkg-plist
+++ b/x11-toolkits/granite/pkg-plist
@@ -71,8 +71,6 @@ share/locale/zh_CN/LC_MESSAGES/granite.mo
share/locale/zh_TW/LC_MESSAGES/granite.mo
share/vala/vapi/granite.deps
share/vala/vapi/granite.vapi
-@dirrmtry share/vala/vapi
-@dirrmtry share/vala
@dirrmtry share/locale/ug/LC_MESSAGES
@dirrmtry share/locale/ug
@dirrmtry share/locale/te/LC_MESSAGES