aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk-sharp10/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-15 21:41:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-15 21:41:38 +0000
commit0a9455e3c063826cf5ada5984503d823e10b40c0 (patch)
treef772e98b65f49effc3751a5b55322f8fb67520a3 /x11-toolkits/gtk-sharp10/Makefile
parent5059990708ea4f0c566c19196eca096f0a392842 (diff)
Notes
Diffstat (limited to 'x11-toolkits/gtk-sharp10/Makefile')
-rw-r--r--x11-toolkits/gtk-sharp10/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/x11-toolkits/gtk-sharp10/Makefile b/x11-toolkits/gtk-sharp10/Makefile
index f2c3fb07a596..1c61c9e5b5bb 100644
--- a/x11-toolkits/gtk-sharp10/Makefile
+++ b/x11-toolkits/gtk-sharp10/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gtk-sharp
-PORTVERSION= 0.11
+PORTVERSION= 0.14
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gtk-sharp
@@ -14,14 +14,20 @@ MASTER_SITE_SUBDIR= gtk-sharp
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gtk+ and GNOME interfaces for the .NET runtime
-BUILD_DEPENDS+= mono:${PORTSDIR}/lang/mono
-LIB_DEPENDS+= pgeasy.2:${PORTSDIR}/databases/postgresql72
-
-# XXX Should conditionalise all the different parts of gtk# maybe.
+BUILD_DEPENDS+= mono:${PORTSDIR}/lang/mono \
+ gst-launch:${PORTSDIR}/multimedia/gstreamer
+RUN_DEPENDS+= ${BUILD_DEPENDS}
USE_LIBTOOL= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack libgda2 libgnomeui libgnomedb
+USE_GNOME= gnomehack libgda2 libgnomeui libgnomedb libgtkhtml
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|lib/pkgconfig|libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|lib/pkgconfig|libdata/pkgconfig|g' \
+ ${WRKSRC}/parser/Makefile.in
.include <bsd.port.mk>