aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk30/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-06-26 09:18:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-06-26 09:18:37 +0000
commit58d6153c1e523d4aeede7753ecf4879e60825b69 (patch)
treeb731abccc22c5da200d9004c6ef85df0fd11f659 /x11-toolkits/gtk30/Makefile
parent8748cab92fd1c74d6ee50e6aa29441042017c7ab (diff)
downloadports-58d6153c1e523d4aeede7753ecf4879e60825b69.tar.gz
ports-58d6153c1e523d4aeede7753ecf4879e60825b69.zip
Notes
Diffstat (limited to 'x11-toolkits/gtk30/Makefile')
-rw-r--r--x11-toolkits/gtk30/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index 514f49290e2d..f982490bc45d 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= gtk
-PORTVERSION= 2.0.3
+PORTVERSION= 2.0.5
CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,pre-gnome2/releases/gnome-2.0-desktop-rc1,} \
+MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,pre-gnome2/releases/gnome-2.0-desktop-rc2,} \
ftp://ftp.gtk.org/pub/gtk/v2.0/ \
ftp://ftp.gimp.org/pub/%SUBDIR%/ \
ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
@@ -31,6 +31,7 @@ USE_BZIP2= yes
NO_LATEST_LINK= yes
USE_X_PREFIX= yes
USE_XPM= yes
+USE_REINPLACE= yes
USE_PERL5= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
@@ -45,9 +46,9 @@ MAN1= gdk-pixbuf-csource.1
post-extract:
@find ${WRKSRC} -name "Makefile.in" | xargs ${GREP} -l lgmodule | \
- xargs ${PERL} -pi -e 's|-lgmodule|\@GMODULE_LIBS\@|g'
- @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
- 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+ xargs ${REINPLACE_CMD} -e 's|-lgmodule|@GMODULE_LIBS@|g'
+ @find ${WRKSRC} -name Makefile.in | xargs ${REINPLACE_CMD} -e \
+ 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
pre-build:
${RM} -rf ${WRKSRC}/docs/gtk.info*