aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk30
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-02-25 22:04:57 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-02-25 22:04:57 +0000
commita48caf676af8e156daa493a4f447f36ff7fc2a82 (patch)
tree5c0aa08b3e7b7dbdde4587b48b89b43ee83ab11a /x11-toolkits/gtk30
parent4684488d86d4330191cf07d89f1c8f6e826d0e1f (diff)
downloadports-a48caf676af8e156daa493a4f447f36ff7fc2a82.tar.gz
ports-a48caf676af8e156daa493a4f447f36ff7fc2a82.zip
Notes
Diffstat (limited to 'x11-toolkits/gtk30')
-rw-r--r--x11-toolkits/gtk30/Makefile2
-rw-r--r--x11-toolkits/gtk30/files/patch-gtk-56158316
2 files changed, 17 insertions, 1 deletions
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index b547bb10d663..a50209f21134 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gtk
PORTVERSION= 2.14.7
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/,} \
ftp://ftp.gtk.org/pub/gtk/%SUBDIR%/ \
diff --git a/x11-toolkits/gtk30/files/patch-gtk-561583 b/x11-toolkits/gtk30/files/patch-gtk-561583
new file mode 100644
index 000000000000..f9a547805fcf
--- /dev/null
+++ b/x11-toolkits/gtk30/files/patch-gtk-561583
@@ -0,0 +1,16 @@
+--- gdk/x11/gdkscreen-x11.orig 2009-02-18 15:29:15.000000000 -0500
++++ gdk/x11/gdkscreen-x11.c 2009-02-18 15:30:03.000000000 -0500
+@@ -915,11 +915,12 @@
+ return;
+ #endif
+
++ _gdk_x11_screen_process_monitors_change (screen);
++
+ if (width == gdk_screen_get_width (screen) &&
+ height == gdk_screen_get_height (screen))
+ return;
+
+- _gdk_x11_screen_process_monitors_change (screen);
+ g_signal_emit_by_name (screen, "size_changed");
+ }
+