aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtkdatabox/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2012-12-08 02:29:45 +0000
committerBeech Rintoul <beech@FreeBSD.org>2012-12-08 02:29:45 +0000
commit79656410fb0a7fb38b68a0f5db5d7dcb8e8861d1 (patch)
tree2b04e52c539d998268fc56c704188e93a18f0594 /x11-toolkits/gtkdatabox/Makefile
parent98bec1ae19e4c0de2e399d185d774e72ef1d0db3 (diff)
downloadports-79656410fb0a7fb38b68a0f5db5d7dcb8e8861d1.tar.gz
ports-79656410fb0a7fb38b68a0f5db5d7dcb8e8861d1.zip
Notes
Diffstat (limited to 'x11-toolkits/gtkdatabox/Makefile')
-rw-r--r--x11-toolkits/gtkdatabox/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/x11-toolkits/gtkdatabox/Makefile b/x11-toolkits/gtkdatabox/Makefile
index 32a973a60a35..5fb1808c5ded 100644
--- a/x11-toolkits/gtkdatabox/Makefile
+++ b/x11-toolkits/gtkdatabox/Makefile
@@ -1,13 +1,8 @@
-# ex:ts=8
-# Ports collection makefile for: gtkdatabox
-# Date created: Mar 20, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= gtkdatabox
-PORTVERSION= 0.9.1.3
+PORTVERSION= 0.9.2.0
CATEGORIES= x11-toolkits
MASTER_SITES= SF
DIST_SUBDIR= gnome2
@@ -22,13 +17,16 @@ GLADE_DESC= Enable libglade2 support
GLADEUI_DESC= Enable glade3 support
USE_GNOME= gnomehack gtk20
+USE_PKGCONFIG= build
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --includedir="${PREFIX}/include/${PORTNAME}" \
--with-html-dir="${PREFIX}/share/doc"
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
MAKE_JOBS_SAFE= yes
+PORTDOCS= *
+PORTEXAMPLES= *
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGLADE}
@@ -61,11 +59,11 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/reference/html/*.* ${DOCSDIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} api ${DOCSDIR})
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/*.c ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${INSTALL_DATA} *.c ${EXAMPLESDIR})
.endif
.include <bsd.port.mk>