aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtkglarea--/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-05 17:50:55 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-05 17:50:55 +0000
commit1b8c93992b609221906dda4dc59b12b17e23378e (patch)
tree0d7ee89c0796e54ec2565c013da099612ffc82d8 /x11-toolkits/gtkglarea--/Makefile
parent2cfd59874c71c9aa1a8b9a6956cc76b2bd2c2eb8 (diff)
downloadports-1b8c93992b609221906dda4dc59b12b17e23378e.tar.gz
ports-1b8c93992b609221906dda4dc59b12b17e23378e.zip
Notes
Diffstat (limited to 'x11-toolkits/gtkglarea--/Makefile')
-rw-r--r--x11-toolkits/gtkglarea--/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-toolkits/gtkglarea--/Makefile b/x11-toolkits/gtkglarea--/Makefile
new file mode 100644
index 000000000000..d51792bf96f2
--- /dev/null
+++ b/x11-toolkits/gtkglarea--/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: gtkglarea--
+# Date created: Dec 5, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkglareamm
+PORTVERSION= 1.1.1
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://www.ece.ucdavis.edu/~kenelson/gtk-glarea/dist/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gtkmm:${PORTSDIR}/x11-toolkits/gtk-- \
+ gtkgl:${PORTSDIR}/x11-toolkits/gtkglarea
+
+USE_GTK= yes
+USE_MESA= yes
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --with-lib-GL
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>