aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtkglarea--/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-06-03 20:18:13 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-06-03 20:18:13 +0000
commit6bb41db8de2d230dc7094adc1e6814b4d08a8f6e (patch)
tree42a20005016b408ec71bd095c4b1866ea68b233d /x11-toolkits/gtkglarea--/Makefile
parent13142dd19cb90b39fac29bd90bd4920febccdd35 (diff)
Notes
Diffstat (limited to 'x11-toolkits/gtkglarea--/Makefile')
-rw-r--r--x11-toolkits/gtkglarea--/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11-toolkits/gtkglarea--/Makefile b/x11-toolkits/gtkglarea--/Makefile
index a1876a631338..9ff656d2cf3a 100644
--- a/x11-toolkits/gtkglarea--/Makefile
+++ b/x11-toolkits/gtkglarea--/Makefile
@@ -21,7 +21,8 @@ LIB_DEPENDS= gtkmm.2:${PORTSDIR}/x11-toolkits/gtk-- \
USE_GL= yes
USE_GNOME= gtk12
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-lib-GL
INSTALLS_SHLIB= yes
@@ -30,4 +31,8 @@ CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lGL -lGLU \
${PTHREAD_LIBS}
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>