aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtkimageview/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-01 08:31:50 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-01 08:31:50 +0000
commit56704f7e73bd5c56d478bfcc7e5f048b3357d214 (patch)
treedcdc7b795f08be5f8fe4971cf0e958be73c86d1f /x11-toolkits/gtkimageview/Makefile
parenta442b55fa67254fa8c107329a5c64a0f093b65c3 (diff)
downloadports-56704f7e73bd5c56d478bfcc7e5f048b3357d214.tar.gz
ports-56704f7e73bd5c56d478bfcc7e5f048b3357d214.zip
Notes
Diffstat (limited to 'x11-toolkits/gtkimageview/Makefile')
-rw-r--r--x11-toolkits/gtkimageview/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-toolkits/gtkimageview/Makefile b/x11-toolkits/gtkimageview/Makefile
new file mode 100644
index 000000000000..1b897793e10c
--- /dev/null
+++ b/x11-toolkits/gtkimageview/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gtkimageview
+# Date created: 1 August 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkimageview
+PORTVERSION= 1.3.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= CENKES
+# http://trac.bjourne.webfactional.com/
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Simple image viewer widget
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+USE_GNOME= gtk20
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CFLAGS/s|-Werror||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^pkgconfigdir/s|=.*|=${PREFIX}/libdata/pkgconfig|'\
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>