aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtkmm20/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-11 19:59:09 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-11 19:59:09 +0000
commita90b2589720af8b585e6a436ae5e01aa32a3ee00 (patch)
tree8cc0532b87e4da3a0916accfb5d88643ffc645d8 /x11-toolkits/gtkmm20/Makefile
parentc28c1bb7e5d241cc5e050c2d1f463a061f71ca67 (diff)
downloadports-a90b2589720af8b585e6a436ae5e01aa32a3ee00.tar.gz
ports-a90b2589720af8b585e6a436ae5e01aa32a3ee00.zip
Notes
Diffstat (limited to 'x11-toolkits/gtkmm20/Makefile')
-rw-r--r--x11-toolkits/gtkmm20/Makefile30
1 files changed, 14 insertions, 16 deletions
diff --git a/x11-toolkits/gtkmm20/Makefile b/x11-toolkits/gtkmm20/Makefile
index fbf06e469ad9..47a7119ac518 100644
--- a/x11-toolkits/gtkmm20/Makefile
+++ b/x11-toolkits/gtkmm20/Makefile
@@ -7,7 +7,6 @@
PORTNAME= gtkmm
PORTVERSION= 2.2.12
-PORTREVISION= 5
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME} \
${MASTER_SITE_SOURCEFORGE}
@@ -18,12 +17,18 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= C++ wrapper for Gtk+, Pango, Atk, and Glib
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+LATEST_LINK= gtkmm2
+
+.if !defined(REFERENCE_PORT)
+
+PORTREVISION= 6
+
LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-USE_BZIP2= yes
-USE_X_PREFIX= yes
-LATEST_LINK= gtkmm2
+USE_XLIB= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
@@ -32,18 +37,11 @@ USE_GNOME= gnomehack lthack gtk20
CONFIGURE_ARGS= --enable-static=yes \
--with-sigc-prefix=${LOCALBASE}
-.if defined(WITH_EXAMPLES)
-PLIST_SUB+= EXAMPLES=""
-.else
-PLIST_SUB+= EXAMPLES="@comment "
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e '/^SUBDIRS =/s/tests//' \
- ${WRKSRC}/Makefile.in
-.if !defined(WITH_EXAMPLES)
- @${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
- ${WRKSRC}/Makefile.in
-.endif
+.for d in docs examples tests
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s/${d}//' ${WRKSRC}/Makefile.in
+.endfor
.include <bsd.port.mk>
+
+.endif