aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtksourceview-sharp/Makefile
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2006-02-19 08:23:42 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2006-02-19 08:23:42 +0000
commit40c7451230a26c16e58b1d54eb2d8e545c33ec29 (patch)
tree43633a09f6b12c74e4074c3dacfad14895490adb /x11-toolkits/gtksourceview-sharp/Makefile
parent0f5f09ee5d0899a6f5c5f46f75b35032664df6d2 (diff)
downloadports-40c7451230a26c16e58b1d54eb2d8e545c33ec29.tar.gz
ports-40c7451230a26c16e58b1d54eb2d8e545c33ec29.zip
Notes
Diffstat (limited to 'x11-toolkits/gtksourceview-sharp/Makefile')
-rw-r--r--x11-toolkits/gtksourceview-sharp/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-toolkits/gtksourceview-sharp/Makefile b/x11-toolkits/gtksourceview-sharp/Makefile
new file mode 100644
index 000000000000..e0323df68d95
--- /dev/null
+++ b/x11-toolkits/gtksourceview-sharp/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: gtksourceview-sharp
+# Date created: 20040821
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.24 2006/02/01 23:02:05 tmclau02 Exp $
+#
+
+PORTNAME= gtksourceview-sharp
+PORTVERSION= 0.10
+PORTREVISION= 4
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://go-mono.com/sources/gtksourceview-sharp-2.0/
+DISTNAME= ${PORTNAME}-2.0-${PORTVERSION}
+
+MAINTAINER= tmclaugh@sdf.lonestar.org
+COMMENT= gtksourview bindings for Mono
+
+BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono \
+ gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
+ monodoc:${PORTSDIR}/devel/mono-tools
+RUN_DEPENDS= mono:${PORTSDIR}/lang/mono \
+ gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
+ monodoc:${PORTSDIR}/devel/mono-tools
+
+USE_GNOME= gtksourceview gnomehack
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= libtool:15
+USE_GMAKE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|[(]prefix[)]/lib/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
+
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
+.include <bsd.port.mk>