aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtksourceview
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-05-08 00:34:09 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-05-08 00:34:09 +0000
commitd22e617995259c970604ecb95987596011fcab19 (patch)
treeaf804fe6ae63af80be9abbb30f08ca1dc55815a9 /x11-toolkits/gtksourceview
parent0ee4b84c904dfdd063a47fddde47bab724e05301 (diff)
downloadports-d22e617995259c970604ecb95987596011fcab19.tar.gz
ports-d22e617995259c970604ecb95987596011fcab19.zip
Notes
Diffstat (limited to 'x11-toolkits/gtksourceview')
-rw-r--r--x11-toolkits/gtksourceview/Makefile32
-rw-r--r--x11-toolkits/gtksourceview/distinfo1
-rw-r--r--x11-toolkits/gtksourceview/files/patch-configure10
-rw-r--r--x11-toolkits/gtksourceview/files/patch-gtksourceview_gtksourcebuffer.c14
-rw-r--r--x11-toolkits/gtksourceview/files/patch-gtksourceview_gtksourceregex.h11
-rw-r--r--x11-toolkits/gtksourceview/files/patch-gtksourceview_gtksourceview.c13
-rw-r--r--x11-toolkits/gtksourceview/pkg-descr3
-rw-r--r--x11-toolkits/gtksourceview/pkg-plist31
8 files changed, 115 insertions, 0 deletions
diff --git a/x11-toolkits/gtksourceview/Makefile b/x11-toolkits/gtksourceview/Makefile
new file mode 100644
index 000000000000..ab5cbcd650c0
--- /dev/null
+++ b/x11-toolkits/gtksourceview/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gtksourceview
+# Date created: 07 May 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtksourceview
+PORTVERSION= 0.2.0
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.2
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A text widget that adds syntax highlighting to the GtkTextView widget
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+USE_GNOME= gnomeprefix gnomehack libgnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -lgnuregex"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gtksourceview/distinfo b/x11-toolkits/gtksourceview/distinfo
new file mode 100644
index 000000000000..a5af0429fb5a
--- /dev/null
+++ b/x11-toolkits/gtksourceview/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/gtksourceview-0.2.0.tar.bz2) = 3b3cae93b4f00f920cdae3a1cb096e75
diff --git a/x11-toolkits/gtksourceview/files/patch-configure b/x11-toolkits/gtksourceview/files/patch-configure
new file mode 100644
index 000000000000..6718d62e1a0f
--- /dev/null
+++ b/x11-toolkits/gtksourceview/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Tue Dec 17 05:27:57 2002
++++ configure Sun Dec 22 17:31:25 2002
+@@ -7270,6 +7270,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/x11-toolkits/gtksourceview/files/patch-gtksourceview_gtksourcebuffer.c b/x11-toolkits/gtksourceview/files/patch-gtksourceview_gtksourcebuffer.c
new file mode 100644
index 000000000000..b6aa901c17a9
--- /dev/null
+++ b/x11-toolkits/gtksourceview/files/patch-gtksourceview_gtksourcebuffer.c
@@ -0,0 +1,14 @@
+--- gtksourceview/gtksourcebuffer.c.orig Wed May 7 20:05:58 2003
++++ gtksourceview/gtksourcebuffer.c Wed May 7 20:06:18 2003
+@@ -687,9 +687,10 @@
+ static void
+ get_tags_func (GtkTextTag *tag, gpointer data)
+ {
++ GSList **list;
+ g_return_if_fail (data != NULL);
+
+- GSList **list = (GSList **) data;
++ list = (GSList **) data;
+
+ if (GTK_IS_SOURCE_TAG (tag))
+ {
diff --git a/x11-toolkits/gtksourceview/files/patch-gtksourceview_gtksourceregex.h b/x11-toolkits/gtksourceview/files/patch-gtksourceview_gtksourceregex.h
new file mode 100644
index 000000000000..fc1be98e6ec1
--- /dev/null
+++ b/x11-toolkits/gtksourceview/files/patch-gtksourceview_gtksourceregex.h
@@ -0,0 +1,11 @@
+--- gtksourceview/gtksourceregex.h.orig Wed May 7 20:04:08 2003
++++ gtksourceview/gtksourceregex.h Wed May 7 20:05:43 2003
+@@ -20,7 +20,7 @@
+ #ifndef __GTK_SOURCE_REGEX_H__
+ #define __GTK_SOURCE_REGEX_H__
+
+-#include <regex.h>
++#include <gnuregex.h>
+ #include <glib/gtypes.h>
+
+ G_BEGIN_DECLS
diff --git a/x11-toolkits/gtksourceview/files/patch-gtksourceview_gtksourceview.c b/x11-toolkits/gtksourceview/files/patch-gtksourceview_gtksourceview.c
new file mode 100644
index 000000000000..c975f84e163f
--- /dev/null
+++ b/x11-toolkits/gtksourceview/files/patch-gtksourceview_gtksourceview.c
@@ -0,0 +1,13 @@
+--- gtksourceview/gtksourceview.c.orig Wed May 7 20:10:15 2003
++++ gtksourceview/gtksourceview.c Wed May 7 20:10:28 2003
+@@ -762,8 +762,9 @@
+ gtk_text_iter_forward_to_line_end (&cur);
+ while (!gtk_text_iter_starts_line (&cur))
+ {
++ gunichar c;
+ gtk_text_iter_backward_char (&cur);
+- gunichar c = gtk_text_iter_get_char (&cur);
++ c = gtk_text_iter_get_char (&cur);
+ if (!g_unichar_isspace (c))
+ {
+ /* We've gone one character too far. */
diff --git a/x11-toolkits/gtksourceview/pkg-descr b/x11-toolkits/gtksourceview/pkg-descr
new file mode 100644
index 000000000000..d24afadff56d
--- /dev/null
+++ b/x11-toolkits/gtksourceview/pkg-descr
@@ -0,0 +1,3 @@
+Gtksourceview is a text widget that extends the standard Gtk+ 2.x GtkTextView.
+It improves it by implementing syntax highlighting and other features typical
+of a source editor.
diff --git a/x11-toolkits/gtksourceview/pkg-plist b/x11-toolkits/gtksourceview/pkg-plist
new file mode 100644
index 000000000000..c5274f7b783b
--- /dev/null
+++ b/x11-toolkits/gtksourceview/pkg-plist
@@ -0,0 +1,31 @@
+include/gtksourceview-1.0/gtksourceview/gtksourcebuffer.h
+include/gtksourceview-1.0/gtksourceview/gtksourcelanguage.h
+include/gtksourceview-1.0/gtksourceview/gtksourcelanguagesmanager.h
+include/gtksourceview-1.0/gtksourceview/gtksourcemarker.h
+include/gtksourceview-1.0/gtksourceview/gtksourcestylescheme.h
+include/gtksourceview-1.0/gtksourceview/gtksourcetag.h
+include/gtksourceview-1.0/gtksourceview/gtksourcetagstyle.h
+include/gtksourceview-1.0/gtksourceview/gtksourcetagtable.h
+include/gtksourceview-1.0/gtksourceview/gtksourceview.h
+lib/libgtksourceview-1.0.a
+lib/libgtksourceview-1.0.so
+lib/libgtksourceview-1.0.so.0
+libdata/pkgconfig/gtksourceview-1.0.pc
+share/gnome/gtksourceview-1.0/language-specs/ada.lang
+share/gnome/gtksourceview-1.0/language-specs/c.lang
+share/gnome/gtksourceview-1.0/language-specs/cpp.lang
+share/gnome/gtksourceview-1.0/language-specs/desktop.lang
+share/gnome/gtksourceview-1.0/language-specs/diff.lang
+share/gnome/gtksourceview-1.0/language-specs/html.lang
+share/gnome/gtksourceview-1.0/language-specs/idl.lang
+share/gnome/gtksourceview-1.0/language-specs/java.lang
+share/gnome/gtksourceview-1.0/language-specs/latex.lang
+share/gnome/gtksourceview-1.0/language-specs/perl.lang
+share/gnome/gtksourceview-1.0/language-specs/po.lang
+share/gnome/gtksourceview-1.0/language-specs/python.lang
+share/gnome/gtksourceview-1.0/language-specs/xml.lang
+share/locale/es/LC_MESSAGES/gtksourceview-1.0.mo
+@dirrm share/gnome/gtksourceview-1.0/language-specs
+@dirrm share/gnome/gtksourceview-1.0
+@dirrm include/gtksourceview-1.0/gtksourceview
+@dirrm include/gtksourceview-1.0