aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtoolkit
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-12-25 10:08:50 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-12-25 10:08:50 +0000
commit42bdf26eef0ee26766539db399a3226be0319f61 (patch)
treecd54cec4ff9390161303b47b57d3f62640abe0d0 /x11-toolkits/gtoolkit
parent6529bc5cf60de2c671a9b8ddfd2a68da55736d96 (diff)
downloadports-42bdf26eef0ee26766539db399a3226be0319f61.tar.gz
ports-42bdf26eef0ee26766539db399a3226be0319f61.zip
Notes
Diffstat (limited to 'x11-toolkits/gtoolkit')
-rw-r--r--x11-toolkits/gtoolkit/Makefile4
-rw-r--r--x11-toolkits/gtoolkit/files/patch-GToolKit.m58
2 files changed, 58 insertions, 4 deletions
diff --git a/x11-toolkits/gtoolkit/Makefile b/x11-toolkits/gtoolkit/Makefile
index 360096d57dd4..fd43ae866b30 100644
--- a/x11-toolkits/gtoolkit/Makefile
+++ b/x11-toolkits/gtoolkit/Makefile
@@ -60,10 +60,6 @@ do-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 500030
-BROKEN= conflicts with new gcc, method definition not in class context
-.endif
-
.if ${MACHINE_ARCH} == "i386"
GNU_ARCH= ix86
.else
diff --git a/x11-toolkits/gtoolkit/files/patch-GToolKit.m b/x11-toolkits/gtoolkit/files/patch-GToolKit.m
new file mode 100644
index 000000000000..1f202e7111af
--- /dev/null
+++ b/x11-toolkits/gtoolkit/files/patch-GToolKit.m
@@ -0,0 +1,58 @@
+--- GToolKit.m.orig Thu Feb 21 16:43:52 2002
++++ GToolKit.m Wed Dec 25 11:12:44 2002
+@@ -2550,6 +2550,17 @@
+ #include <GToolKit/GTKWidget.h>
+ #include <GToolKit/GTKAccelGroup.h>
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
++#include <stdio.h>
++#include <string.h>
++#include <Foundation/NSAutoreleasePool.h>
++#if defined (DEBUG) && defined (HAVE_OBJC_OBJC_API_H)
++#include <objc/objc-api.h>
++#endif
++
+ @implementation GTKItemFactory
+ + (GtkType) getType
+ {
+@@ -2651,16 +2662,6 @@
+ {
+ gtk_item_factory_set_translate_func(gtk, func , data , notify);
+ }
+-#ifdef HAVE_CONFIG_H
+-#include "config.h"
+-#endif
+-
+-#include <stdio.h>
+-#include <string.h>
+-#include <Foundation/NSAutoreleasePool.h>
+-#if defined (DEBUG) && defined (HAVE_OBJC_OBJC_API_H)
+-#include <objc/objc-api.h>
+-#endif
+
+
+ static void item_forward_signal (gpointer data, guint action, GtkWidget *widget)
+@@ -6376,6 +6377,10 @@
+ #include <GToolKit/GTKWidget.h>
+ #include <GToolKit/GTKAccelGroup.h>
+
++#include <gtk/gtksignal.h>
++#include <Foundation/NSAutoreleasePool.h>
++#include <Foundation/NSNotification.h>
++
+ @implementation GTKWindow
+ + (GtkType) getType
+ {
+@@ -6437,9 +6442,6 @@
+ {
+ gtk_window_set_modal(gtk, modal);
+ }
+-#include <gtk/gtksignal.h>
+-#include <Foundation/NSAutoreleasePool.h>
+-#include <Foundation/NSNotification.h>
+
+
+ NSString *GTKWindowDidBecomeMainNotification = @"GTKWindowDidBecomeMain";