aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/guile-gtk
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-05-02 03:19:47 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-05-02 03:19:47 +0000
commit7c6a77a5913800c723f2264358e982399966b051 (patch)
tree13c17587c2e0dc0baa72778fc3743dcf8a8cb6e7 /x11-toolkits/guile-gtk
parent34256c1b8375c2c679872fc0d208faad3c421d72 (diff)
downloadports-7c6a77a5913800c723f2264358e982399966b051.tar.gz
ports-7c6a77a5913800c723f2264358e982399966b051.zip
Notes
Diffstat (limited to 'x11-toolkits/guile-gtk')
-rw-r--r--x11-toolkits/guile-gtk/Makefile22
-rw-r--r--x11-toolkits/guile-gtk/distinfo2
-rw-r--r--x11-toolkits/guile-gtk/files/patch-Makefile.in11
-rw-r--r--x11-toolkits/guile-gtk/files/patch-configure10
-rw-r--r--x11-toolkits/guile-gtk/files/patch-guile-gtk.c19
-rw-r--r--x11-toolkits/guile-gtk/pkg-plist8
6 files changed, 47 insertions, 25 deletions
diff --git a/x11-toolkits/guile-gtk/Makefile b/x11-toolkits/guile-gtk/Makefile
index fd2ab029cd73..389203e2dec0 100644
--- a/x11-toolkits/guile-gtk/Makefile
+++ b/x11-toolkits/guile-gtk/Makefile
@@ -6,25 +6,27 @@
#
PORTNAME= guile-gtk
-PORTVERSION= 0.20
-PORTREVISION= 2
+PORTVERSION= 0.31
CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-guile/0.20
-DISTNAME= gnome-guile-${PORTVERSION}
+MASTER_SITES= http://savannah.nongnu.org/download/guile-gtk/
+DISTNAME= ${PORTNAME}-1.2-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Guile binding library for GTK+
-LIB_DEPENDS= guile.10:${PORTSDIR}/lang/guile
-
-WRKSRC= ${WRKDIR}/${DISTNAME}/guile-gtk
+LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
USE_X_PREFIX= yes
-USE_GNOME= gtk12
+USE_GMAKE= yes
+USE_GNOME= gtk12 gnometarget
+USE_REINPLACE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib" HAVE_PKG_CONFIG="no"
+ LIBS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|gtk-1\.2/||g'
.include <bsd.port.mk>
diff --git a/x11-toolkits/guile-gtk/distinfo b/x11-toolkits/guile-gtk/distinfo
index 98bdef9ef7d0..09745fe09bdc 100644
--- a/x11-toolkits/guile-gtk/distinfo
+++ b/x11-toolkits/guile-gtk/distinfo
@@ -1 +1 @@
-MD5 (gnome-guile-0.20.tar.gz) = 2be739e8bbc9fffe70e7ef19950bc984
+MD5 (guile-gtk-1.2-0.31.tar.gz) = b16d97570e1f06cbfdd232173ce9e179
diff --git a/x11-toolkits/guile-gtk/files/patch-Makefile.in b/x11-toolkits/guile-gtk/files/patch-Makefile.in
deleted file mode 100644
index 9fac6c4f0360..000000000000
--- a/x11-toolkits/guile-gtk/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Wed Jun 19 16:06:19 2002
-+++ Makefile.in Wed Jun 19 16:06:50 2002
-@@ -623,7 +623,7 @@
- $(INSTALL_DATA) $(srcdir)/gtk/repl.scm $(gtkmoduledir)/repl.scm
- $(INSTALL_DATA) $(srcdir)/gtk/threads.scm $(gtkmoduledir)/threads.scm
- .c.x:
-- guile-snarf $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< >$<.tmp && mv $<.tmp $@
-+ guile-snarf -o $<.tmp $< $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) && mv $<.tmp $@
-
- gtk-glue.c: $(gtkdefs) $(gdkdefs) build-guile-gtk
- $(BUILD) -I $(srcdir) glue $(gtkdefs) >tmpt && mv tmpt $@
diff --git a/x11-toolkits/guile-gtk/files/patch-configure b/x11-toolkits/guile-gtk/files/patch-configure
new file mode 100644
index 000000000000..f195f07b43c6
--- /dev/null
+++ b/x11-toolkits/guile-gtk/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Dec 11 18:31:51 2002
++++ configure Thu Dec 12 12:07:17 2002
+@@ -7414,6 +7414,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/x11-toolkits/guile-gtk/files/patch-guile-gtk.c b/x11-toolkits/guile-gtk/files/patch-guile-gtk.c
new file mode 100644
index 000000000000..b38607b0856e
--- /dev/null
+++ b/x11-toolkits/guile-gtk/files/patch-guile-gtk.c
@@ -0,0 +1,19 @@
+--- guile-gtk.c.orig Wed Apr 30 23:26:36 2003
++++ guile-gtk.c Wed Apr 30 23:27:57 2003
+@@ -19,6 +19,7 @@
+ #include <string.h>
+ #include <config.h>
+ #include <assert.h>
++#include <sys/types.h>
+ #ifdef GTK_2_0
+ #include <gtk-2.0/gtk/gtk.h>
+ #include <gtk-2.0/gdk/gdkprivate.h>
+@@ -44,6 +45,8 @@
+ #ifndef SCM_VECTOR_SET
+ #define SCM_VECTOR_SET(obj,i,v) (SCM_VELTS(obj)[i]=(v))
+ #endif
++
++typedef unsigned long ulong;
+
+ static SCM
+ sgtk_make_cell (scm_t_bits word0, scm_t_bits word1)
diff --git a/x11-toolkits/guile-gtk/pkg-plist b/x11-toolkits/guile-gtk/pkg-plist
index f3efed56e969..a451c48cd2a8 100644
--- a/x11-toolkits/guile-gtk/pkg-plist
+++ b/x11-toolkits/guile-gtk/pkg-plist
@@ -1,17 +1,19 @@
bin/build-guile-gtk
-bin/guile-gtk
-bin/guile-gtk-1.2
+bin/build-guile-gtk-1.2
include/guile-gtk.h
lib/libguilegtk-1.2.a
lib/libguilegtk-1.2.so
lib/libguilegtk-1.2.so.0
share/guile-gtk/gdk-1.2.defs
share/guile-gtk/gtk-1.2.defs
+share/guile/gtk-1.2/config.scm
+share/guile/gtk-1.2/dynlink.scm
share/guile/gtk-1.2/gdk.scm
share/guile/gtk-1.2/gtk.scm
+share/guile/gtk-1.2/repl.scm
+share/guile/gtk-1.2/threads.scm
share/guile/gtk/config.scm
share/guile/gtk/dynlink.scm
-share/guile/gtk/dynlink-old.scm
share/guile/gtk/gdk.scm
share/guile/gtk/gtk.scm
share/guile/gtk/repl.scm