aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/hippo-canvas
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-30 21:49:08 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-30 21:49:08 +0000
commitf74b4299ef6c731ca4aed841bfe8ca415de05a37 (patch)
treeade11c6168de27ded17089f857f2ee2ed8e79ebe /x11-toolkits/hippo-canvas
parentcc6c284eda611bbf49911aab8358571d4d1f4d10 (diff)
downloadports-f74b4299ef6c731ca4aed841bfe8ca415de05a37.tar.gz
ports-f74b4299ef6c731ca4aed841bfe8ca415de05a37.zip
Notes
Diffstat (limited to 'x11-toolkits/hippo-canvas')
-rw-r--r--x11-toolkits/hippo-canvas/Makefile33
-rw-r--r--x11-toolkits/hippo-canvas/distinfo3
-rw-r--r--x11-toolkits/hippo-canvas/pkg-descr5
-rw-r--r--x11-toolkits/hippo-canvas/pkg-plist59
4 files changed, 100 insertions, 0 deletions
diff --git a/x11-toolkits/hippo-canvas/Makefile b/x11-toolkits/hippo-canvas/Makefile
new file mode 100644
index 000000000000..ed2974cb4390
--- /dev/null
+++ b/x11-toolkits/hippo-canvas/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: hippo-canvas
+# Date created: 2008-05-27
+# Whom: Ashish Shukla <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hippo-canvas
+PORTVERSION= 0.2.31
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= A client stacker popup widget for GTK+ toolkit
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libcroco-0.6.pc:${PORTSDIR}/textproc/libcroco \
+ ${LOCALBASE}/libdata/pkgconfig/cairo.pc:${PORTSDIR}/graphics/cairo \
+ ${LOCALBASE}/libdata/pkgconfig/pycairo.pc:${PORTSDIR}/graphics/py-cairo \
+ ${LOCALBASE}/bin/gtkdocize:${PORTSDIR}/textproc/gtk-doc
+LIB_DEPENDS= croco-0.6.3:${PORTSDIR}/textproc/libcroco \
+ cairo.2:${PORTSDIR}/graphics/cairo
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pycairo.pc:${PORTSDIR}/graphics/py-cairo
+
+USE_GMAKE= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack gtk20 glib20 pygtk2 pango
+USE_PYTHON= 2.5+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-python --enable-gtk-doc
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/hippo-canvas/distinfo b/x11-toolkits/hippo-canvas/distinfo
new file mode 100644
index 000000000000..4f8e6eccb964
--- /dev/null
+++ b/x11-toolkits/hippo-canvas/distinfo
@@ -0,0 +1,3 @@
+MD5 (hippo-canvas-0.2.31.tar.bz2) = a5df369f4be5494d51bd0c7355c7fc48
+SHA256 (hippo-canvas-0.2.31.tar.bz2) = cbf2d7d6898f59934536dddcdb46cef67d6dd62e5e841de1ca2ab5e64101f321
+SIZE (hippo-canvas-0.2.31.tar.bz2) = 376039
diff --git a/x11-toolkits/hippo-canvas/pkg-descr b/x11-toolkits/hippo-canvas/pkg-descr
new file mode 100644
index 000000000000..a0d2b58f6b2c
--- /dev/null
+++ b/x11-toolkits/hippo-canvas/pkg-descr
@@ -0,0 +1,5 @@
+The Hippo Canvas was originally developed to display the
+client stacker popup. It is now used in other projects such
+as the OLPC Sugar interface, and the Big Board desktop.
+
+WWW: http://developer.mugshot.org/wiki/Hippo_Canvas
diff --git a/x11-toolkits/hippo-canvas/pkg-plist b/x11-toolkits/hippo-canvas/pkg-plist
new file mode 100644
index 000000000000..3ae313e359b9
--- /dev/null
+++ b/x11-toolkits/hippo-canvas/pkg-plist
@@ -0,0 +1,59 @@
+include/hippo-canvas-1/hippo/hippo-canvas-box.h
+include/hippo-canvas-1/hippo/hippo-canvas-container.h
+include/hippo-canvas-1/hippo/hippo-canvas-context.h
+include/hippo-canvas-1/hippo/hippo-canvas-gradient.h
+include/hippo-canvas-1/hippo/hippo-canvas-image-button.h
+include/hippo-canvas-1/hippo/hippo-canvas-image.h
+include/hippo-canvas-1/hippo/hippo-canvas-item.h
+include/hippo-canvas-1/hippo/hippo-canvas-layout.h
+include/hippo-canvas-1/hippo/hippo-canvas-link.h
+include/hippo-canvas-1/hippo/hippo-canvas-style.h
+include/hippo-canvas-1/hippo/hippo-canvas-text.h
+include/hippo-canvas-1/hippo/hippo-canvas-theme-engine.h
+include/hippo-canvas-1/hippo/hippo-canvas-theme.h
+include/hippo-canvas-1/hippo/hippo-canvas-util.h
+include/hippo-canvas-1/hippo/hippo-canvas-widget.h
+include/hippo-canvas-1/hippo/hippo-canvas-widgets.h
+include/hippo-canvas-1/hippo/hippo-canvas-window.h
+include/hippo-canvas-1/hippo/hippo-canvas.h
+include/hippo-canvas-1/hippo/hippo-event.h
+include/hippo-canvas-1/hippo/hippo-graphics.h
+lib/libhippocanvas-1.a
+lib/libhippocanvas-1.la
+lib/libhippocanvas-1.so
+lib/libhippocanvas-1.so.0
+%%PYTHON_SITELIBDIR%%/hippo.a
+%%PYTHON_SITELIBDIR%%/hippo.la
+%%PYTHON_SITELIBDIR%%/hippo.so
+libdata/pkgconfig/hippo-canvas-1.pc
+share/gtk-doc/html/hippo-canvas/HippoCanvasBox.html
+share/gtk-doc/html/hippo-canvas/HippoCanvasContainer.html
+share/gtk-doc/html/hippo-canvas/HippoCanvasContext.html
+share/gtk-doc/html/hippo-canvas/HippoCanvasGradient.html
+share/gtk-doc/html/hippo-canvas/HippoCanvasImage.html
+share/gtk-doc/html/hippo-canvas/HippoCanvasImageButton.html
+share/gtk-doc/html/hippo-canvas/HippoCanvasItem.html
+share/gtk-doc/html/hippo-canvas/HippoCanvasLink.html
+share/gtk-doc/html/hippo-canvas/HippoCanvasStyle.html
+share/gtk-doc/html/hippo-canvas/HippoCanvasText.html
+share/gtk-doc/html/hippo-canvas/ch01.html
+share/gtk-doc/html/hippo-canvas/hippo-canvas-Graphics.html
+share/gtk-doc/html/hippo-canvas/hippo-canvas-HippoEvent.html
+share/gtk-doc/html/hippo-canvas/hippo-canvas-Utilitites.html
+share/gtk-doc/html/hippo-canvas/hippo-canvas-Widgets.html
+share/gtk-doc/html/hippo-canvas/hippo-canvas.devhelp
+share/gtk-doc/html/hippo-canvas/hippo-canvas.devhelp2
+share/gtk-doc/html/hippo-canvas/home.png
+share/gtk-doc/html/hippo-canvas/index.html
+share/gtk-doc/html/hippo-canvas/index.sgml
+share/gtk-doc/html/hippo-canvas/left.png
+share/gtk-doc/html/hippo-canvas/right.png
+share/gtk-doc/html/hippo-canvas/style.css
+share/gtk-doc/html/hippo-canvas/up.png
+@dirrm share/gtk-doc/html/hippo-canvas
+@dirrm share/gtk-doc/html
+@dirrm share/gtk-doc
+@dirrm %%PYTHON_SITELIBDIR%%
+@dirrm lib/python2.5
+@dirrm include/hippo-canvas-1/hippo
+@dirrm include/hippo-canvas-1