aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/hs-gtk+hs/Makefile
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2002-10-05 18:57:21 +0000
committerOliver Braun <obraun@FreeBSD.org>2002-10-05 18:57:21 +0000
commitc6d6d36f20a14adb825e1d1b1207afcd2b867c62 (patch)
tree0369128bad1dc066ffe9bd9bd93d3ad591bcd75e /x11-toolkits/hs-gtk+hs/Makefile
parent0975efda51568ff5335ab20cd16d08c0616886cb (diff)
Notes
Diffstat (limited to 'x11-toolkits/hs-gtk+hs/Makefile')
-rw-r--r--x11-toolkits/hs-gtk+hs/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/x11-toolkits/hs-gtk+hs/Makefile b/x11-toolkits/hs-gtk+hs/Makefile
index 23b37c7b2ddb..63dbd5b12134 100644
--- a/x11-toolkits/hs-gtk+hs/Makefile
+++ b/x11-toolkits/hs-gtk+hs/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gtk+hs
-PORTVERSION= 0.11.5
-PORTREVISION= 1
+PORTVERSION= 0.14.10
CATEGORIES= x11-toolkits
MASTER_SITES= http://www.cse.unsw.edu.au/~chak/haskell/gtk/
PKGNAMEPREFIX= hs-
@@ -18,6 +17,9 @@ BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
c2hs:${PORTSDIR}/devel/hs-c2hs
RUN_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
c2hs:${PORTSDIR}/devel/hs-c2hs
+.if defined(WITH_IHASKELL)
+RUN_DEPENDS+= ports-config:${PORTSDIR}/devel/hs-hpl
+.endif
USE_GNOMENG= yes
USE_GNOME= glib12 gtk12
@@ -26,12 +28,20 @@ USE_REINPLACE= yes
HAS_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS+= --prefix=${PREFIX}
+CONFIGURE_ARGS+= --prefix=${PREFIX} --enable-add-package
+.if defined(WITH_IHASKELL)
+CONFIGURE_ARGS+= --with-ih
+.endif
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+pre-everything::
+.if !defined(WITH_IHASKELL)
+ @${ECHO_CMD} "To build gtk+hs with iHaskell define WITH_IHASKELL."
+.endif
+
post-patch:
- ${REINPLACE_CMD} -e 's/gtk-config/gtk12-config/g ; \
+ @${REINPLACE_CMD} -e 's/gtk-config/gtk12-config/g ; \
s/glib-config/glib12-config/g' ${WRKSRC}/configure
.include <bsd.port.mk>