aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/hs-gtk/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2011-05-08 18:45:08 +0000
committerGabor Pali <pgj@FreeBSD.org>2011-05-08 18:45:08 +0000
commite7c3ad3d088c5ffbdc0f60fafbd9038d69390b84 (patch)
treefde7a392b594f897e223d6bc758a91007ada3bd9 /x11-toolkits/hs-gtk/Makefile
parentb0249c7e2d8e1093f0ebf8570533de6fed5f4ebd (diff)
downloadports-e7c3ad3d088c5ffbdc0f60fafbd9038d69390b84.tar.gz
ports-e7c3ad3d088c5ffbdc0f60fafbd9038d69390b84.zip
Notes
Diffstat (limited to 'x11-toolkits/hs-gtk/Makefile')
-rw-r--r--x11-toolkits/hs-gtk/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-toolkits/hs-gtk/Makefile b/x11-toolkits/hs-gtk/Makefile
new file mode 100644
index 000000000000..4b2580b4deb3
--- /dev/null
+++ b/x11-toolkits/hs-gtk/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: hs-gtk
+# Date created: March 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtk
+PORTVERSION= 0.12.0
+CATEGORIES= x11-toolkits haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Binding to the Gtk+ graphical user interface library
+
+LICENSE= LGPL21
+FILE_LICENSE= COPYING
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= cairo>=0.12.0 glib>=0.12.0 mtl pango>=0.12.0
+USE_GNOME= gtk20
+
+PORTDATA= *
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>