aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/hs-wxc
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
commitcc555442337c7591ab5c3fd19ad8e3e185a256b0 (patch)
treea6a0dfa4f440949889fc7b609c83f74555f6894e /x11-toolkits/hs-wxc
parent5e492199d1e024a681c6d21087c8d948cb3b7bc3 (diff)
Notes
Diffstat (limited to 'x11-toolkits/hs-wxc')
-rw-r--r--x11-toolkits/hs-wxc/Makefile18
-rw-r--r--x11-toolkits/hs-wxc/distinfo4
-rw-r--r--x11-toolkits/hs-wxc/files/nopatch-wxc.cabal11
-rw-r--r--x11-toolkits/hs-wxc/files/patch-src__cpp__eljpen.cpp11
-rw-r--r--x11-toolkits/hs-wxc/files/patch-wxc.cabal7
-rw-r--r--x11-toolkits/hs-wxc/pkg-descr6
6 files changed, 25 insertions, 32 deletions
diff --git a/x11-toolkits/hs-wxc/Makefile b/x11-toolkits/hs-wxc/Makefile
index 3ab194b0d69b..fa50f2ed6c8e 100644
--- a/x11-toolkits/hs-wxc/Makefile
+++ b/x11-toolkits/hs-wxc/Makefile
@@ -1,16 +1,13 @@
# $FreeBSD$
PORTNAME= wxc
-PORTVERSION= 0.90.0.4
-PORTREVISION= 7
+PORTVERSION= 0.90.1.1
CATEGORIES= x11-toolkits haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= wxHaskell C++ wrapper
-USE_CABAL= wxdirect>=0.90
-
-BROKEN= does not build with any of the supported wx
+USE_CABAL= wxdirect>=0.90.1.0
USES= dos2unix
USE_WX= 3.0
@@ -20,8 +17,15 @@ WX_UNICODE= yes
OPTIONS_EXCLUDE=DOCS
post-patch::
- @${REINPLACE_CMD} 's|"wx-config"|"wxgtk2u-2.9-config"| ; \
- s|/sbin/ldconfig -n|/sbin/ldconfig -m| ' ${WRKSRC}/Setup.hs
+ @${REINPLACE_CMD} 's|"wx-config"|"wxgtk2u-3.0-config"| ; \
+ s|/sbin/ldconfig -n|/sbin/ldconfig -m| ; \
+ s|"2.9"|"3.0"|' \
+ ${WRKSRC}/Setup.hs
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+
+.if ${OSVERSION} >= 900000
+EXTRA_PATCHES+= ${PATCHDIR}/nopatch-wxc.cabal
+.endif
+
.include <bsd.port.mk>
diff --git a/x11-toolkits/hs-wxc/distinfo b/x11-toolkits/hs-wxc/distinfo
index e8062af03ff6..a8f612b5ce0c 100644
--- a/x11-toolkits/hs-wxc/distinfo
+++ b/x11-toolkits/hs-wxc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/wxc-0.90.0.4.tar.gz) = e69e4870c33dc32ee388c5f1be5b0ad1f2b231aa16a51da205cfa295430402ae
-SIZE (cabal/wxc-0.90.0.4.tar.gz) = 181799
+SHA256 (cabal/wxc-0.90.1.1.tar.gz) = ec71deebafdb69e50742acf1a4307ab2706f3282d24022a8a603eb3d35bc6e33
+SIZE (cabal/wxc-0.90.1.1.tar.gz) = 183992
diff --git a/x11-toolkits/hs-wxc/files/nopatch-wxc.cabal b/x11-toolkits/hs-wxc/files/nopatch-wxc.cabal
new file mode 100644
index 000000000000..1e5363f34d93
--- /dev/null
+++ b/x11-toolkits/hs-wxc/files/nopatch-wxc.cabal
@@ -0,0 +1,11 @@
+--- ./wxc.cabal.orig 2014-03-22 21:53:20.000000000 +0100
++++ ./wxc.cabal 2014-07-20 08:09:51.000000000 +0200
+@@ -161,6 +161,8 @@
+ base >= 4 && < 5,
+ wxdirect >= 0.90.1.0
+
++ cc-options: -std=c++11
++
+ x-dll-sources:
+ src/cpp/apppath.cpp
+ src/cpp/dragimage.cpp
diff --git a/x11-toolkits/hs-wxc/files/patch-src__cpp__eljpen.cpp b/x11-toolkits/hs-wxc/files/patch-src__cpp__eljpen.cpp
deleted file mode 100644
index 577dcdee6b0b..000000000000
--- a/x11-toolkits/hs-wxc/files/patch-src__cpp__eljpen.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/cpp/eljpen.cpp.orig 2012-07-03 11:12:17.000000000 +0100
-+++ ./src/cpp/eljpen.cpp 2012-09-06 15:58:22.000000000 +0100
-@@ -156,7 +156,7 @@
- EWXWEXPORT(void,wxPen_GetStipple)(void* self,wxBitmap* _ref)
- {
- #if defined(__WXGTK__)
-- *_ref = NULL;
-+ *_ref = (GdkPixbuf *) NULL;
- #else
- *_ref = *(((wxPen*)self)->GetStipple());
- #endif
diff --git a/x11-toolkits/hs-wxc/files/patch-wxc.cabal b/x11-toolkits/hs-wxc/files/patch-wxc.cabal
deleted file mode 100644
index e6acc24af265..000000000000
--- a/x11-toolkits/hs-wxc/files/patch-wxc.cabal
+++ /dev/null
@@ -1,7 +0,0 @@
---- ./wxc.cabal.orig 2013-12-19 21:28:05.000000000 +0100
-+++ ./wxc.cabal 2013-12-19 21:36:12.000000000 +0100
-@@ -273,3 +273,4 @@
-
- x-dll-extra-libraries:
-
-+ cc-options: -std=gnu++0x
diff --git a/x11-toolkits/hs-wxc/pkg-descr b/x11-toolkits/hs-wxc/pkg-descr
index 38627ecd2e0e..79c2ea3d3a8b 100644
--- a/x11-toolkits/hs-wxc/pkg-descr
+++ b/x11-toolkits/hs-wxc/pkg-descr
@@ -1,9 +1,5 @@
wxHaskell is a portable and native GUI library for Haskell. It is built
on top of wxWidgets, a comprehensive C++ library that is portable across
-all major GUI platforms, including GTK, Windows, X11, and MacOS X. This
-version works with wxWidgets 2.9 only. Distributed under the WXWINDOWS
-LIBRARY LICENSE. Please see LICENSE file, but note that this is essentially
-LGPL with an exception allowing binary distribution of proprietary software.
-This is the same license as wxWidgets itself uses.
+all major GUI platforms, including GTK, Windows, X11, and MacOS X.
WWW: http://haskell.org/haskellwiki/WxHaskell