aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/jdic
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-01-05 23:24:40 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-01-05 23:24:40 +0000
commitc4c8523eac36d2bfc2114544ea5c95852db36edf (patch)
tree28d8791c01cfd2f8ae97ea09ca4470a5efde50fb /x11-toolkits/jdic
parent0ca2c8666b0e5ce51a0045fa0a520148ff88b5d6 (diff)
Notes
Diffstat (limited to 'x11-toolkits/jdic')
-rw-r--r--x11-toolkits/jdic/Makefile69
-rw-r--r--x11-toolkits/jdic/distinfo3
-rw-r--r--x11-toolkits/jdic/files/patch-jdic_build.xml36
-rw-r--r--x11-toolkits/jdic/files/patch-jdic_src_unix_native_jni_Makefile28
-rw-r--r--x11-toolkits/jdic/files/patch-jdic_src_unix_native_mozilla_Makefile44
-rw-r--r--x11-toolkits/jdic/pkg-descr18
6 files changed, 198 insertions, 0 deletions
diff --git a/x11-toolkits/jdic/Makefile b/x11-toolkits/jdic/Makefile
new file mode 100644
index 000000000000..f0941552d969
--- /dev/null
+++ b/x11-toolkits/jdic/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: jdic
+# Date created: Tue 26 dec 2006 10:46:02 GMT
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= jdic
+PORTVERSION= 20061102
+CATEGORIES= x11-toolkits java
+MASTER_SITES= https://jdic.dev.java.net/files/documents/880/43269/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= JDesktop Integration Components
+
+# USE_GMAKE conflicts with USE_ANT
+BUILD_DEPENDS= gmake:${PORTSDIR}/devel/gmake
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+# nspr4.1:${PORTSDIR}/devel/nspr
+
+USE_ZIP= yes
+USE_ANT= yes
+USE_GNOME= pkgconfig # libgnome
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+USE_LDCONFIG= yes
+# Do not build mozembed: it requires Gecko_SDK and XULRunner, which is
+# broken ATM - see <http://developer.mozilla.org/en/docs/Gecko_SDK>.
+#USE_GECKO= firefox seamonkey mozilla
+
+#ALL_TARGET= buildall
+ALL_TARGET= buildtray
+WRKSRC= ${WRKDIR}/src
+BUILD_WRKSRC= ${WRKSRC}/jdic # Remove to build all
+MAKE_ENV= CLASSPATH="${JAVA_HOME}/jre/lib/javaws.jar"
+#MAKE_ENV= MOZILLA_DIST="`${GECKO_CONFIG} --prefix`/lib/${GECKO}" \
+# GECKO_SDK="${GECKO_SDK}"
+
+MKFILES= jni mozilla
+DIST_DIR= ${WRKSRC}/jdic/dist/${OPSYS:L}
+
+PLIST_FILES= %%JAVAJARDIR%%/jdic.jar \
+ lib/libtray.so \
+ lib/libtray.so.0
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+.for mk in ${MKFILES}
+ ${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g; \
+ s|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/jdic/src/unix/native/${mk}/Makefile
+.endfor
+
+do-install:
+ ${INSTALL_DATA} ${DIST_DIR}/jdic.jar ${JAVAJARDIR}
+ ${INSTALL_SCRIPT} ${DIST_DIR}/libtray.so ${PREFIX}/lib/libtray.so.0
+ ${LN} -sf ${PREFIX}/lib/libtray.so.0 ${PREFIX}/lib/libtray.so
+
+.if defined(MAINTAINER_MODE)
+regression-test: install
+ (cd ${WRKSRC}/jdic/demo/Tray && \
+ javac -cp "${JAVAJARDIR}/jdic.jar:." Tray.java && \
+ java -cp "${JAVAJARDIR}/jdic.jar:." Tray)
+.endif
+
+#.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/jdic/distinfo b/x11-toolkits/jdic/distinfo
new file mode 100644
index 000000000000..0fa96c1e2a4a
--- /dev/null
+++ b/x11-toolkits/jdic/distinfo
@@ -0,0 +1,3 @@
+MD5 (jdic-20061102-src.zip) = 57895b34d2a71b3f5394f56f69a87d5b
+SHA256 (jdic-20061102-src.zip) = 7a21d303bfd6df2b4db46eaba4ec983ae53bed470001c0211fa23e2a7bad6ccb
+SIZE (jdic-20061102-src.zip) = 3912327
diff --git a/x11-toolkits/jdic/files/patch-jdic_build.xml b/x11-toolkits/jdic/files/patch-jdic_build.xml
new file mode 100644
index 000000000000..960eabbb81f1
--- /dev/null
+++ b/x11-toolkits/jdic/files/patch-jdic_build.xml
@@ -0,0 +1,36 @@
+--- ./jdic/build.xml.orig Tue Oct 31 17:33:06 2006
++++ ./jdic/build.xml Tue Dec 26 22:07:34 2006
+@@ -543,6 +543,10 @@
+ <target name="buildtray" depends="clean"
+ description="build a distribution for the current platform.">
+ <!-- Set the platform-dependent buildall target -->
++ <condition property="platform.target" value="buildfreebsd_tray">
++ <os name="freebsd"/>
++ </condition>
++
+ <condition property="platform.target" value="buildwin32_tray">
+ <os family="windows" />
+ </condition>
+@@ -563,6 +567,13 @@
+ </target>
+
+ <!--
++ - FreeBSD DISTRIBUTION
++ -->
++ <target name="buildfreebsd_tray" depends="buildunixjar_tray, buildunixjni_tray"
++ description="build java and native source code for FreeBSD platform" >
++ </target>
++
++ <!--
+ - WIN32 DISTRIBUTION
+ -->
+ <target name="buildwin32_tray" depends="buildwin32jar_tray, buildwin32jni_tray"
+@@ -644,7 +655,7 @@
+ <!-- *** Build Unix native JNI code *** -->
+ <target name="buildunixjni_tray" depends="init"
+ description="build native jni libraries." >
+- <exec dir="${unix.native.jni.dir}" executable="make" failonerror="yes" >
++ <exec dir="${unix.native.jni.dir}" executable="gmake" failonerror="yes" >
+ <arg line="tray"/>
+ </exec>
+
diff --git a/x11-toolkits/jdic/files/patch-jdic_src_unix_native_jni_Makefile b/x11-toolkits/jdic/files/patch-jdic_src_unix_native_jni_Makefile
new file mode 100644
index 000000000000..df0b8cbc0b40
--- /dev/null
+++ b/x11-toolkits/jdic/files/patch-jdic_src_unix_native_jni_Makefile
@@ -0,0 +1,28 @@
+--- ./jdic/src/unix/native/jni/Makefile.orig Fri Oct 14 10:42:22 2005
++++ ./jdic/src/unix/native/jni/Makefile Tue Dec 26 22:11:34 2006
+@@ -44,11 +44,12 @@
+ endif
+ ifeq ($(UNAME), FreeBSD)
+ PLATFORM = freebsd
+- CXX = g++
+- CXXFLAGS = -c -I/usr/local/include -I/usr/X11R6/include
+- LDFLAGS = -shared -fPIC -L/usr/local/lib -L/usr/X11R6/lib
++ #CXX = g++
++ CXXFLAGS += -c -I/usr/local/include -I/usr/X11R6/include
++ CFLAGS += -I/usr/X11R6/include
++ LDFLAGS += -shared -fPIC -L/usr/local/lib -L/usr/X11R6/lib
+ endif
+- CC = gcc
++ #CC = gcc
+ ifeq ($(ARCH), x86_64)
+ X11LIB=/usr/X11R6/lib64
+ else
+@@ -124,7 +125,7 @@
+ tray: $(TRAY_SO_NAME)
+
+ $(TRAY_SO_NAME): $(TRAY_CSRC)
+- $(CC) $(INCLUDES) $(LDFLAGS) -ldl -L$(X11LIB) -lXt -lX11 $(TRAY_CSRC) -o $@
++ $(CC) $(CFLAGS) $(INCLUDES) $(LDFLAGS) -L$(X11LIB) -lXt -lX11 $(TRAY_CSRC) -o $@
+
+ clean:
+ rm -f *.so
diff --git a/x11-toolkits/jdic/files/patch-jdic_src_unix_native_mozilla_Makefile b/x11-toolkits/jdic/files/patch-jdic_src_unix_native_mozilla_Makefile
new file mode 100644
index 000000000000..14458cdd021e
--- /dev/null
+++ b/x11-toolkits/jdic/files/patch-jdic_src_unix_native_mozilla_Makefile
@@ -0,0 +1,44 @@
+--- ./jdic/src/unix/native/mozilla/Makefile.orig Wed Mar 8 17:33:18 2006
++++ ./jdic/src/unix/native/mozilla/Makefile Tue Dec 26 22:14:05 2006
+@@ -47,8 +47,8 @@
+ # For Gecko SDK 1.6 or ealier, enable USING_GECKO_SDK_1_4. Or else, enable
+ # USING_GECKO_SDK_1_7.
+ #
+-USING_GECKO_SDK_1_4 = 1
+-#USING_GECKO_SDK_1_7 = 1
++#USING_GECKO_SDK_1_4 = 1
++USING_GECKO_SDK_1_7 = 1
+
+ # set gtk version
+ #
+@@ -56,8 +56,8 @@
+ # (1.2 or 2) Gecko SDK and the Mozilla binary used. The GTK version building
+ # Gecko SDK and the Mozilla binary must be same.
+ #
+-#MOZ_ENABLE_GTK = 1
+-MOZ_ENABLE_GTK2 = 1
++MOZ_ENABLE_GTK = 1
++#MOZ_ENABLE_GTK2 = 1
+
+ MODULE_NAME_PART= mozembed
+
+@@ -74,8 +74,8 @@
+ MODULE_NAME_PART = mozembed-solaris-gtk
+ endif
+ ifeq ($(OS_ARCH), FreeBSD)
+-CXX = g++
+-LDFLAGS = -shared -fPIC -Wl,--version-script=gnu-ld-script
++#CXX = g++
++LDFLAGS += -shared -fPIC -Wl,--version-script=gnu-ld-script
+ MODULE_NAME_PART = mozembed-freebsd-gtk
+ endif
+
+@@ -102,7 +102,7 @@
+ LIBRARY = lib$(MODULE_NAME).so
+
+ #CXXFLAGS = -g -fPIC
+-CXXFLAGS = -O2 -fPIC
++CXXFLAGS += -fPIC
+
+ # link against the version of gtkembedmoz included with a
+ # mozilla distribution
diff --git a/x11-toolkits/jdic/pkg-descr b/x11-toolkits/jdic/pkg-descr
new file mode 100644
index 000000000000..2546c54da09b
--- /dev/null
+++ b/x11-toolkits/jdic/pkg-descr
@@ -0,0 +1,18 @@
+The JDesktop Integration Components (JDIC) project aims to make Java(TM)
+technology-based applications ("Java applications") first-class citizens of
+current desktop platforms without sacrificing platform independence.
+
+JDIC provides Java applications with access to facilities provided by the native
+desktop such as the mailer, the browser, and registered document viewing
+applications. Additionally it provides the mechanisms by which Java applications
+can integrate into the native desktop such as registering Java applications as
+document viewers on the desktop, creating tray icons on the desktop and creating
+installer packages.
+
+JDIC consists of a collection of Java packages (JDIC API), all with the package
+name prefix org.jdesktop.jdic, and a JNLP application packaging tool (JDIC
+Packager).
+
+Note: only the tray icon API is built at the moment.
+
+WWW: https://jdic.dev.java.net/