aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/jx/files
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-07 16:52:01 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-07 16:52:01 +0000
commitc3a9f54064609371af5d64a4c54dc6b261131fec (patch)
tree56d6d9f113f34563d2715ef0c85b76ead5a6d2ee /x11-toolkits/jx/files
parent501e616d95224474b43bb79171e373aed0860ac1 (diff)
JX is a C++ application framework and widget library for X11.
PR: 19030 Submitted by: Mario Sergio Fujikawa Ferriera <lioux@uol.com.br>
Notes
Notes: svn path=/head/; revision=29320
Diffstat (limited to 'x11-toolkits/jx/files')
-rw-r--r--x11-toolkits/jx/files/patch-aa11
-rw-r--r--x11-toolkits/jx/files/patch-ab10
-rw-r--r--x11-toolkits/jx/files/patch-ac26
-rw-r--r--x11-toolkits/jx/files/patch-ad14
-rw-r--r--x11-toolkits/jx/files/patch-ae11
-rw-r--r--x11-toolkits/jx/files/patch-ag13
-rw-r--r--x11-toolkits/jx/files/post-patch-aa37
7 files changed, 122 insertions, 0 deletions
diff --git a/x11-toolkits/jx/files/patch-aa b/x11-toolkits/jx/files/patch-aa
new file mode 100644
index 000000000000..96c1edb4d40b
--- /dev/null
+++ b/x11-toolkits/jx/files/patch-aa
@@ -0,0 +1,11 @@
+--- programs/makemake/Make.header.orig Tue Sep 21 16:33:40 1999
++++ programs/makemake/Make.header Tue May 30 11:07:18 2000
+@@ -95,7 +95,7 @@
+ #
+
+ .PHONY : jxinstall
+-jxinstall: makemake
++jxinstall_not: makemake
+ @strip makemake
+ @mv makemake ${JX_INSTALL_ROOT}/
+ @chmod a+x ${SCRIPT_FILES}
diff --git a/x11-toolkits/jx/files/patch-ab b/x11-toolkits/jx/files/patch-ab
new file mode 100644
index 000000000000..214cc4017165
--- /dev/null
+++ b/x11-toolkits/jx/files/patch-ab
@@ -0,0 +1,10 @@
+--- programs/makemake.ORIG/Makefile.port Sat Nov 6 13:36:35 1999
++++ programs/makemake/Makefile.port Sat Nov 6 13:37:55 1999
+@@ -49,7 +49,6 @@
+ .PHONY : jxinstall
+ jxinstall: regex makemake
+ @strip makemake
+- @mv makemake ${JX_INSTALL_ROOT}/
+
+ @if { which makemake > /dev/null; } then \
+ { \
diff --git a/x11-toolkits/jx/files/patch-ac b/x11-toolkits/jx/files/patch-ac
new file mode 100644
index 000000000000..bf9c36ac4f1b
--- /dev/null
+++ b/x11-toolkits/jx/files/patch-ac
@@ -0,0 +1,26 @@
+--- ACE/ACE_wrappers/ace/config-freebsd-pthread.h.orig Mon Apr 10 13:55:24 2000
++++ ACE/ACE_wrappers/ace/config-freebsd-pthread.h Mon Apr 10 13:56:09 2000
+@@ -44,7 +44,6 @@
+ #define ACE_HAS_NONCONST_SELECT_TIMEVAL
+ #define ACE_HAS_CHARPTR_DL
+ //#define ACE_USES_ASM_SYMBOL_IN_DLSYM
+-#define ACE_LACKS_SIGSET
+ #define ACE_NEEDS_SCHED_H
+
+ // Use of <malloc.h> is deprecated.
+@@ -84,6 +83,15 @@
+ #if (__FreeBSD_version >= 300000)
+ #define ACE_HAS_SIGINFO_T
+ #endif /* __FreeBSD_version >= 300000 */
++
++#if (__FreeBSD_version < 400000)
++#define ACE_LACKS_SIGSET
++#endif /* __FreeBSD_version < 400000 */
++
++#if (__FreeBSD_version >= 400000)
++#define ACE_HAS_UCONTEXT_T
++#define ACE_HAS_SOCKLEN_T
++#endif /* __FreeBSD_version >= 400000 */
+
+ #define ACE_HAS_CONSISTENT_SIGNAL_PROTOTYPES
+ #define ACE_LACKS_SIGINFO_H
diff --git a/x11-toolkits/jx/files/patch-ad b/x11-toolkits/jx/files/patch-ad
new file mode 100644
index 000000000000..559110cf9ed0
--- /dev/null
+++ b/x11-toolkits/jx/files/patch-ad
@@ -0,0 +1,14 @@
+--- ACE/ACE_wrappers/ace/Log_Msg.cpp.orig Mon Apr 10 14:01:34 2000
++++ ACE/ACE_wrappers/ace/Log_Msg.cpp Mon Apr 10 14:02:38 2000
+@@ -670,9 +670,9 @@
+ ACE_TRACE ("ACE_Log_Msg::log");
+ // External decls.
+
+-#if ! (defined(__BORLANDC__) && __BORLANDC__ >= 0x0530)
++#if defined(ACE_LACKS_SYS_NERR)
+ extern int sys_nerr;
+-#endif /* ! (defined(__BORLANDC__) && __BORLANDC__ >= 0x0530) */
++#endif /* defined(ACE_LACKS_SYS_NERR) */
+ typedef void (*PTF)(...);
+
+ // Only print the message if <priority_mask_> hasn't been reset to
diff --git a/x11-toolkits/jx/files/patch-ae b/x11-toolkits/jx/files/patch-ae
new file mode 100644
index 000000000000..35ccdca55dea
--- /dev/null
+++ b/x11-toolkits/jx/files/patch-ae
@@ -0,0 +1,11 @@
+--- programs/jxlayout/Make.header.ORIG Tue May 30 10:58:37 2000
++++ programs/jxlayout/Make.header Tue May 30 11:04:08 2000
+@@ -102,7 +102,7 @@
+ #
+
+ .PHONY : jxinstall
+-jxinstall: jxlayout
++jxinstall_not: jxlayout
+ @strip jxlayout
+ @mv jxlayout ${JX_INSTALL_ROOT}/
+ @cp ${DATA_FILES} ${JX_INSTALL_ROOT}/
diff --git a/x11-toolkits/jx/files/patch-ag b/x11-toolkits/jx/files/patch-ag
new file mode 100644
index 000000000000..c2d832455dea
--- /dev/null
+++ b/x11-toolkits/jx/files/patch-ag
@@ -0,0 +1,13 @@
+--- Makefile Sat Sep 11 16:44:38 1999
++++ Makefile.new Wed Jun 7 12:39:22 2000
+@@ -492,9 +492,7 @@
+
+ CHECK_ACE := lib/util/ace/j_has_ace
+
+-CC := ${shell if { which gcc > /dev/null; } \
+- then { echo gcc; } \
+- else { echo ${CC}; } fi }
++CC := ${CC}
+
+ .PHONY : fix_ace
+ fix_ace:
diff --git a/x11-toolkits/jx/files/post-patch-aa b/x11-toolkits/jx/files/post-patch-aa
new file mode 100644
index 000000000000..c7932e4d2877
--- /dev/null
+++ b/x11-toolkits/jx/files/post-patch-aa
@@ -0,0 +1,37 @@
+--- include/make/sys/FreeBSD-3.x_g++.orig Tue Aug 31 20:36:33 1999
++++ include/make/sys/FreeBSD-3.x_g++ Tue May 30 21:08:07 2000
+@@ -6,11 +6,11 @@
+
+ # This tells us where to find the X libraries.
+
+-J_X11_LIB_DIR := -L/usr/X11R6/lib
++J_X11_LIB_DIR := -LX11PREFIX/lib
+
+ # Uncomment this and change it if your X11 headers are not in /usr/include/X11.
+
+-J_X11_INCLUDE_DIR := -I/usr/X11R6/include
++J_X11_INCLUDE_DIR := -IX11PREFIX/include
+
+ # Uncomment this if you want to compile libXpm into libjx
+
+@@ -88,15 +88,15 @@
+
+ # makemake variables
+
+-LINKER := g++
++LINKER := ${CXX}
+
+ # make variables
+
+-CC := gcc
+-CXX := g++
++CC := ${CC}
++CXX := ${CXX}
+ CPPFLAGS = ${DEPENDFLAGS}
+-CFLAGS = ${J_MAKE_NEEDS_OUTPUT_ARG}
+-CXXFLAGS = ${J_MAKE_NEEDS_OUTPUT_ARG}
++CFLAGS = ${J_MAKE_NEEDS_OUTPUT_ARG} ${PORTCFLAGS}
++CXXFLAGS = ${J_MAKE_NEEDS_OUTPUT_ARG} ${PORTCXXFLAGS}
+
+ # libraries to link
+