aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/lesstif/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1997-01-09 09:07:31 +0000
committerSatoshi Asami <asami@FreeBSD.org>1997-01-09 09:07:31 +0000
commit27ac6f6f63134049acd1c0bc6a0054d74a537396 (patch)
tree43ef3055ece9aea6312e16b0205e59d03b90189d /x11-toolkits/lesstif/Makefile
parenteb76d94df95a80384cb114915d596985c7fde4e2 (diff)
Notes
Diffstat (limited to 'x11-toolkits/lesstif/Makefile')
-rw-r--r--x11-toolkits/lesstif/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-toolkits/lesstif/Makefile b/x11-toolkits/lesstif/Makefile
new file mode 100644
index 000000000000..411400bcb7f9
--- /dev/null
+++ b/x11-toolkits/lesstif/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: lesstif
+# Version required: 0.71
+# Date created: December 10, 1996
+# Whom: 1wardd@airmail.net
+#
+# $Id$
+#
+
+DISTNAME= lesstif-0.75a
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.hungry.com/pub/hungry/lesstif/
+
+GNU_CONFIGURE= yes
+USE_X11= yes
+# change this and remove the strip statement in post-install for debugging
+CONFIGURE_ENV= CCFLAGS="-O -pipe"
+
+.if defined(HAVE_MOTIF)
+IS_INTERACTIVE= yes
+pre-fetch:
+ @echo "***********************************************************"
+ @echo "* W a r n i n g *"
+ @echo "* This port will overwrite your Motif installation. *"
+ @echo "***********************************************************"
+ @echo -n "Is this ok? (y/n) ==> "
+ @(read ans; \
+ case x"$$ans" in \
+ xy*|xY*) \
+ return 0; \
+ ;; \
+ *) \
+ echo "Okay, I won't install it then...."; \
+ echo "(Don't worry about the following \"*** Error code 1\"s)"; \
+ return 1; \
+ ;; \
+ esac)
+.endif
+
+post-install:
+ ${MKDIR} ${PREFIX}/lib/X11/mwm
+ ${INSTALL_DATA} ${WRKSRC}/clients/mwm/system.mwmrc \
+ ${PREFIX}/lib/X11/mwm
+ ${INSTALL_DATA} ${WRKSRC}/clients/mwm/alt.map ${PREFIX}/lib/X11/mwm
+ ${INSTALL_DATA} ${WRKSRC}/clients/mwm/Mwm \
+ ${PREFIX}/lib/X11/app-defaults/Mwm
+ /usr/bin/strip ${PREFIX}/lib/libXm.so.0.0 ${PREFIX}/lib/libMrm.so.0.0
+ /sbin/ldconfig -m ${PREFIX}/lib
+
+.include <bsd.port.mk>