aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libXaw/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2004-01-25 10:51:38 +0000
committerEric Anholt <anholt@FreeBSD.org>2004-01-25 10:51:38 +0000
commit2719fae50a4b83b9e0f12a95cc72187a3ea6f83b (patch)
tree6d522d2e92677267d214dd068343b1d582babf6b /x11-toolkits/libXaw/Makefile
parent2df42a604c4004f1804fb527c87154d2b9508296 (diff)
downloadports-2719fae50a4b83b9e0f12a95cc72187a3ea6f83b.tar.gz
ports-2719fae50a4b83b9e0f12a95cc72187a3ea6f83b.zip
Notes
Diffstat (limited to 'x11-toolkits/libXaw/Makefile')
-rw-r--r--x11-toolkits/libXaw/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-toolkits/libXaw/Makefile b/x11-toolkits/libXaw/Makefile
new file mode 100644
index 000000000000..8d34727697e7
--- /dev/null
+++ b/x11-toolkits/libXaw/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libXaw
+# Date Created: 25 Jan, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXaw
+PORTVERSION= 7.0.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://pdx.freedesktop.org/~xlibs/release/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X Athena Widgets library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11 \
+ ${X11BASE}/libdata/pkgconfig/xt.pc:${PORTSDIR}/x11-toolkits/libXt \
+ ${X11BASE}/libdata/pkgconfig/xmu.pc:${PORTSDIR}/x11-toolkits/libXmu
+BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+INSTALLS_SHLIB= yes
+USE_GNOME= gnomehack pkgconfig
+
+.include <bsd.port.mk>